Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP CONFIGURATION FOR SWITCHES.

Hi,

I am having 2 access switches and two core switches how i can impliment HSRP in these switches. All are L3 switches with SFP module.Pls send the Configuration for HSRP.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Sham,

I don't know if Nagendra is present at the moment, so I answer your question here:

Core Switch 1:

conf t

interface vlan 1

ip address 192.168.1.1 255.255.255.0

no shutdown

standby 1 ip 192.168.1.10

standby 1 priority 200

standby 1 preempt

Core Switch 2:

conf t

interface vlan 1

ip address 192.168.1.2 255.255.255.0

no shutdown

standby 1 ip 192.168.1.10

This is probably one of the simplest configurations.

Note that ip addresses, vlan number and standby group number are imaginary. You should use your own values.

This will provide you a backup configuration, but only one HSRP router will be active at a time.

However, you can configure load balancing as well with a simmetrical configuration for standby group 2.

If you need this more complex load balancing config, please tell me and I will post it as well for you.

Cheers:

Istvan

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Sham,

The configuration I provided you makes Core Switch 1 as active and Core Switch 2 as standby by default.

This is done by setting the priority of Core Switch 1 to 200, which is higher than the default value of Core Switch 2 of 100.

HSRP will not update any routing configuration on the other router. You have to make modifications on the other router manually.

HSRP only does default gateway high availability and redundancy.

Here's the load balancing simmetrical config:

Core Switch 1:

conf t

interface vlan 1

standby 2 ip 192.168.1.20

Core Switch 2:

conf t

interface vlan 1

standby 2 ip 192.168.1.20

standby 2 priority 200

standby 2 preempt

You need to configure one half of the host PCs with default gateway address 192.168.1.10, the other half with default gateway address 192.168.1.20.

Cheers:

Istvan

12 REPLIES
Cisco Employee

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi,

Can you explain your topology?..

If all the switches are L3, you can better go for routing redundancy rather than HSRP.

Do you have any specific reason for HSRP in this L3 setup?.

Regards,

Nagendra

New Member

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Naikumar,

We are having totally 5 Access Switches.That is configured as 2 + 3 Stacking. And also 2 Core switches. In core Switches one is used for redundency. so HSRP is implimenting in between these core switches.pls forward the configurations for doing this. Thanks for your replay

Regards,

Sham.

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Sham,

I don't know if Nagendra is present at the moment, so I answer your question here:

Core Switch 1:

conf t

interface vlan 1

ip address 192.168.1.1 255.255.255.0

no shutdown

standby 1 ip 192.168.1.10

standby 1 priority 200

standby 1 preempt

Core Switch 2:

conf t

interface vlan 1

ip address 192.168.1.2 255.255.255.0

no shutdown

standby 1 ip 192.168.1.10

This is probably one of the simplest configurations.

Note that ip addresses, vlan number and standby group number are imaginary. You should use your own values.

This will provide you a backup configuration, but only one HSRP router will be active at a time.

However, you can configure load balancing as well with a simmetrical configuration for standby group 2.

If you need this more complex load balancing config, please tell me and I will post it as well for you.

Cheers:

Istvan

New Member

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Istvan,

Thanks for your replay. Pls Send the load balancing configuration also.and how we can make one switch as standby mode.? If one is in standby if we make any configuration changes in active one it will automaticaly update the other switch or we want to manuely configure it?

Regards,

Sham.

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Sham,

The configuration I provided you makes Core Switch 1 as active and Core Switch 2 as standby by default.

This is done by setting the priority of Core Switch 1 to 200, which is higher than the default value of Core Switch 2 of 100.

HSRP will not update any routing configuration on the other router. You have to make modifications on the other router manually.

HSRP only does default gateway high availability and redundancy.

Here's the load balancing simmetrical config:

Core Switch 1:

conf t

interface vlan 1

standby 2 ip 192.168.1.20

Core Switch 2:

conf t

interface vlan 1

standby 2 ip 192.168.1.20

standby 2 priority 200

standby 2 preempt

You need to configure one half of the host PCs with default gateway address 192.168.1.10, the other half with default gateway address 192.168.1.20.

Cheers:

Istvan

New Member

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi,

Here we are oppening one another Standby mode is it? For Hsrp we give standby 1 and for load balancing we are giving stand by 2.

for Hsrp the switch 1 is acting as primary.

in loadbalancing switch 2 will act as primary am i correct?because you give priority for the second switch.Please Clarify this doubt.

Thanks & Regards

Sham.

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Sham,

This is correct.

For standby group 2 switch 2 will be active and switch 1 will be in standby mode.

This way both switches are active for different groups, and both switches will forward traffic for a group of host PCs.

Cheers:

Istvan

New Member

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Istvan,

Thanks for your replay.

Regards,

Sham.

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Sham,

You're welcome, and thank you for the excellent rates.

Cheers:

Istvan

New Member

Re: HSRP CONFIGURATION FOR SWITCHES.

Hi Istvan,

I just checking the posted message.i hv some confusion and like to clarify with u.

I have 2 No.of Cisco 3750 Switches.6 No. of 2960 Switches.I hv one VLAN for office and one vlan for production unit. Production vLAN should be active on Core-2 and standby on Core-1 and Office should be active on Core -1 and standby on Core-2. I hv trunk b/w Core-1 and Core-2. Both Core have same config and have VLAN for both Office and production. All 2960 is connected to Core Switch- A through trunk right now. I m running VTP server on Core and VTP Client on Distribution switches.

NOw i want if my core -A goes down,or trunk from Distribution switch to Core-A goes down My office should be able to work through Core-B vice versa for production Network.

I hv two trunk port on Distribution Switches.

Do i need to connect one trunk of Distribution switch to Core-1 and second trunk of Dist. Switch to Core-B.

Please help me i m in urgent need for solution.

New Member

Re: HSRP CONFIGURATION FOR SWITCHES.

Please find the Diagram for More clear picture

New Member

Re: HSRP CONFIGURATION FOR SWITCHES.

Rahul,

Connecting distribution switches to both core switches will make the perfect load balancing in case one of the switches goes down. So connect all distribution switches trunk two to the second core switch.

For HSRP implementation use two HSRP groups, make one for each one VLAN active and other standby and do the same on other core switch with reversing the VLAN for active and standby groups.

Hope this solves your problem. If you need any help in configuration then let me know

344
Views
0
Helpful
12
Replies