Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP Help

I have implemented HSRP on two 2811 routers one standby group is working on my LAN interfaces however, the WAN interfaces are not talking to each other, hence my link goes down because both routers go into active state. Also, on the other end of my wan interfaces they are connected to a portchannel group on a catalyst switch. I don't know what kind because it is administered by another company.

config snipet

routerA

interface GigabitEthernet0/0/0 (LAN)

ip address 172.29.0.1 255.255.240.0

no ip redirects

negotiation auto

standby 1 ip 172.29.1.1

standby 1 timers 5 15

standby 1 priority 120

standby 1 preempt

interface GigabitEthernet0/1/0 (WAN)

ip address 192.168.255.3 255.255.255.248

no ip redirects

negotiation auto

standby 2 ip 192.168.255.6

standby 2 timers 5 15

standby 2 priority 120

standby 2 preempt

RouterB

interface GigabitEthernet0/0/0 (LAN)

ip address 172.29.0.2 255.255.240.0

no ip redirects

negotiation auto

standby 1 ip 172.29.1.1

standby 1 timers 5 15

standby 1 priority 95

standby 1 preempt

interface GigabitEthernet0/1/0 (WAN)

ip address 192.168.255.4 255.255.255.248

no ip redirects

negotiation auto

standby 2 ip 192.168.255.6

standby 2 timers 5 15

standby 2 priority 95

standby 2 preempt

7 REPLIES
Hall of Fame Super Silver

Re: HSRP Help

Alan

Are the WAN interfaces in the same broadcast domain? When you do show cdp neighbors do they see each other as neighbors over the WAN interfaces? If not then HSRP will not work.

Also I am puzzled how the interfaces on your router which are treated as seperate independent routable interfaces can be connected to Etherchannel on the other end which bundles the links together in one logical layer 2 bundle. Perhaps you can clarify the topology for us.

HTH

Rick

New Member

Re: HSRP Help

Yes, both WAN interfaces are in the same broadcast domain. when I do a sh cdp neighbor, I see the other company's 3750G device on both routers.

However, if there is a better way to go about creating a redundant link, I will be interested in the better of the two options.

Hall of Fame Super Silver

Re: HSRP Help

Alan

I think that you misunderstood my question. I was not asking if your routers see the other company equipment as cdp neighbor, I was asking if your routers see each other as neighbors over the WAN interfaces.

I am not convinced that HSRP should be configured on the WAN interfaces. But since I do not know anything significant about your enironment or about your requirements I am not in a place to make suggestions about it. If you can explain a bit more about the environment and about what you are trying to accomplish then perhaps we can make suggestions about the best way to get what you need to work.

HTH

Rick

New Member

Re: HSRP Help

Sorry about that, The answer is no on the WAN interfaces. I cannot see either interface showing up in the list. I only see the interfaces on the LAN showing up.

Hall of Fame Super Silver

Re: HSRP Help

Alan

That demonstrates why HSRP was not working, and would not work (for HSRP both devices need to be in the same broadcast domain - show cdp neighbor is an easy way to check for same broadcast domain). I am still not clear what you are trying to accomplish, but it becomes increasingly clear that HSRP is not the right way to get there.

HTH

Rick

New Member

Re: HSRP Help

Thanks for your help. The end result I'm looking to accomplish is to have a redundant link. it can be standby or even load balancing. ether one will sufice in this arrangment. I have two diffrent paths of fiber connecting to the other company.

Hall of Fame Super Silver

Re: HSRP Help

Alan

There are several alternatives to consider when planning to establish redundancy. You can have redundancy at layer 3, which seems to be the direction that you are going with your separate interfaces, separate addressing, on separate routers. This could be accomplished with two static routes, with floating static routes, or with a dynamic routing protocol. Or you can plan redundancy at layer 2, which sounds like what the other end is doing if the connection is ether channel or port channel.

It seems to me that you need to get a clear understanding of what they are doing (or what they plan to do) on the other end of the connection and then plan the same kind of thing on your end. You can not do effective redundancy from just one end. Both ends must implement the same kind of things.

HTH

Rick

129
Views
0
Helpful
7
Replies