Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

HSRP Ignoring Coup message

I'm trying to track a WAN interface with HSRP.

Router HSRP config. is as follows.

Active Router(GW01)

-------------------

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 2.2.2.2 255.255.255.0

standby 1 ip 2.2.2.1

standby 1 priority 105

standby 1 preempt delay minimum 60

standby 1 track Serial0/0

Standby Router(GW02)

--------------------

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 2.2.2.3 255.255.255.0

standby 1 ip

standby 1 preempt

-----------------

Active router sends a lower priority (95) as soon as it tracks the failure of the WAN interface.

I see the following HSRP debug messages(debug standby on Active router) saying that the coup was ignored.

GW01: Sep 1 15:04:31: HSRP: Fa0/0.20 Grp 1 Hello out 2.2.2.2 Active pri 95 vIP 2.2.2.1

GW01: Sep 1 15:04:31: HSRP: Fa0/0.20 Grp 1 Coup in 2.2.2.3 Standby pri 100 vIP 2.2.2.1

GW01: Sep 1 15:04:31: HSRP: Fa0/0.20 Grp 1 Ignoring Coup (100/2.2.2.3 < 105/2.2.2.2)

What does this actually mean and why does it happen?

Many thanks for sharing your ideas and experiences.

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: HSRP Ignoring Coup message

Yes, the switchover will happen regardless.

The lower pri active will see a hello from the higher pri standby and will resign.

Unfortunately I'm not really in a position to recommend any particular image for you.

Rgds,

Ian

8 REPLIES
Hall of Fame Super Silver

Re: HSRP Ignoring Coup message

Hello Ranil,

I would try to remove standby 1 preempt delay minimum 60 and then to repeat the test.

It is the only command that can change the behaviuor.

the router is saying that is own priority is 105 like as tracking hasn't been in effect.

Hope to help

Giuseppe

Community Member

Re: HSRP Ignoring Coup message

Hi Giuseppe,

A delayed preemption is applied only in the course of reactivation of the original WAN link. However, I see this message during the failure of the active side WAN link.

Is this the expected behavior to ignore the initial coup?

I checked the RFC to see whether there's anything specific with regard to 'ignored coups'. However couldn't find anything related.

Community Member

Re: HSRP Ignoring Coup message

The Coup is being ignored because the router seems to still think that its priority is 105, which is higher than the priority in the Coup packet.

The (100/2.2.2.3 < 105/2.2.2.2) part is the comparison that HSRP is doing. It is comparing priority and IP address of the two routers.

What image is this?

Ian

Community Member

Re: HSRP Ignoring Coup message

Hi Ian,

It's c1841-spservicesk9-mz.124-7d.bin.

Community Member

Re: HSRP Ignoring Coup message

Thanks Ian for giving me clear directions.

Bug Ref: CSCsm35794 includes 12.4(7d) as an affected version.

What is the recommended Image(128/32) to go for in order to tackle the issue?

Community Member

Re: HSRP Ignoring Coup message

Hi,

This is a bug. It was fixed in 12.4(20)

Ian

Community Member

Re: HSRP Ignoring Coup message

Ian,

I have only 128/32 of memory. Would you recommend c1841-spservicesk9-mz.124-21.bin ?

My next question is about the severity? It says this has a moderate severity.

What is the real impact on the switchover process? Is it delayed?

From what I can see the switchover process(Standby -> Active) takes place even with this ignoring coup notification.

Thanks,

Community Member

Re: HSRP Ignoring Coup message

Yes, the switchover will happen regardless.

The lower pri active will see a hello from the higher pri standby and will resign.

Unfortunately I'm not really in a position to recommend any particular image for you.

Rgds,

Ian

1075
Views
5
Helpful
8
Replies
CreatePlease to create content