Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP ISSUE

Hi Guys,

Requesting for your assistance. I have a issue with HSRP. Despite having R1 Priority lower than R2. R1 does not become the standby router. 

Below is show outputs.  The flash i am using is c880data-universalk9-mz.150-1.M5.bin. Probably a IOS bug?

R1

show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Fa4.846 1 150 P Init unknown unknown 202.151.24.124
Fa4.4091 255 150 P Init unknown unknown 10.150.194.51
Vl10 1 95 P Active local 10.10.0.2 10.10.0.1
Vl20 2 85 P Active local 10.20.0.2 10.20.0.1
Vl30 3 85 P Active local 10.30.0.2 10.30.0.1
Vl100 4 85 P Active local 10.100.0.2 10.100.0.1

R2

Interface Grp Pri P State Active Standby Virtual IP
Fa4.846 1 100 P Active local unknown 202.151.24.124
Fa4.4091 255 100 Active local unknown 10.150.194.51
Vl10 1 100 Standby 10.10.0.3 local 10.10.0.1
Vl20 2 100 Standby 10.20.0.3 local 10.20.0.1
Vl30 3 100 Standby 10.30.0.3 local 10.30.0.1
Vl100 4 100 Standby 10.100.0.3 local 10.100.0.1

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Your configuration of R1

Your configuration of R1 shows a priority of 105 but you are tracking an interface and the output of "sh standby brief" shows a priority of 95.

So do you mean R1 is still active when the tracked interface goes down ?

If so this is because you have not configured preempt on R2 and without that R2 will not take over even with a higher priority.

Jon

6 REPLIES
VIP Purple

hi

hi

are these directly connected router to router interfaces or through a layer 2 switch ?

can you post the running config of the hsrp off each router please and if there is a switch involved make sure there is no acl blocking hsrp multicast address and that stp is not blocking at layer 2 in the path the failover takes

New Member

Hi Mark,

Hi Mark,

They are connected via  a layer 2 switch. There are acl in layer 2 switch

R1 config

interface Vlan10
ip address 10.10.0.3 255.255.255.0
ip nat inside
ip virtual-reassembly
standby 1 ip 10.10.0.1
standby 1 priority 105
standby 1 preempt delay reload 60 sync 15
standby 1 name test
standby 1 track 1 decrement 10

#show standby brief
P indicates configured to preempt.

R1
Interface Grp Pri P State Active Standby Virtual IP
Fa4.846 1 150 P Init unknown unknown 202.151.24.124
Fa4.4091 255 150 P Init unknown unknown 10.150.194.51
Vl10 1 95 P Active local 10.10.0.2 10.10.0.1
Vl20 2 85 P Active local 10.20.0.2 10.20.0.1
Vl30 3 85 P Active local 10.30.0.2 10.30.0.1
Vl100 4 85 P Active local 10.100.0.2 10.100.0.1

R2 Config 

interface Vlan10
ip address 10.10.0.2 255.255.255.0
ip nat inside
ip virtual-reassembly
standby 1 ip 10.10.0.1
standby 1 name test

R2

show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Fa4.846 1 100 P Active local unknown 202.151.24.124
Fa4.4091 255 100 Active local unknown 10.150.194.51
Vl10 1 100 Standby 10.10.0.3 local 10.10.0.1
Vl20 2 100 Standby 10.20.0.3 local 10.20.0.1
Vl30 3 100 Standby 10.30.0.3 local 10.30.0.1
Vl100 4 100 Standby 10.100.0.3 local 10.100.0.1

VIP Purple

Hi

Hi

There are acl in layer 2 switch

what is the acl in place doing ?

Is there only 1 layer 2 switch connected to each router 1 link  ?

is it Vlan 10 that's not working as it looks correct , Router 1 is currently active and router 1 is standby ?

Vl10 1 95 P Active local 10.10.0.2 10.10.0.1

Vl10 1 100 Standby 10.10.0.3 local 10.10.0.1

New Member

Hi , Issue was on preempt

Hi ,

Issue was on preempt

Hall of Fame Super Blue

Your configuration of R1

Your configuration of R1 shows a priority of 105 but you are tracking an interface and the output of "sh standby brief" shows a priority of 95.

So do you mean R1 is still active when the tracked interface goes down ?

If so this is because you have not configured preempt on R2 and without that R2 will not take over even with a higher priority.

Jon

New Member

thanks John. yes preempt was

thanks John. yes preempt was the issue.

3
Views
0
Helpful
6
Replies