Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

HSRP issue

I have 2620 and 3620 configured as HSRP group which have 64k serial link conected to other side router repectively. It seems the operation is ok as if 2620 serial link down, 3620 serial link will be take effect as back up link. One problem is if 2620 Wan link resume. then I need to wait ~1 min to see the traffic go through 3620 change over to 2620 serial again. I think the time is quick long. Can I make it shorter ?

Router 2620

interface Ethernet0/0

description LAN

ip address 10.1.1.1 255.255.255.0

half-duplex

standby 20 ip 10.1.1.3

standby 20 priority 110

standby 20 preempt

standby 20 track Serial0/0

!

interface Serial0/0

description to 1605

ip address 172.20.1.2 255.255.255.252

no fair-queue

!

interface Ethernet0/1

no ip address

shutdown

half-duplex

!

router ospf 1

log-adjacency-changes

network 10.1.1.0 0.0.0.255 area 0

network 172.20.1.0 0.0.0.3 area 0

Router 3620

interface Ethernet1/0

ip address 10.1.1.2 255.255.255.0

no ip redirects

no ip directed-broadcast

standby 20 priority 90 preempt

standby 20 ip 10.1.1.3

standby 20 track Serial1/0

!

interface Serial1/0

ip address 172.20.1.6 255.255.255.252

no ip directed-broadcast

no ip mroute-cache

no fair-queue

!

router ospf 1

network 10.1.1.0 0.0.0.255 area 0

network 172.20.1.4 0.0.0.3 area 0

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Bronze

Re: HSRP issue

Your problem is not HSRP, it's OSPF. OSPF needs time to converge and depending on the OSPF network type, it can take that long. What type of OSPF network are you running between sites ?

You don't want to failover to a router that has no external routes right away so HSRP is helping you on this delay. You can also alter the HSRP timers but I suggest you deal with the routing protocol timers first.

Re: HSRP issue

Friend,

Try modifying the standby priority of the 3620 router to 105.

standby 20 priority 105 or use

standby 20 track Serial0/0 25

Since you are tracking the serial interface and if it goes down, by default HSRP priority will be reduced by 10 and will still remain the Active Peer and depends on the routing protocol for the traffic reroute

Also as edison said, check the network type of your serial interfaces and try to tune the timers accordingly

HTH, rate if it does

Narayan

2 REPLIES
Hall of Fame Super Bronze

Re: HSRP issue

Your problem is not HSRP, it's OSPF. OSPF needs time to converge and depending on the OSPF network type, it can take that long. What type of OSPF network are you running between sites ?

You don't want to failover to a router that has no external routes right away so HSRP is helping you on this delay. You can also alter the HSRP timers but I suggest you deal with the routing protocol timers first.

Re: HSRP issue

Friend,

Try modifying the standby priority of the 3620 router to 105.

standby 20 priority 105 or use

standby 20 track Serial0/0 25

Since you are tracking the serial interface and if it goes down, by default HSRP priority will be reduced by 10 and will still remain the Active Peer and depends on the routing protocol for the traffic reroute

Also as edison said, check the network type of your serial interfaces and try to tune the timers accordingly

HTH, rate if it does

Narayan

123
Views
0
Helpful
2
Replies
CreatePlease to create content