Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP not working between 2911 ISR's

I'm trying to configure HSRP on a pair of 2911 routers with Etherswitches and am having difficulties getting it working. 

The symptoms are the following:

  • HSRP shows as ACTIVE on both routers
  • Trunk appears to be working as I can ping devices connected to ports on the Etherswitch.
  • From each individual Etherswitch, able to ping the router interface port (GI0/0)

Below is a snippet of the configuration on both of the ISR devices.  Any help would greatly be appreciated.

2911 #1

interface GigabitEthernet0/0

  ip address 192.168.10.11 255.255.255.0

standby 1 ip 192.168.10.1

standby 1 preempt

standby 1 priority 110

interface GigabitEthernet1/0

  ip address 10.10.10.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 10.10.10.3

2911 #1 integrated Etherswitch

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

interface GigabitEthernet0/26

  ip address 10.10.10.3 255.255.255.0

ip route 0.0.0.0 0.0.0.0 10.10.10.1

2911 #2

interface GigabitEthernet0/0

  ip address 192.168.10.12 255.255.255.0

standby 1 ip 192.168.10.1

interface GigabitEthernet1/0

  ip address 10.10.10.2 255.255.255.0

ip route 0.0.0.0 0.0.0.0 10.10.10.4

2911 #2 integrated Etherswitch

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

interface GigabitEthernet0/26

  ip address 10.10.10.4 255.255.255.0

ip route 0.0.0.0 0.0.0.0 10.10.10.2

9 REPLIES
Silver

HSRP not working between 2911 ISR's

Hi David,

Please, can you provide us diagram of the network? Or at least, please give us information of how precisely ( which ports are connected and where ) are these Routers interconnected.

Thank you very much!

Best regards,

Jan

New Member

HSRP not working between 2911 ISR's

Hi david ,

As i understood from your config that you have Two isp  line connecting via Etherswitch port no 26. however what is your  connectivity for LAN where Both router LAN interface should be connect  to it.. I hope you should connect a L2 switch between both router for  LAN connection and your LAN users Gateway would be your standby ip  address as in your case it is 192.168.10.1..

:-)

Thanks

New Member

HSRP not working between 2911 ISR's

I'm still having issues with connectivity.  I have connectivity between the 2911 and the intergrated switch via port gi1/0 on the 2911 and gi0/26 on the integrated switch.

Both integrated switches are connected via Trunk on gi0/5.

I can see between the switches without any issues but the router ports don't see each other.

New Member

HSRP not working between 2911 ISR's

here's a simple diagram of how this looks

Silver

HSRP not working between 2911 ISR's

Hi David,

Correct me if I'm wrong but are the gi0/0 ports on the Routers connected through L2 switch? You NEED to have LAN connectivity, just like Gajendra pointed out.

This is the reason why I asked for the topology, I am thinking that these gi0/0 ports are not on the same LAN. Therefore, the Routers doesn't see each other directly and HSRP is in Active state on both of them. You see, in order to HSRP work, Routers need to able to exchange messages via "switching" means (L2) and not L3 means (not via packet routing).

One more question, just to clarify that this is the case - what is on the other side of gi0/0?

Best regards,

Jan

New Member

HSRP not working between 2911 ISR's

Hi Jan,

Thanks for such fast responses.  Maybe I'm completely not understanding my setup but isn't that what the EtherSwitches are for?  I have the EtherSwitches trunk'd together which should be conneting the gi0/0 ports on the routers together?

The other side of the gi0/0 is an external redundant network made up of various field devices.

HSRP not working between 2911 ISR's

Hi David, that is not the case, those routed ports are independent of the switch card in the router. In order for your setup to work then both interfaces (G0/0) would need to be connected to the same physical switch or in the correct VLAN if multiple switches are used. It is just like Jan explained earlier.

Silver

HSRP not working between 2911 ISR's

Hi David,

as I thought, the problem is that you do not have LAN connectivity here.

The etherswitch module is not there for some "interconnection" of the other router's ports. It is there to provide a "switch" so that you don't have to buy another device and use some of the switch's advantages. But don't expect the routed ports (for example gi0/0) to send traffic via etherswitch, if they are not interconnected.

In addition, HSRP belongs to the First Hop Redundancy Protocol family. Like its name, the FHRP protocols are there to provide hosts on LAN with additional (redundant) gateway (first hop). So you need to configure it towards your hosts in your LAN and not to some other network.

Best regards,

Jan

New Member

HSRP not working between 2911 ISR's

Hi David,

Assuming from your diagram that G1/0 on each 2911 ISR connects to G0/26 on the Etherswitch then what you could do is set HSRP on interface G1/0 and set it to track interface G0/0 assuming that you want the failover to occur if that interface drops.

For Example:

R1

int G1/0

standby 1 ip 10.10.10.3

standby 1 preempt

standby 1 priority 110

standby 1 track G0/0

R2

standby 1 ip 10.10.10.3

The standby IP would have to be adjusted to ensure you don't have any IP conflicts.

1168
Views
0
Helpful
9
Replies