Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP not working

Hi,

I have configured two sub interface inorder to setup 2 DHCP in a router and HSRP between two routers,

HSRP is working for .10 and but not the .71, Config is pasted below for further reference.

Out puts of both router's and config is attahched please refer the same

9 REPLIES
New Member

Re: HSRP not working

Can you please upload the network diagram? How did you interconnect the 2 routers? Is there any switch in between?

It seems that you have 2 VLANs, vlan 10 and 71.

Re: HSRP not working

Hi

In "show standby" output the group is duplicate.

Have you added one more group with same group id 1 under interface fastethernet 0/1 ??

Maybe that is causing problem.

HSRP Group ID should be unique.

HTH...rate if helpful..

New Member

Re: HSRP not working

I assume that you have a switch between 2 routers

You should do this:

Proposed config on B1 router

New config for LAN - Data and WIFI

===================================

interface FastEthernet0/0

no shutdown

!

interface FastEthernet0/0.10

description #### DATA ####

encapsulation dot1Q 10

ip address 172.24.3.7 255.255.255.0

standby 0 ip 172.24.3.1

standby 0 preempt

standby 0 priority 150

!

interface FastEthernet0/0.71

description #### WIFI ####

encapsulation dot1Q 71

ip address 172.24.71.7 255.255.255.0

standby 1 ip 172.24.71.1

standby 1 preempt

standby 1 priority 150

Proposed config on B2 router

New config for LAN - Data and WIFI

===================================

interface G0/0

no shutdown

!

interface GigabitEthernet0/0.10

description #### DATA ####

encapsulation dot1Q 10

ip address 172.24.3.5 255.255.255.0

standby 0 ip 172.24.3.1

standby 0 preempt

standby 0 priority 140

!

interface FastEthernet0/0.71

description #### WIFI ####

encapsulation dot1Q 71

ip address 172.24.71.5 255.255.255.0

standby 1 ip 172.24.71.1

standby 1 preempt

standby 1 priority 140

Please rate it if it helps

New Member

Re: HSRP not working

Hi,

thanks for your reply but wondering . why no shutdown is require in the Fa0/0 and G0/0 as this are in use now.

New Member

Re: HSRP not working

That's ok if it is already in use.

Hall of Fame Super Silver

Re: HSRP not working

Hello UCB,

before your router FE interfaces had ip addresses on the physical interfaces : now you want to use 802.1Q subinterfaces.

In order to that the switch ports must be configured as trunk ports with 802.1Q encapsulation and allowing vlan 10,71.

Remember also to declare the vlan 10 as native

Example of cfg on switch side:

int g0/15

switchport

switchport trunk enc dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,71

to find out what is the switch port

do

sh cdp n f0/0

There is no communication in vlan 71 between the two routers this means they are not sharing a broadcast domain

Hope to help

Giuseppe

New Member

Re: HSRP not working

thank you so much for your help

New Member

Re: HSRP not working

Hi,

The reason for your issue is shown in the output for router B1, you have a duplicate for HSRP group 1. Now that you have moved the subnet 172.24.3.0/24 from fa0/0 to subinterface fa0/0.10 you should remove the ip address and standby ip from fa0/0, i.e.

interface FastEthernet0/0

no ip address 172.24.3.7 255.255.255.0

no standby ip 172.24.3.1

Although no specific standby group was associated with fa0/0 it has used group 1 as default, and this has conflicted with your new group 1 defined for subinterface fa0/0.71

Hope this helps

Don

Hall of Fame Super Silver

Re: HSRP not working

Hello Don,

from sh standby you can see the third HSRP group is number 1 but out f0/1 not f0/0.

I had the same doubt but it is not possible to have overlapping ip addresses on LAN interfaces you get an error on the router if you try to do this.

However, it is possible that physical interface config still needs to be cleaned from the standby command but without ip address on main interface.

Hope to help

Giuseppe

332
Views
4
Helpful
9
Replies