Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

HSRP OR STP PROBLEM?

whats wrong with the below configuration. With only either the infrared or wireless is connected, theres no problem at all..once both are connected, then leds on port 25 and 26 on the moon switch will start to blink so fast and lost the connectivity from the core to the moon.

CORE SWITCH 1

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree vlan 2,10,12,14,16,216 priority 8192

spanning-tree vlan 11,13,15,100 priority 12288

interface GigabitEthernet1/44

description INFRARED TO the moon

no ip address

switchport

switchport access vlan 216

switchport mode access

interface Vlan216

ip address 172.20.254.202 255.255.255.248

standby 216 ip 172.20.254.201

standby 216 priority 115

standby 216 preempt

standby 216 track GigabitEthernet1/44 20

CORE SWITCH 2

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree vlan 2,10,12,14,16,216 priority 12288

spanning-tree vlan 11,13,15,100 priority 8192

interface Vlan216

ip address 172.20.254.203 255.255.255.248

standby 216 ip 172.20.254.201

standby 216 priority 105

standby 216 preempt

interface GigabitEthernet1/44

description Wireless connection to the moon

no ip address

switchport

switchport access vlan 216

switchport mode access

MOON

spanning-tree vlan 24-25,27,200,215-216 priority 24576

interface GigabitEthernet0/25

description Infrared Link Connected to

core SW1

switchport access vlan 216

switchport mode access

!

interface GigabitEthernet0/26

description Wireless Link Connected to

core SW2

switchport access vlan 216

switchport mode access

4 REPLIES

Re: HSRP OR STP PROBLEM?

Hi

As per u r configs the core 1 seems to be the root switch for u r 216 vlan and core the secondry.As STP will be in picture u r gig0/25 on moon will be blocked.

U didnt show how u r core switches are connected with each other.This might give us some insight.

Thanks

Mahmood

Community Member

Re: HSRP OR STP PROBLEM?

isnt it port 26 should be blocked coz stp priority on vlan216 on core 1 is lower than the priority on core 2.

theres a layer 3 connectivity between the core as well as trunked layer 2.

Re: HSRP OR STP PROBLEM?

Hi,

which STP mode is the MOON switch running?

It looks like some RSTP+/STP compatibility problem.

See http://www.cisco.com/application/pdf/en/us/guest/tech/tk621/c1501/ccmigration_09186a0080174993.pdf

BR,

Milan

Community Member

Re: HSRP OR STP PROBLEM?

it is on rpvst

133
Views
0
Helpful
4
Replies
CreatePlease to create content