Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP problem -

I am having an issue where the standby router is not becoming active even though it has a higher priority. Details below

Setup

Router 1 - Primary

2911 - 15.1(4)M4

interface GigabitEthernet0/0.30

encapsulation dot1Q 2 native

ip address 10.1.30.171 255.255.255.0

standby 30 ip 10.1.30.1

standby 30 priority 105

standby 30 preempt

standby 30 track 1 decrement 10

track 1 ip route 172.16.255.1 255.255.255.255 reachability

Router 2

871 - 12.4(24)T7

interface Vlan2

description  data vlan

ip address 10.1.30.172 255.255.255.0

standby 30 ip 10.1.30.1

For testing I simulate a WAN failure and receive the correct notification

%TRACKING-5-STATE: 1 ip route 172.16.255.1/32 reachability Up->Down

Here is the output from show standby on both routers. They recognize the tracked object is down and the primary is decremented to 95 but is still active, and the standby is 100

GigabitEthernet0/0.30 - Group 30

  State is Active

    12 state changes, last state change 5d00h

  Virtual IP address is 10.1.30.1

  Active virtual MAC address is 0000.0c07.ac1e

    Local virtual MAC address is 0000.0c07.ac1e (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 2.800 secs

  Preemption enabled

  Active router is local

  Standby router is 10.1.30.172, priority 100 (expires in 9.904 sec)

Priority 95 (configured 105)

    Track object 1 state Down decrement 10

  Group name is "hsrp-Gi0/0.30-30" (default)

Vlan2 - Group 30

  State is Standby

    4 state changes, last state change 5d00h

  Virtual IP address is 10.1.30.1

  Active virtual MAC address is 0000.0c07.ac1e

    Local virtual MAC address is 0000.0c07.ac1e (v1 default)

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.824 secs

  Preemption disabled

  Active router is 10.1.30.171, priority 95 (expires in 11.552 sec)

  Standby router is local

  Priority 100 (default 100)

  Group name is "hsrp-Vl2-30" (default)

Any ideas ?

Thanks

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: HSRP problem -

Hi Gizbri,

Please enable preemption on Router 2 and send "sh standby brief" details with and without WAN failure simulation.

Thanks

Ameya

5 REPLIES
Bronze

Re: HSRP problem -

Hi Gizbri,

Please enable preemption on Router 2 and send "sh standby brief" details with and without WAN failure simulation.

Thanks

Ameya

New Member

Re: HSRP problem -

Hii,

Sorry for my misleading information previously.

Can you try decrementing it by 30 instead of 10 and check if it works...

HTH,

Sukanya

PS: Please rate helpful posts...

Message was edited by: sukanya chavan

New Member

Re: HSRP problem -

Hi Gizbri,

What happens when you set the same group name on both devices?

Regards,

Nate

VIP Purple

Re: HSRP problem -

HI Gizbari,

Router1(config)#interface GigabitEthernet0/0.30

Router1(config-if)#encapsulation dot1Q 2 native

Router1(config-if)#inter10.1.30.171 255.255.255.0

Router1(config-if)#standby 30 ip 10.1.30.1

Router1(config-if)#standby 30 priority 105

Router1(config-if)#standby 30 preempt

Router1(config-if)#standby 30 track .....

Router2(config)#interface vlan2

Router2(config-if)#10.1.30.172 255.255.255.0

Router2(config-if)#standby 30 ip 10.1.30.1

Router2(config-if)#standby 30 priority 101

Router2(config-if)#standby 30 preempt

Router2(config-if)#standby 30 track .....

according to your sh standby command ..I can see the preempt is disabled on router 2.

Can you please config  preempt on router 2 and just check the config as mine and then test it.

Regards

Please rate if it helps.

New Member

Re: HSRP problem -

Thanks Ameya and others. The preempt command on the other router is what I was missing. Tested and working

948
Views
0
Helpful
5
Replies
CreatePlease login to create content