Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

hsrp question

Hi,

I check the old router config in TW braches, it does not track the serial WAN status. According to the config, does it failover to R1 if the FE of R2 is down?

Moreover, what is the default setting which reduce the priority?

pls advance

rdgs

R1

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

speed 100

full-duplex

standby 1 ip 192.168.0.10

standby 1 priority 75

R2

interface FastEthernet0/0

ip address 192.168.0.2 255.255.255.0

speed 100

full-duplex

standby 1 ip 192.168.0.10

standby 1 priority 150

standby 1 preempt

!

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: hsrp question

Hi,

You're right R1 will become the active router if R2 looses its FE interface.

Priority will be decreased by 10 by default if you configure WAN tracking feature:

http://www.cisco.com/en/US/docs/ios/ipapp/command/reference/iap_s3.html#wp1062861

HTH

Laurent.

Super Bronze

Re: hsrp question

No, you don't need a new group, but you got the basic idea.

R1

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

speed 100

full-duplex

standby 1 ip 192.168.0.10

standby 1 priority 75

R2

interface FastEthernet0/0

ip address 192.168.0.2 255.255.255.0

speed 100

full-duplex

standby 1 ip 192.168.0.10

standby 1 priority 150

standby 1 preempt

!you'll need to decrement 76 (150 - 75 = 75) or more

standby 1 track interface S0/0 decrement 100

4 REPLIES
Cisco Employee

Re: hsrp question

Hi,

You're right R1 will become the active router if R2 looses its FE interface.

Priority will be decreased by 10 by default if you configure WAN tracking feature:

http://www.cisco.com/en/US/docs/ios/ipapp/command/reference/iap_s3.html#wp1062861

HTH

Laurent.

Super Bronze

Re: hsrp question

To expand a bit on the information Laurent provided, the default decrement wouldn't be sufficient, if used, because the priorities are configured and they're more than 10 apart in your post.

Tracking the WAN link, and moving the active gateway, might not be required for correct functioning, although it might be more traffic flow efficient in avoiding the need to transit the original gateway router.

PS:

If these routers in question are recent ISRs, you might have other virtual gateways options, such as MHSRP or GLBP to better take advantage of outbound WAN bandwidths.

Also, original interface tracking watched interface up/down, but some later interfaces stay up but the path is bad. There are newer methods to also track whether the path appears good vs. just the link.

New Member

Re: hsrp question

Hi,

So, the "reduce" value will not apply above config. the "reduce" value should be applied for "track" command only, should not it?

If I would like to monitor the FE interface and the WAN circuit, I should create two groups. One is for FE (the config is same as about); other is "trace" the WAN interface. the config should be below:

rdgs

R1

standby 2 ip 192.168.0.1

standby 2 priority 195

R2

standby 2 ip 192.168.0.1

standby 2 priority 200

standby 2 track interface S0/0 decrement 10

Super Bronze

Re: hsrp question

No, you don't need a new group, but you got the basic idea.

R1

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

speed 100

full-duplex

standby 1 ip 192.168.0.10

standby 1 priority 75

R2

interface FastEthernet0/0

ip address 192.168.0.2 255.255.255.0

speed 100

full-duplex

standby 1 ip 192.168.0.10

standby 1 priority 150

standby 1 preempt

!you'll need to decrement 76 (150 - 75 = 75) or more

standby 1 track interface S0/0 decrement 100

115
Views
0
Helpful
4
Replies
CreatePlease to create content