Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

HSRP track rtr state not working?

We have dual 2851's with 12.4(9)T1 on both ends over MPLS the inside sub-interfaces are configured with HSRP groups and track rtr state. We notice upon icmp failover that the rtr state changes to down and the priority decrements to 95 from 105. Below the standby which is at default at 100. But it doesnt failover? Any ideas?

RTR1

track 5 rtr 15

!

interface GigabitEthernet0/0

description INSIDE INTERFACE

no ip address

duplex full

speed 1000

!

interface GigabitEthernet0/0.2

description MANAGEMENT VLAN

encapsulation dot1Q 2

ip address 172.29.2.4 255.255.255.0

standby version 2

standby 2 ip 172.29.2.1

standby 2 priority 105

standby 2 preempt

standby 2 authentication md5 key-chain KEY

standby 2 name MANAGEMENT

standby 2 track 5 decrement 10

!

interface GigabitEthernet0/0.4

description VOIP VLAN

encapsulation dot1Q 4

ip address 172.29.4.4 255.255.255.0

standby version 2

standby 4 ip 172.29.4.1

standby 4 priority 105

standby 4 preempt

standby 4 authentication md5 key-chain KEY

standby 4 name VOIP

standby 4 track 5 decrement 10

service-policy input VOIP-IN

!

interface GigabitEthernet0/0.5

description LAN1 VLAN

encapsulation dot1Q 5

ip address 172.29.5.4 255.255.255.0

standby version 2

standby 5 ip 172.29.5.1

standby 5 priority 105

standby 5 preempt

standby 5 authentication md5 key-chain KEY

standby 5 name LAN1

standby 5 track 5 decrement 10

!

ip sla 15

icmp-echo 172.24.70.11 source-ip 172.29.2.4

frequency 5

ip sla schedule 15 life forever start-time now

!

RTR2

track 5 rtr 15

!

interface GigabitEthernet0/0

description INSIDE INTERFACE

no ip address

duplex full

speed 1000

!

interface GigabitEthernet0/0.2

description MANAGEMENT VLAN

encapsulation dot1Q 2

ip address 172.29.2.6 255.255.255.0

standby version 2

standby 2 ip 172.29.2.1

standby 2 preempt

standby 2 authentication md5 key-chain KEY

standby 2 name MANAGEMENT

standby 2 track 5 decrement 10

!

interface GigabitEthernet0/0.4

description VOIP VLAN

encapsulation dot1Q 4

ip address 172.29.4.6 255.255.255.0

standby version 2

standby 4 ip 172.29.4.1

standby 4 preempt

standby 4 authentication md5 key-chain KEY

standby 4 name VOIP

standby 4 track 5 decrement 10

service-policy input VOIP-IN

!

interface GigabitEthernet0/0.5

description LAN1 VLAN

encapsulation dot1Q 5

ip address 172.29.5.6 255.255.255.0

standby version 2

standby 5 ip 172.29.5.1

standby 5 preempt

standby 5 authentication md5 key-chain KEY

standby 5 name LAN1

standby 5 track 5 decrement 10

!

ip sla 15

icmp-echo 172.24.70.12 source-ip 172.29.2.6

frequency 5

ip sla schedule 15 life forever start-time now

!

6 REPLIES

Re: HSRP track rtr state not working?

Can you post a sh standby from both the routers?

Also will it be possible to run a debug standby and shut down a link to get some log events

Narayan

Hall of Fame Super Bronze

Re: HSRP track rtr state not working?

Both HSRPs are tracking the same SLA and they are both decrementing 10. As you reported when the track reports down, the HSRP with priority 105 goes down to 95 but the 'standby failover' also decrements from 100 to 90 since it has the same track.

If you want the standby failover to take over with priority 100, you must remove the track from RTR2's interfaces.

Community Member

Re: HSRP track rtr state not working?

Thx Edison! They appear identical, but they are using different source/dest IP's. Upon failover the HSRP standby router indicates tracking Up state and priority 100. But still no failover between the two. Thanks for the help though, anything else I could try?

Re: HSRP track rtr state not working?

What does the 'show standby' status on RTR1 show as the local priority and the RTR2's (standby router) priority when the RTR1's tracked object is down? Or can you post the output of show standby from RTR1 when it's tracked object is down.

HTH

Sundar

Hall of Fame Super Bronze

Re: HSRP track rtr state not working?

Have you verified the authentication between the HSRP routers is working correctly ?

Let us see the 'show stand' output from each device.

Community Member

Re: HSRP track rtr state not working?

Just for kicks, I tried changing the HSRP versions back to 1 and surprisingly it worked like a charm. Very strange, thx guys for all your help!

772
Views
0
Helpful
6
Replies
CreatePlease to create content