Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP with 2 x 877 routers and Cisco switch

Hi, I'm trying to setup HSRP on two C877 routers. Fo some reason advertisements / helo packets are not going from one router to the other. I have Cisco switch (C2960) in between and I was wondering If I need to set up something on this switch?

My configuration:

R1:

interface Vlan1

ip address 192.168.10.254 255.255.255.0

ip access-group V1-IN in

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

standby delay minimum 10 reload 120

standby version 2

standby 1 ip 192.168.10.250

standby 1 timers 5 15

standby 1 priority 10

standby 1 preempt delay minimum 5 reload 30 sync 10

standby 1 name GROUP1

standby 1 track ATM0

R2:

interface Vlan1

ip address 192.168.10.253 255.255.255.0

ip access-group V1-IN in

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

standby delay minimum 10 reload 120

standby version 2

standby 1 ip 192.168.10.250

standby 1 timers 5 15

standby 1 priority 5

standby 1 preempt delay minimum 5 reload 30 sync 10

standby 1 name GROUP1

standby 1 track 1 decrement 10

Switch:

interface Vlan1

ip address 192.168.10.234 255.255.255.0

no ip route-cache

Debug: (debug standby pack all)

R1:

Jun 25 11:57:14.589: HSRP: Vl1 Grp 1 Hello  out 192.168.10.254 Active  pri 10 vIP 192.168.10.250

Jun 25 11:57:19.330: HSRP: Vl1 Grp 1 Hello  out 192.168.10.254 Active  pri 10 vIP 192.168.10.250

Jun 25 11:57:24.079: HSRP: Vl1 Grp 1 Hello  out 192.168.10.254 Active  pri 10 vIP 192.168.10.250

Jun 25 11:57:28.407: HSRP: Vl1 Grp 1 Hello  out 192.168.10.254 Active  pri 10 vIP 192.168.10.250

Jun 25 11:57:33.176: HSRP: Vl1 Grp 1 Hello  out 192.168.10.254 Active  pri 10 vIP 192.168.10.250

Jun 25 11:57:37.336: HSRP: Vl1 Grp 1 Hello  out 192.168.10.254 Active  pri 10 vIP 192.168.10.250

R2:

Jun 25 11:58:11.536: HSRP: Vl1 Grp 1 Hello  out 192.168.10.253 Active  pri 5 vIP 192.168.10.250

Jun 25 11:58:15.893: HSRP: Vl1 Grp 1 Hello  out 192.168.10.253 Active  pri 5 vIP 192.168.10.250

Jun 25 11:58:20.602: HSRP: Vl1 Grp 1 Hello  out 192.168.10.253 Active  pri 5 vIP 192.168.10.250

Jun 25 11:58:25.230: HSRP: Vl1 Grp 1 Hello  out 192.168.10.253 Active  pri 5 vIP 192.168.10.250

I can communicate between both routers (using ping or ssh) and CDP is showing neighbours correctly.

Any idea why it's not working correctly?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

HSRP with 2 x 877 routers and Cisco switch

You have access-lists on your VLANs. Are you allowing the HSRP-Packets there? HSRPv2 uses the destination-address 224.0.0.102 (instead of 224.0.0.2 which was used by HSRPv1) with port 1985.


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
3 REPLIES
Hall of Fame Super Silver

Re: HSRP with 2 x 877 routers and Cisco switch

Hello Pawel,

in order to have the two routers to exchange HSRP hello packets the switch has to work at OSI layer2 not OSI layer3 as a router for vlan1.

Try after having shutdown SVI vlan1 on the LAN switch C2960, in this way the C2960 will act as an OSI L2 switch.

Edit:

Karsten is on spot here look at the ACL applied inbound

Hope to help

Giuseppe

VIP Purple

HSRP with 2 x 877 routers and Cisco switch

You have access-lists on your VLANs. Are you allowing the HSRP-Packets there? HSRPv2 uses the destination-address 224.0.0.102 (instead of 224.0.0.2 which was used by HSRPv1) with port 1985.


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

HSRP with 2 x 877 routers and Cisco switch

ACL was blocking it. Manage to solve this problem. Thanks guys for your help.

479
Views
9
Helpful
3
Replies
CreatePlease to create content