Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

HTTP incoming traffic with two ISPs

Hi,

We have a cisco router 2821 and a Cisco ASA 5510 firewall.

Router's ADSL interfaces are connected to 2 different ISPs (ISPa - Dialer0 and ISPb - Dialer2).

From ISPb we have 8 public IP addresses. The first is configured on the routers G0/0, the second on the external interface of the ASA firewall. The other IPs are used on firewall rules in ASA firewall so to pass http and smtp traffic from outside to inside (web site and mail server are on LAN). The SMTP and HTTP incoming (from internet) traffic comes from ISPb connection.

We have configured Policy Based Routing on Cisco router so to pass the HTTP outgoing traffic from ISPa connection. All users HTTP requests go through ISPa connection and all other requests go through ISPb connection.

We have used the following commands to accomplish that:

Interface Dialer0

ip nat outside

Interface GigabitEthernet0/0

ip nat inside

route-map HTTP2Vivo permit 10
match ip address HTTP-REQ
set interface Dialer0

ip access-list extended HTTP-REQ
permit tcp any any eq www
permit udp any any eq domain
permit tcp any any eq domain

ip nat inside source route-map HTTP2Vivo interface Dialer0 overload

For load balancing and fault tolerance reasons, we want the incoming HTTP traffic to use both ISPs.

We are thinking of adding another A record to DNS that will point to the ISPa public IP connection.

What other steps do we have to take so to achieve this goal?

Thanks in advanced.

162
Views
0
Helpful
0
Replies
CreatePlease login to create content