Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HWIC-3G-GSM Module Configration Problem...need help urgent Thank

Dear Group members:-

   i am  trying to configure the 3G-module.i have inserted my sim card  into the  HWIC module sim card properly working in the phone and i am accessing  the internet.
but when i configure HWIC module accordingly i am unable to access the  internet my configration pasted below if any experience person guid me  little.


in my phone i just put APN and it work fine without Authentication Service provider ask me that the username and password is blank..   and no authentication.


country Libya
GSM service provider =Almadar
APN or access point name =almadar.net


Router#show cellular 0/1/0 profile
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = almadar.net
Authentication = None
Username: , Password:

* - Default profile

--------------------------------------------------------------------------------------
Router config:

!
!
!
multilink bundle-name authenticated
!
chat-script gsm "" "ATDT*99*1#" TIMEOUT 60 "CONNECT"
!
!
!
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface Wlan-GigabitEthernet0/0
  description Internal switch interface connecting to the embedded AP
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface wlan-ap0
description Service module interface to manage the embedded AP
  no ip address
arp timeout 0
no mop enabled
no mop sysid
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
shutdown
  no atm ilmi-keepalive
!
interface Cellular0/1/0
ip address negotiated
encapsulation ppp
dialer in-band
dialer idle-timeout 30
dialer string gsm
dialer-group 1
async mode interactive
ppp ipcp dns request
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
!
!
control-plane
!
!
line con 0
line aux 0
line 0/1/0
exec-timeout 0 0
script dialer gsm
login
modem InOut
no exec
speed 80000
line 67
no activation-character
no exec
  transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------------------------------------------------------------------


Router#show cellular 0/1/0 all
Hardware Information
====================
Modem Firmware Version = H1_1_9_3MCAP C:/WS/
Modem Firmware built = 12/12/07
Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) = 606010105114370
International Mobile Equipment Identity (IMEI) = 011359000487907
Factory Serial Number (FSN) = D28026013381043
Modem Status = Online
Current Modem Temperature = 26 deg C, State = Normal

Profile Information
====================

Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = almadar.net
Authentication = None
Username: , Password:

* - Default profile

Data Connection Information
===========================
Data Transmitted = 0 bytes, Received = 0 bytes
Profile 1, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 2, Packet Session Status = INACTIVE
         Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 5, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 6, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 7, Packet Session Status = INACTIVE
         Inactivity Reason = Normal inactivate state
Profile 8, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 9, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 10, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 11, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 12, Packet Session Status = INACTIVE
         Inactivity Reason = Normal inactivate state
Profile 13, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 14, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 15, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 16, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state

Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = GPRS (Attached)
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = 606, Network = 606 01
Mobile Country Code (MCC) = 606
Mobile Network Code (MNC) = 1
Location Area Code (LAC) = 1
Routing Area Code (RAC) = 1
Cell ID = 11071
Primary Scrambling Code = 0
PLMN Selection = Automatic
Registered PLMN = Libya Al Madar , Abbreviated = 606 01
Service Provider = 606 01

Radio Information
=================
Current Band = GSM 900, Channel Number = 5
Current RSSI = -62 dBm
Band Selected = Auto

Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3


Thanks
----------------------------------------------------------------------------------------------------


Router#ping 69.147.125.65

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 69.147.125.65, timeout is 2 seconds:
.
*Oct 30 13:05:36.599: %LINK-3-UPDOWN: Interface Cellular0/1/0, changed state to
up.
*Oct 30 13:05:38.639: %LINK-5-CHANGED: Interface Cellular0/1/0, changed state to
reset...
Success rate is 0 percent (0/5)
Router#
*Oct 30 13:05:43.663: %LINK-3-UPDOWN: Interface Cellular0/1/0, changed state to
down
2 REPLIES
New Member

Re: HWIC-3G-GSM Module Configration Problem...need help urgent T

You have missed the Dialer interface...  the Cell0/1/0 interface needs to be looked like a modem...  so you need a dialer interface.  I also noticed in your Chat-script up i have ATDT*99, were I use 98, not sure if that maters or not.

Now you carrier might register your SIM to the SN, or (EIME, MEIE, IEME whatever it is) so the SIM might not come up on the network when switching it to a differant hardware for data traffic.  I have this issue with AT&T often.

Anyway here is a config similar to yours that I use often:


multilink bundle-name authenticated
!
chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT"
!

!
interface Cellular0/1/0
no ip address
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer pool-member 1
dialer-group 1
no peer default ip address
async mode interactive
ppp chap hostname ISP@CINGULARGPRS.COM
ppp chap password 7 15312222231F07051A62
ppp ipcp dns request
fair-queue 64 16 0
!
!
interface Dialer1
ip address negotiated
ip access-group 120 in
ip nbar protocol-discovery
ip nat outside
ip nat enable
ip virtual-reassembly
dialer pool 1
dialer idle-timeout 0
dialer string gsm
dialer persistent
dialer-group 1
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
control-plane
!
!
!
line con 0
login local
line aux 0
line 0/1/0
exec-timeout 0 0
script dialer gsm
login
modem InOut
no exec
transport input all
rxspeed 3600000
txspeed 384000
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1

As you can see you default to the dialer interface not the cell interface.  the Dialer acts as the middle man determining when the cell should make the connection and when not.  As you see I have mine set to be up all the time with the "Dialer persistent" cammand.  if using this as a back up data connection you will want to use on demand dialing with a acl....  keeping the connection up all the time even not passing traffic, just in a idle state, will take you over you contracted 5Gig bandwidth.  It is not realy unlimited data, so read the fine print.  I think Sprint has a true unlimited plan for this use, but the odds of having service is about as commen as everyone having a lake front home...

Good luck..

Dave

P.S.  I just noticed you are not using US cell service so just ignore my carrier specific comments...  use your APN not what I have listed...

Silver

Re: HWIC-3G-GSM Module Configration Problem...need help urgent T

Hi,

the cellular interface works already as a dialer interface.

You can configure a dialer interface over it for specific requirements, but for a normal setup this is not required.

Can you please enable:

debug chat

debug dialer

debug ppp nego

Then start a ping traffic that will raise the cellular interface, and collect the logs.

I've seen sometimes that even if the ISP does not require authentication, we need to configure dummy username/password to succeed.

I'd suggest you try this:

1. capture the debugs with the current config

2. change the profile to add authentication chap and username/password guest

3. change the cellular configure to add "ppp chap hostname guest" and "ppp chap password guest"

4. collect the debugs again.

Cheers

Marco

1413
Views
0
Helpful
2
Replies