Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

HWIC-3G-GSM no traffic

Hi

I have configured cisco HWIC-3G-GSM router cellular and Dialer0 interfaces.

The WWAN LED is green solid (active, no traffic). I turned on debug chat, debug ppp negotiation, but no output generated.

I have also tried to ping to an internal network and a public ip, still no debug output.

cellular Profile status is inactive.

router#show cellular 0/0/0 security

Modem Security Information
==========================
Card Holder Verification (CHV1) = Enabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3

Please advice.

8 REPLIES
Hall of Fame Super Silver

Re: HWIC-3G-GSM no traffic

Hello Leepeiwai,

you may need to create a modem profile before being able to use the HWIC. It is a sort or registration with mobile provider

see

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/mrwlsgsm.html#wp1119164

Hope to help

Giuseppe

New Member

Re: HWIC-3G-GSM no traffic

Yes, I have already created the profile at the beginning

#sho cellular 0/0/0 all
Profile Information
====================
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = telstra.internet
Authentication = CHAP
Username: dummy, Password: dummy

Profile 4 = INACTIVE
--------
PDP Type = IPv4
--More--                           Access Point Name (APN) = telstra.corp
Authentication = None
Username: , Password:

* - Default profile

Data Connection Information
===========================
Data Transmitted = 0 bytes, Received = 0 bytes
Profile 1, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 2, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 5, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 6, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 7, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
--More--                           Profile 8, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 9, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 10, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 11, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 12, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 13, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 14, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 15, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 16, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state

Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
--More--                           Packet Service = UMTS/WCDMA (Attached)
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = AUS, Network = Telstra
Mobile Country Code (MCC) = 505
Mobile Network Code (MNC) = 1
Location Area Code (LAC) = 12880
Routing Area Code (RAC) = 1
Cell ID = 708
Primary Scrambling Code = 459
PLMN Selection = Automatic
Registered PLMN =  , Abbreviated =
Service Provider = Telstra

Radio Information
=================
Current Band = WCDMA 850, Channel Number = 4387
Current RSSI(RSCP) = -76 dBm
Band Selected = GSM EGSM/DCS
Number of nearby cells = 1
Cell 1
Primary Scrambling Code = 0x1CB
--More--                            RSCP = -78 dBm, ECIO = -9 dBm

Hall of Fame Super Silver

Re: HWIC-3G-GSM no traffic

Hello Leepeiwai,

this is fine

have you configured the chat script?

be aware that the string that follows the ATDT command is specific of the provider

Hope to help

Giuseppe

New Member

Re: HWIC-3G-GSM no traffic

yes, chat script is applied. configuration as below:

chat-script NextG "" "ATDT*98*1#" TIMEOUT 60 "CONNECT"

interface Cellular0/0/0
no ip address
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer pool-member 1
async mode interactive
!
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string NextG
dialer persistent
dialer-group 1
ppp authentication chap callin
ppp chap hostname dummy
ppp chap password 0 dummy
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server

Hall of Fame Super Silver

Re: HWIC-3G-GSM no traffic

Hello Leepewai,

have you configured also the corresponding async line 0/0/0 ?

line 0/0/0
 exec-timeout 0 0
 script dialer NextG
 login
 modem InOut

see

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/mrwlsgsm.html#wp1040391

Hope to help

Giuseppe

New Member

Re: HWIC-3G-GSM no traffic

Yes I have, also read the doc link you provided

line 0/0/0
script dialer NextG
modem InOut
no exec
transport input all

New Member

Re: HWIC-3G-GSM no traffic

I am able to connect and get an ip address from the Service Provider by changing the SIM card.

This time, unlike the previous SIM, the CHV1 code of this new SIM is disabled.

router#show cellular 0/0/0 security

Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3

I this that is why I could not connect to the Service provider.

New Member

Re: HWIC-3G-GSM no traffic

hey,

make sure of the below configurations:

1- chat script.

2- profile creation.

3- correct natting.

4- GSM or 3G coverage and configurations.

5- cellular interface ip address should be negotiated.

as well try to change the script to

chat-script NextG "" "ATDT*99*1#" TIMEOUT 60 "CONNECT"

i've never used a dialer config for GSM, i configure the cell interface directly as below:

interface Cellular0/0/0
ip address negotiated

ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string ISP

dialer-group 1
async mode interactive
ppp chap hostname ISP

ppp chap password 7 ISP

1640
Views
0
Helpful
8
Replies
CreatePlease to create content