Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

I do 'no ip nat pool mypool' and get 'cannot destroy' message

I am trying to remove a NAT entry;

I do 'no ip nat pool mypool 195.1.1.1 195.1.1.3 netmask 255.255.255.0'

then the IOS returns:

%Pool globalpool in use, cannot destroy

Can you clarify how I can handle this ? IOS 12.3, C2610.

interface Serial0/0

*Mar 1

ip address 195.1.1.4 255.255.255.0FAILURE: System config parse from (

clockrate 500000

clockrate 500

no fair-queue

no fair

no cdp enable

ftp://255.2

ip nat pool globalpool 195.1.1.1 195.1.1.3 netmask 255.255.255.0

ip nat inside source list 1 pool globalpool

ip http server

no ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0

!

!

access-list 1 permit 10.1.1.2

access-list 1 permit 10.1.1.3

access-list 1 permit 10.1.1.1

access-list 1 permit 10.1.1.4

no cdp run

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0

5 REPLIES
Hall of Fame Super Bronze

Re: I do 'no ip nat pool mypool' and get 'cannot destroy' messag

Marlon,

The reason you are unable to delete the pool is due NAT taking place at the moment.

You need to perform the following commands real quick. If I were you, I copy and paste as a script.

#clear ip nat translation *

#config terminal

(config)#no ip nat pool mypool 195.1.1.1 195.1.1.3 netmask 255.255.255.0

Please rate helpful posts.

Thanks

Purple

Re: I do 'no ip nat pool mypool' and get 'cannot destroy' messag

Hi,

There is a document on CCO that describes how to get around precisely this situation:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094422.shtml

Hope that helps - pls do rate the post if it does

Paresh

Bronze

Re: I do 'no ip nat pool mypool' and get 'cannot destroy' messag

Hii,

For this to be done properly, clear the translations and then remove the statement.

If still its not happening then remove the internal network physical connection from the router and do it.or you can disable nat on the interfaces,clear the tables and then do it.

Pls rate the post.

New Member

Re: I do 'no ip nat pool mypool' and get 'cannot destroy' messag

This forum is amazing. Thanks.

Re: I do 'no ip nat pool mypool' and get 'cannot destroy' messag

you can also do it by just issuing command on interface configuration mode "shutdown"

and then you can disable the NAT on the interface...

rate this post if it helps

regards

Devang

4745
Views
34
Helpful
5
Replies