Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

I have a problem on Switch 3560 and 2960

My network diagram is

Router (Internet)

||ip : 203.1.1.1 (real IP)

||

||ip : 203.1.1.2 (real IP)

C3560(3vlan,v1:10.1,v2:10.2,v3:10.3)

||

C2960(2vlan,v1:10.1,v2:10.2)

||

Client

In c3560 has configed

!

interface FastEthernet0/1

description Link TO Router-Internet

switchport access vlan 1

switchport mode access

!

interface GigabitEthernet0/1

description Link TO c2960

switchport mode trunk

switchport trunk encapsulation dot1q

interface Vlan1

ip address 203.1.1.2 255.255.255.224

!

interface Vlan101

ip address 10.1.1.1 255.255.255.0

!

interface Vlan102

ip address 10.2.1.1 255.255.255.0

!

interface Vlan103

ip address 10.3.1.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 203.1.1.1

and in c2960 has configed

interface GigabitEthernet0/1

description Link TO c3560

switchport mode trunk

switchport trunk encapsulation dot1q

interface Vlan101

no ip address

no ip route-cache

!

interface Vlan101

ip address 10.1.1.2 255.255.255.0

!

interface Vlan102

ip address 10.2.1.2 255.255.255.0

!

But now client on vlan in c3560 and c2960 cann't connect to internet please help me . please revise configuration for me

** My router is own ISP but i have config it and when i bring client connect straight with router its can connect to internet.

8 REPLIES
Bronze

Re: I have a problem on Switch 3560 and 2960

Hi

I think its because u have configured the port towards router as an access port.Try with making it a trunk port on both 3560 and router side or make it an L3 port using "no switchport" command on 3560,gave both ports an ip and then put the default routes next-hop as the ip on router side.

Pls check out this.. :)

bye

Hall of Fame Super Bronze

Re: I have a problem on Switch 3560 and 2960

The router needs to have a route back to your network.

I'm assuming there is NAT configured somewhere ?

When you connect a PC directly into the router, does the PC obtain an IP from this router via DHCP or you apply a static IP ?

Per your post, having a public IP and a private IP in the 3560 won't provide a good design. You need to NAT your private IP address in order to communicate to the public domain.

New Member

Re: I have a problem on Switch 3560 and 2960

Please revise config to me.

I nat (overload[PAT]) at router its work when i bring computer connect in fa0/0 [ip:203.149.31.99]

Please Help me,If its don't finish,i'm not go back home. :(

New Member

Re: I have a problem on Switch 3560 and 2960

File config of c3560 and network diagram

please help me.

Re: I have a problem on Switch 3560 and 2960

I think your problem may not be in the configurations of the switches at all, but in the clients. Do I understand that your hosts connected to the 3560 can connect and the hosts connected to the 2960 cannot?

The 2960 is a layer-2 switch and will not do routing at all. So ... what default gateway have you configured in the host clients? If it is the addresses on the 2960, hen it will not work at all. The clients need to use the IP addresses of the 3560 as their gateway.

Kevin Dorrell

Luxembourg

New Member

Re: I have a problem on Switch 3560 and 2960

i don't know, i config in both switch is true, please explain to me if i config switch wrong.

thank you so much

Re: I have a problem on Switch 3560 and 2960

I just had another look at your configurations. In you 3560, you have a static default route via 203.149.31.97, but I am not sure you have a route to 203.149.31.67. I suppose it is out the F0/1 port, but the 3560 does not know that.

You need to configure something like this on the 3560:

int F0/1

 no switchport

 ip address 203.149.31.98 255.255.255.224

Then, make sure you can ping 203.149.31.97 from the 3560, and check that your default route has turned up in your routing table.

The ISP router will know about 192.168.101.0/24 because of it secondary address presence in the VLAN 101 (although you will need to resolve its IP address conflict with the VLAN 101 interface of the 2960). But the ISP router will need to be told about 192.168.102.0/24 and 192.168.103.0/24. Does it run any routing protocol? If so, and once it know about 192.168.102.0/24 etc., you could handle 192.168.101.0/24 in the same way.

Kevin Dorrell

Luxembourg

New Member

Re: I have a problem on Switch 3560 and 2960

Thank for all support,but i confuse about NAT, now i think on router use Overload NAT,may be config in C3560 for NAT to internet ?. or something effect this cause.

184
Views
0
Helpful
8
Replies
CreatePlease to create content