Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

I wonder why not ping!!!! please answer my question!!!!!

hi...

the network design is...

r1(s0)-(s0)r2(s1)-(s1)r3(e0)-(e0)r4

r1)

!

interface Loopback0

ip address 7.7.1.1 255.255.255.0

!

interface Serial0

ip address 7.7.12.1 255.255.255.0

!

interface Serial1

no ip address

shutdown

!

router bgp 1

bgp router-id 7.7.1.1

bgp log-neighbor-changes

network 7.7.1.0 mask 255.255.255.0

neighbor 7.7.12.2 remote-as 234

!

=========================================

r2)

!

interface Loopback0

ip address 7.7.2.2 255.255.255.0

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

ip address 7.7.12.2 255.255.255.0

clockrate 64000

!

interface Serial1

ip address 7.7.23.2 255.255.255.0

clockrate 64000

!

router eigrp 7

network 7.7.2.0 0.0.0.255

network 7.7.12.0 0.0.0.255

network 7.7.23.0 0.0.0.255

auto-summary

eigrp router-id 7.7.2.2

!

router bgp 234

bgp router-id 7.7.2.2

bgp log-neighbor-changes

network 7.7.2.0 mask 255.255.255.0

neighbor 7.7.3.3 remote-as 234

neighbor 7.7.3.3 update-source Loopback0

neighbor 7.7.4.4 remote-as 234

neighbor 7.7.4.4 update-source Loopback0

neighbor 7.7.12.1 remote-as 1

!

=========================================

r3)

!

interface Loopback0

ip address 7.7.3.3 255.255.255.0

!

interface Ethernet0

ip address 7.7.34.3 255.255.255.0

!

interface Serial0

no ip address

shutdown

!

interface Serial1

ip address 7.7.23.3 255.255.255.0

!

router eigrp 7

network 7.7.3.0 0.0.0.255

network 7.7.23.0 0.0.0.255

network 7.7.34.0 0.0.0.255

auto-summary

eigrp router-id 7.7.3.3

no eigrp log-neighbor-changes

!

router bgp 234

bgp router-id 7.7.3.3

bgp log-neighbor-changes

network 7.7.3.0 mask 255.255.255.0

neighbor 7.7.2.2 remote-as 234

neighbor 7.7.2.2 update-source Loopback0

neighbor 7.7.4.4 remote-as 234

neighbor 7.7.4.4 update-source Loopback0

!

r4)

!

interface Loopback0

ip address 7.7.4.4 255.255.255.0

!

interface Ethernet0

ip address 7.7.34.4 255.255.255.0

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

router eigrp 7

network 7.7.4.0 0.0.0.255

network 7.7.34.0 0.0.0.255

auto-summary

eigrp router-id 7.7.4.4

!

router bgp 234

bgp router-id 7.7.4.4

bgp log-neighbor-changes

network 7.7.4.0 mask 255.255.255.0

neighbor 7.7.2.2 remote-as 234

neighbor 7.7.2.2 update-source Loopback0

neighbor 7.7.3.3 remote-as 234

neighbor 7.7.3.3 update-source Loopback0

!

=========================================

but r1's 7.7.7.0 subnetwork don't install r3,r4's routing table.

so not ping from r4 to r1's 7.7.7.0!

why??!!!! please ㅜㅜ

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: I wonder why not ping!!!! please answer my question!!!!!

You are running iBGP so in order to install another iBGPs network, you need to enter the following command under the BGP process

no synchronization

or, you need to employ an IGP (static or dynamic routing) to install those routes.

To learn about synchronization, please read

http://www.cisco.com/warp/public/459/bgp_noad.html

__________

Please rate helpful posts.

Thanks

6 REPLIES
Hall of Fame Super Bronze

Re: I wonder why not ping!!!! please answer my question!!!!!

You are running iBGP so in order to install another iBGPs network, you need to enter the following command under the BGP process

no synchronization

or, you need to employ an IGP (static or dynamic routing) to install those routes.

To learn about synchronization, please read

http://www.cisco.com/warp/public/459/bgp_noad.html

__________

Please rate helpful posts.

Thanks

Gold

Re: I wonder why not ping!!!! please answer my question!!!!!

I assume you mean 7.7.1.0 and not 7.7.7.0 since I cannot see 7.7.7.0 even in router 1.

All IBGP routers need to be connected to all other IBGP routers within a AS to function properly. BGP will not advertise a route learned via IBGP to another IBGP neighbor.

You will need to put in route reflectors to make this work.

New Member

Re: I wonder why not ping!!!! please answer my question!!!!!

Hi ,

Due to split horizon also , a neighbor will not reflect updates to next neighbor until its disabled. .. so u need to have route-reflector also installed and no synchronization .. see if this works

it would be helpful if u can send routing table / database entries..

Gold

Re: I wonder why not ping!!!! please answer my question!!!!!

Split hotizon would only be a issue with EIGRP. BGP does not worry about split horizon because it uses a session based communication where EIGRP is using multicast. Even then there are no point to multipoint conenction so even EIGRP will not have a issue. If he is running a newer IOS level synchronization is disabled by default.

New Member

Re: I wonder why not ping!!!! please answer my question!!!!!

hey man..if u see the answer below also..he talks about the route reflector ...somewhere i read its like a split horizon ..where in the router reflecter clients are not given routes via central router...so it has to be configured as router reflector server...then routes are advertised from one neighbor to another..esp. in hub spoke locations

Re: I wonder why not ping!!!! please answer my question!!!!!

Hi,

BGP does not advertise the networks if the entry is not found in its internal IGP routing table. This default behaviour can be overidden by the command "no synchronization"

ALso one IBGP peer does not advertise the routes to another IBGP peer to avoid loops.

For this you have to either configure route reflectors or you should have full mesh between all of your IBGP peers.

http://www.cisco.com/univercd/cc/td/doc/cisintwk/ics/icsbgp4.htm

HTH

Narayan

105
Views
0
Helpful
6
Replies
CreatePlease to create content