Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IBGP doesn't work

 

I want that R5 knows a route to the subnet 192.168.8.0.

Configuration of R1:

interface Loopback0
 ip address 192.168.100.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.8.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.2.0
 network 192.168.8.0
 neighbor 192.168.8.2 remote-as 200
 neighbor 192.168.100.5 remote-as 100
 neighbor 192.168.100.5 update-source Loopback0
 no auto-summary
!

Configuration of R4:

interface Loopback0
 ip address 192.168.100.4 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.8.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 192.168.8.0
 neighbor 192.168.8.1 remote-as 100
 no auto-summary
!

 

Configuration of R5:

!
interface Loopback0
 ip address 192.168.100.5 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.2.0
 neighbor 192.168.100.1 remote-as 100
 neighbor 192.168.100.1 update-source Loopback0
 no auto-summary
!

  • WAN Routing and Switching
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Hi,Change all loopbacks to a

Hi,


Change all loopbacks to a /32, you have created all on the same /24 network.

Create static routes on R1 and R5 to reach both loopbacks addresses.

Example

R1:

interface Loopback0
 ip address 192.168.100.1 255.255.255.255   

ip route 192.168.100.5 255.255.255.255 192.168.2.2

R5:

!
interface Loopback0
 ip address 192.168.100.5 255.255.255.255

ip route 192.168.100.1 255.255.255.255 192.168.2.1

Best Regards,

Pedro Lereno

3 REPLIES
New Member

Hi,Change all loopbacks to a

Hi,


Change all loopbacks to a /32, you have created all on the same /24 network.

Create static routes on R1 and R5 to reach both loopbacks addresses.

Example

R1:

interface Loopback0
 ip address 192.168.100.1 255.255.255.255   

ip route 192.168.100.5 255.255.255.255 192.168.2.2

R5:

!
interface Loopback0
 ip address 192.168.100.5 255.255.255.255

ip route 192.168.100.1 255.255.255.255 192.168.2.1

Best Regards,

Pedro Lereno

New Member

Thank you very much!Is it

Thank you very much!

Is it possible to make it without static routes so it will be more dynamically?

New Member

Hi,Yes, it is possible.R1 and

Hi,

Yes, it is possible.

R1 and R5 are iBGP neighbors you can add an IGP (interior gateway protocol: RIP, EIGRP, OSPF or IS-IS) between them to announce theirs loopbacks.

Example for eigrp:

R1:

router eigrp 1
network 192.168.100.1 0.0.0.0
network 192.168.2.0 0.0.0.255   

R5:

router eigrp 1
network 192.168.100.5 0.0.0.0
network 192.168.2.0 0.0.0.255  

do not forget to remove the static routes.

 

Best Regards,

 

Pedro Lereno

 

84
Views
0
Helpful
3
Replies
This widget could not be displayed.