Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ibgp learned route not advertised to ebgp peers

Hi,

I want to announce an iBGP learned route to eBGP peers..

this is my output

R8#sh ip bgp neighbors 203.172.5.1 advertised-routes             ; this is my eBGP neighbor

BGP table version is 14, local router ID is 180.20.61.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 200.141.227.0/24 180.31.0.3               0         32768 i

*> 200.141.228.0/24 180.31.0.3               0         32768 i

*> 203.172.21.0     180.31.0.3               0         32768 i

Total number of prefixes 3

R8#sh ip bgp sum

BGP router identifier 180.20.61.1, local AS number 54444

BGP table version is 14, main routing table version 14

11 network entries using 1287 bytes of memory

11 path entries using 572 bytes of memory

4/3 BGP path/bestpath attribute entries using 496 bytes of memory

2 BGP AS-PATH entries using 48 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 2403 total bytes of memory

BGP activity 395/384 prefixes, 405/394 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

180.20.5.1      4 54444   16748   16974       14    0    0 6d20h           1

200.211.241.253 4 28103  263600  263594       14    0    0 1w6d            1

85.200.47.189   4 23201  301740  279483       14    0    0 06:13:21        0

203.172.5.1     4 27768  361491  361704       14    0    0 2d07h           0

R8#sh ip bgp 179.35.3.0

BGP routing table entry for 179.35.3.0/24, version 14

Paths: (1 available, best #1, table Default-IP-Routing-Table)

  Not advertised to any peer

  23456

    200.141.226.42 from 180.20.5.1 (180.20.5.1)

      Origin IGP, metric 0, localpref 100, valid, internal, best ; This is the ibgp learned route not advertised to my ebgp peers

R8#sh ip protocols | begin bgp

Routing Protocol is "bgp 54444"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  IGP synchronization is disabled

  Automatic route summarization is disabled

  Neighbor(s):

    Address          FiltIn FiltOut DistIn DistOut Weight RouteMap

    180.20.5.1

    200.211.241.253

    85.200.47.189

    203.172.5.1

  Maximum path: 1

  Routing Information Sources:

    Gateway         Distance      Last Update

    200.211.241.253       20      1w6d

    180.20.5.1           200      6d20h

  Distance: external 20 internal 200 local 200

according to this:

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800945ff.shtml

in the part "Unable to Announce iBGP-Learned Routes"

they give the solution, disabling IGP synchronization... but in my case, IGP is already disabled.. how can I solve this?

greetings

Everyone's tags (7)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

ibgp learned route not advertised to ebgp peers

Miguel,

You've told use that there is no filtering. However, your config shows that towards 201.217.5.1, you are using the prefix-list prov3 to filter out advertised updates. Would you mind posting that prefix list here - or at least review it to see if the network 200.124.120.0/24 is permitted by it?

Best regards,

Peter

13 REPLIES

ibgp learned route not advertised to ebgp peers

Hi,

as AS number 23456 is used as AS_TRANS for 4-octet AS peering

(see http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6554/ps6599/white_paper_c11-516826.html )

your problem might be related to that somehow?

BR,

Milan

New Member

ibgp learned route not advertised to ebgp peers

hi, I don't think that should be related (the ASN of the not-advertised route is the version of 4 bytes), as far as I understand, the issue with 4 bytes ASN is related just with the peering of BGP neighbors (we've done that already, successfully). The criteria of advertisment of a route via BGP is not based on the ASN, is based in others parameters and configurations... and those parameters and configurations, to make this iBGP learned route to be advertised to a eBGP neighbor, are the ones which i'm not finding and are driving me crazy :S

regards

ibgp learned route not advertised to ebgp peers

Hi,

without knowing more details, only trivial hints coming to my mind, like:

1) any route-maps/filter-lists used on R8 to filter prefixes advertised?

2) is the 190.114.226.42 next-hop reachable from R8? If not, wouldn't nei ... next-hop-self used fo iBGP peering help?

BR,

Milan

New Member

ibgp learned route not advertised to ebgp peers

Milan, in the last post, I've outlined the topology of my situation, does it help?

Answering your questions:

1) no filters are implemented,

2) is not a next hop reachable from R8

New Member

Re: ibgp learned route not advertised to ebgp peers

Hi Miguel,

can you provide us a picture of your topology? This would give us a mucher better understanding of the whole setup/problem.

regards,

Dirk

BTW: Please rate if helpful

regards, Dirk (Please rate if helpful)
New Member

Re: ibgp learned route not advertised to ebgp peers

Yes, it is like this:

(200.124.120.0, ASN X, 4 bytes format)-->Router_A<---eBGP--->Router_B<-----iBGP--->Router_C<---eBGP--->Router_D

Router A and Router B are eBGP peers, differents ASs.

Router B and Router C are iBGP peers, same AS

Router C and D are eBGP peers, different AS

Router A and D are not in my control

Router B and C are in my control

Router C has the config I've posted in the first post

Router C learns from Router B the route to 200.124.120.0, via iBGP, and can fully route until there

I want Router C to advertise this route, learned via iBGP, to its eBGP peers, but this route is not advertised to any peers (as it's shown in the config)

IGP is disabled, and this is the solution that accross the internet is proposed for cases like these, but doesn't work for me

thanks people for the interest,

regards

Purple

ibgp learned route not advertised to ebgp peers

Hi,

have you already tried clear ip bgp * out and if not do it and if it doesn't work post the result of debug ip bgp update.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: ibgp learned route not advertised to ebgp peers

didn't work the clear ip bgp :s

the output:

Router_C#clear ip bgp * out

Router_C#sh ip bgp 179.35.3.0

BGP routing table entry for 179.35.3.0/24, version 14

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Not advertised to any peer

  23456

    200.141.226.42 from 180.20.5.1 (180.20.5.1)

      Origin IGP, metric 0, localpref 100, valid, internal, best

Router_C

#debug ip bgp

Router_C

#debug ip bgp u

Router_C

#debug ip bgp updates

Mobile router debugging is on for address family: IPv4 Unicast

Router_C#

Cisco Employee

ibgp learned route not advertised to ebgp peers

Miguel,

This is indeed a very interesting issue. In addition to the debugs asked for by Alain, do you believe you could also post the BGP configuration from the router C, i.e. show run | section router bgp ? Even if it appears plain and common, there may be something worth looking at.

Best regards,

Peter

New Member

Re: ibgp learned route not advertised to ebgp peers

Peter,

The config i've posted is from Router C, here is what you asked

Core_Borde#show run | section router bgp

router bgp 54444

no synchronization

bgp log-neighbor-changes

network 200.141.224.0 mask 255.255.248.0

network 200.141.224.0 mask 255.255.255.0

network 200.141.225.0 mask 255.255.255.0

network 200.141.226.0 mask 255.255.255.0

network 200.141.227.0 mask 255.255.255.0

network 200.141.228.0 mask 255.255.255.0

network 200.141.229.0 mask 255.255.255.0

network 200.141.230.0 mask 255.255.255.0

network 200.141.231.0 mask 255.255.255.0

network 200.124.120.0

network 203.172.21.0

neighbor 180.20.5.1 remote-as 54444

neighbor 180.20.5.1 update-source Loopback0

neighbor 200.211.241.253 remote-as 28103

neighbor 200.211.241.253 prefix-list prov1 out

neighbor 85.200.47.189 remote-as 23201

neighbor 85.200.47.189 prefix-list prov2 out

neighbor 203.172.5.1 remote-as 27768

neighbor 203.172.5.1 prefix-list prov3 out

no auto-summary

the bolded one is my iBGP neighbor from which I am receiving the updates

Regards

El mensaje fue editado por: Miguel Gonzalez

Cisco Employee

ibgp learned route not advertised to ebgp peers

Miguel,

You've told use that there is no filtering. However, your config shows that towards 201.217.5.1, you are using the prefix-list prov3 to filter out advertised updates. Would you mind posting that prefix list here - or at least review it to see if the network 200.124.120.0/24 is permitted by it?

Best regards,

Peter

New Member

ibgp learned route not advertised to ebgp peers

the problem was in the prefix list!

I'm not enough trained in bgp... thanks a lot! it is working now.

I've permited my previously non-advertised, iBGP learned route, in each prefix list for each eBGP neighbor, and after that i've "clear ip bgp * out"... then the route started to be advertised to the peers

Cisco Employee

ibgp learned route not advertised to ebgp peers

Hi Miguel,

We were glad to help. Please note that it was Milan's first set of questions that mentioned the filtering as the possible reason for your problems, so he deserves to be credited with the correct answer as well. Also, in future, please post the configurations along with your description of the problem. Often, the problem really lies in overlooking or misinterpreting a part of the existing configuration.

Best regards,

Peter

7448
Views
24
Helpful
13
Replies
CreatePlease to create content