Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ILMI Error 12.3 IOS

we have several routers that are looging th e following errors.

*Mar 5 19:05:07.219: ILMI(ATM3/0): Sending ilmiColdStart trap

*Mar 5 19:05:07.219: ILMI(ATM3/0): No ILMI VC found

*Mar 5 19:05:07.219: ILMI: Encapsulation error on o/g ILMI Pdu <ilmi_send_pkt> (ATM3/0)

*Mar 5 19:05:07.219: ILMI: Unable to Send Pdu out <ilmi_send_trap>

We have configured:-

no atm ilmi-keepalive

under the main ATM interface to turn of ILMI

Please can anyone advise

3 REPLIES

Re: ILMI Error 12.3 IOS

Hello,

this message appears because the auto-configuration of ATM addresses (NSAP) is failing.

By default a router has no network prefix but only the host specific part. So in order to have a complete NSAP address it tries to "ask" the switch through ILMI about the prefix (configured per ATM switch).

Obviously there is no ILMI PVC defined so the request can not be sent.

You can disable this by issuing "disable-ilmi-enterprise-traps". Have a look at http://www.cisco.com/warp/public/121/illmi.html#9

Did this help? Please rate all helpful posts

Martin

New Member

Re: ILMI Error 12.3 IOS

We have the exact same issue with an 877 router connected to a Telefonica ADSL2+ line in Spain.

After searching, it appear other people have the same issue but nobody seems to have an answer. We tried the “"disable-ilmi-enterprise-traps" hidden command but it doesn’t appear to be supported on the 877.

interface ATM0

ip address 10.10.10.1 255.255.255.0

no atm ilmi-keepalive

pvc 8/32

encapsulation aal5snap

!

dsl operating-mode auto

*Mar 5 19:31:43: ICMP: echo reply sent, src 10.10.10.1, dst 192.168.1.1

*Mar 5 19:31:43: ILMI(ATM0): Sending ilmiColdStart trap

*Mar 5 19:31:43: ILMI(ATM0): No ILMI VC found

*Mar 5 19:31:43: ILMI: Encapsulation error on o/g ILMI Pdu (ATM0)

*Mar 5 19:31:43: ILMI: Unable to Send Pdu out

The weird thing is that the interface appears to be able to receive packets from the internet on the ATM0 interface, it just can’t send.

Any ideas?

New Member

Re: ILMI Error 12.3 IOS

OK, we managed to find a solution for this:

When Telefonica sent us the configuration details of the new line they included a “gestión IP” address which is management IP in English.

We then shutdown the ilmi completely since it simply wasn’t working in any modes and added the management IP address as a secondary on ATM0. We then did a ping to the management IP addresses broadcast range. We got a response back from a previously unknown IP address.

We then added that IP address to the protocol of the atm pvc and set it as the default route as such…

interface ATM0

ip address 10.10.10.1 255.255.255.0

no atm ilmi-keepalive

no atm address-registration

no atm ilmi-enable

pvc 8/32

protocol ip 11.11.11.1

encapsulation aal5snap

!

dsl operating-mode auto

!

ip route 0.0.0.0 0.0.0.0 11.11.11.1

Believe it or not but it works fine now.

1144
Views
0
Helpful
3
Replies
CreatePlease to create content