Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

incomplete arpa

Hi guys, here's the scenario

PE MAC Address is : 80:71:1f:44:da:f4 and CE MAC is : 00.06.f6.e8.89.70.

However we are still not able to reach the remote end.

PHSDCOTAUPH01R02#sh arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.185.0.133            0   Incomplete      ARPA  

Internet  10.185.0.134            -   0006.f6e8.8970  ARPA   GigabitEthernet0/0.910

why is it that i can't learn PE mac?

thanks

8 REPLIES
Community Member

Re:incomplete arpa

You are not getting ARP replies from PE, you don't have the full layer 2 connectivity, check with ISP.

Sent from Cisco Technical Support Android App

Community Member

incomplete arpa

This is actually details coming from PE side which both mac is learnt.

ULC   Mac address        Interface/Circuit               Type  Age(sec)

----  -----------------  ------------------------------  ----  --------

1/5   00:06:F6:E8:89:70  ge-1/5/3/2.910                  D     166    

1/9   80:71:1F:44:DA:F4  ge-1/9/2/4.910                  D     252    

and i've actually configured L3 on its L2 settings, i actually been able to ping WAN ip.

fyi, this is actually the problem from my client where ISP has no problem only they can't learn the mac on their PE side.

Silver

incomplete arpa

Josiah,

All that means is that your CE router has tried to resolve the MAC address of10.185.0.133 and for whatever reason it failed. There are many reasons why that would happen. If it is not a physical problem then it could be that the address is not configured on the other end of that link. Or if your provider expects you to dot1q tag your traffic then that would also cause it.

Silver

incomplete arpa

Couple of things that is needed:

How is the Provider connected to you, what is the topology?

What routing is in place or are the IP's a part of a directly connected interface?

Is the interface up and line protocol up on the interface facing your provider?

Can you ping anything beyond the provider?

From the CE router can you see anything on your internal network?

From the CE do you have a default route or default-gateway configured?

Community Member

Re: incomplete arpa

Look:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094adb.shtml

http://www.cisco.com/en/US/docs/routers/xr12000/software/xr12k_r4.1/addr_serv/command/reference/b_ipaddr_cr41xr12k_chapter_010.html

======================================================================================================

Add Mac of interface neighbor ( ISP )

R1(config)#arp  10.185.0.x aaaa.bbbb.cccc arpa alias

Community Member

incomplete arpa

Here's the checking from our client below:

1. Single tag at PE and no tag at CE

2. Single tag at PE and single tag at CE

If using 1., then PE can see CE MAC, but CE still cannot see PE MAC, thus, CE & PE cannot ping each other,

If using 2., then PE and CE cannot see MAC of each other, thus, CE & PE cannot ping each other.

Currently, PE is setting double tag & CE is setting single tag as following. Both cannot see each other MAC.

Please further check it.

PE router:

ME2# run show configuration interfaces ge-5/2/0.10

vlan-tags outer 910 inner 910;

family inet {

    mtu 1500;

    no-redirects;

    address 10.185.0.133/30;

}

{master}[edit]

ME2# run show arp | match 5/2/0.10                   

{master}[edit]

CE router:

Router(config-subif)#do show run | s GigabitEthernet0/0

interface GigabitEthernet0/0

description link to PE: DTAC to update circuit ID

bandwidth 4000

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

load-interval 30

duplex full

speed 100

no cdp enable

hold-queue 32768 out

interface GigabitEthernet0/0.910

encapsulation dot1Q 910

ip address 10.185.0.134 255.255.255.252

no cdp enable

PHSDCOTAUPH01R02(config-subif)#do show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.185.0.133            0   Incomplete      ARPA  

Internet  10.185.0.134            -   0006.f6e8.8970  ARPA   GigabitEthernet0/0.910

What's next course of action for this? thanks

Community Member

Re: incomplete arpa

you can not see MAC of ge-5/2/0.10.

use show interfaces:

CPDVG01#show interfaces gigabitEthernet 0/1

GigabitEthernet0/1 is up, line protocol is up

  Hardware is BCM1125 Internal MAC, address is aaaa.aaaa.aaaa (bia 001c.f6f1)

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 2/255, rxload 2/255

  -- more --

after:

R1(config)#arp  10.185.0.x aaaa.aaaa.aaaa arpa alias

abs.

Community Member

incomplete arpa

The ge-5/2/0.10 interface is actually connected on their PE router, so do i need to define this command "R1(config)#arp  10.185.0.x aaaa.aaaa.aaaa arpa alias" on their CE router?

1244
Views
0
Helpful
8
Replies
CreatePlease to create content