Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

mf
New Member

Information Request

I have router model 2612 and I recieve internet signal in RJ45, How can I confugre this router to use both internet and internal network if this router only has one ethernet port?

1 REPLY

Re: Information Request

Hi,

I have router model 2612 and I recieve internet signal in RJ45, How can I confugre this router to use both internet and internal network if this router only has one ethernet port?

Yes.. This is possible.But you have to configure the interface as "Router on Stick" method.

Create two sub-interfaces and assign each interface into seperate VLAN.Then connect that cable into any one of the L2 Switch and make that port as trunk.

Now connect you LAN link and internet link into your L2 switch and assign those port into the respective VLAN


ROUTER CONFIGURATION

I am assigning that your Internet Link is belongs to vlan 10 and internal LAN belongs to vlan 20

(config)# interface fastethernet 0/0.10

(config-if)# encapsulation dot1q 10

(config-if)# ip address 10.10.10.2 255.255.255.0

(config-if)# exit

(config)# interface fastethernet 0/0.20

(config-if)# encapsulation dot1q 20

(config-if)# ip address 20.20.20.2 255.255.255.0

(config-if)# exit

SWITCH CONFIGURATION
# conf t

(config)# vlan 10
(config-vlan)# vlan 20
(config-vlan)# exit


(config)# interface FastEthernet1/0/1
(config-if)# description trunk-to-router-on-a-stick
(config-if)# switchport trunk encapsulation dot1q
(config-if)# switchport mode trunk
(config-if)# exit


(config)# interface FastEthernet1/0/2
(config-if)# description connection-to-Internet
(config-if)# switchport mode access
(config-if)# switchport access vlan 10
(config-if)# exit


(config)# interface FastEthernet1/0/3
(config-if)# description connection-to-LAN
(config-if)# switchport mode access
(config-if)# switchport access vlan 20
(config-if)# exit

Regards

Karuppu

125
Views
0
Helpful
1
Replies