Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Input errors on fastethernet interface router 2811

Hi,

First thanks for your time.

I have this output from show interfaces command for the fastethernet interface on a 2811 router.

Can any one help me find the causes of the crc and the ignored input errors on the interface?

The interface  configuration is:

interface FastEthernet0/0

description VLANS_CHILE

no ip address

ip route-cache flow

duplex full

speed 100

And it's pluged to gigabit interface on a 3560 switch witth version 12.2(25r)SEE4

The interface has subinterfaces. As an aexample:

interface FastEthernet0/0.1

description Vlan Marketing  & Directorio $FW_INSIDE$

encapsulation dot1Q 20

ip address 192.168.20.19 255.255.255.0

ip helper-address 192.168.23.100

ip nbar protocol-discovery

ip flow ingress

ipx encapsulation NOVELL-ETHER

ipx network 21

ipx type-20-propagation

standby 20 ip 192.168.20.1

standby 20 priority 130

standby 20 preempt

Here is the configuration of the interface on the switch:

interface GigabitEthernet0/40

description Hacia GW2_XCL

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,20-27

switchport mode trunk

speed 100

duplex full

Thanks in advance.

Regards.

Samuel.

The output from the router's interface:

GW2_XCL#sh int fas 0/0

FastEthernet0/0 is up, line protocol is up

Hardware is MV96340 Ethernet, address is 001b.d4be.66e8 (bia 001b.d4be.66e8)

Description: VLANS_CHILE

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 99/255, rxload 99/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 02:34:53

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 38975000 bits/sec, 4344 packets/sec

5 minute output rate 38959000 bits/sec, 4340 packets/sec

     43681411 packets input, 1886473 bytes

     Received 157807 broadcasts, 8 runts, 0 giants, 0 throttles

     104 input errors, 54 CRC, 0 frame, 0 overrun, 42 ignored

    0 watchdog

     0 input packets with dribble condition detected

     43695253 packets output, 4277351296 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

Everyone's tags (1)
6 REPLIES
Hall of Fame Super Bronze

Re: Input errors on fastethernet interface router 2811

Have you tried swapping the cables?

If so, try connecting the router to another interface in the switch - it could be a bad port at either end.

Community Member

Re: Input errors on fastethernet interface router 2811

Thanks, for your answer.

Yes I have changed cables, with the same results.

I will change to another port on the switch, later this evening (people are working now). I haven't tried that yet.

Question:

If the problem is something phisical on the router's interface, why I don't have errors on the other side, on the switch interface?, It's that normal?

Thanks.

Regards.

Samuel.

Community Member

Re: Input errors on fastethernet interface router 2811

Hey Samuel,

CRCs are considered input errors, and usually point to an issue with the other side of the physical connection. So, to answer your question it's normal to see CRCs on only one side of a link. That's most likely why Edison suggested you try connecting to a different switch port.

If you are going to change switch ports, I would suggest making sure you are moving to a different ASIC as well. To determine port / ASIC mappings, you can do a 'show platform pm if-numbers'.

Also, have you tried using auto-negotiated speed and duplex on this links? Since they're hardcoded you shouldn't see a mismatch, but just something to try..

Hope this helps!

Hall of Fame Super Blue

Input errors on fastethernet interface router 2811

1.  Remove the "speed 100" from your switch.  Instead try "speed auto 10 100".

2.  Remove the speed 100 from your router.

3.  On your switch, try the following:

Command:  test cable tdr interface ;

Wait for about 5 to 7 seconds;

Command:  sh cable tdr interface ; and

Post the output

Community Member

Input errors on fastethernet interface router 2811

Hi,

Here is the output:

Interface Speed Local pair Pair length        Remote pair Pair status

--------- ----- ---------- ------------------ ----------- --------------------

Gi0/40    100M  Pair A     2    +/- 4  meters Pair A      Normal

                Pair B     2    +/- 4  meters Pair B      Normal

                Pair C     2    +/- 4  meters Pair C      Short

                Pair D     2    +/- 4  meters Pair D      Short

I change the cable, with identical result.

I also set speed auto in both sides as you say.

Thanks.

Regards

Community Member

Input errors on fastethernet interface router 2811

Hi,

It is normal to have pairs C and D in shoert?

I have changed cables with identical result, each time.

Thanks.

Regards

5901
Views
0
Helpful
6
Replies
CreatePlease to create content