Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

inter-vlan routing

wiil any body plz explain me how to do inter vlan routing in 3550 as if i ve config vlans in 2950

1 ACCEPTED SOLUTION

Accepted Solutions

Re: inter-vlan routing

Dear imran,

Inter Routin routing used with MLS switches to route between different vlans, the interface VLAN ip address must be belong to the same subnet that the hosts on the vlan area using which then will be used as GW address for all vlan members.

CA3550(config)#vlan 600

CA3550(config-vlan)#name blabla

CA3550(config-if)#interface f0/1

CA3550(config-if)#switchport

CA3550(config-if)#switchport mode access

CA3550(config-if)#switchport access vlan 600

CA3550(config-if)#exit

CA3550(config-if)#interface vlan600

CA3550(config-if)#ip address 10.0.0.1 255.255.255.0

Best Regards,

Mounir Mohamed

5 REPLIES

Re: inter-vlan routing

HI imran.

Fisrt verify weather all the trunk configurations are working properly between the switches.

And on 3550 u have to create SVI's for each vlan u have defined,

For eg

interface vlan

ip address this will be the gateway for u r clients.

and may this link will help u .

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008015f17a.shtml

Thanks

Mahmood

Re: inter-vlan routing

Hi Imran,

In addition to above post remember to enable "ip routing" command on global config mode because it is disable on 3550 switch and till the time it is disable intervlan routing or normal routing will not work.

Once you enable "ip routing" you will be able to see all your vlans (logical interfaces are necessary) in your routing table as directly connected and intervlan rotuting will start working.

HTH

Ankur

New Member

Re: inter-vlan routing

Thanks mehmood for ur valuable help i ll go throug the link which u ve provided me

Re: inter-vlan routing

Dear imran,

Inter Routin routing used with MLS switches to route between different vlans, the interface VLAN ip address must be belong to the same subnet that the hosts on the vlan area using which then will be used as GW address for all vlan members.

CA3550(config)#vlan 600

CA3550(config-vlan)#name blabla

CA3550(config-if)#interface f0/1

CA3550(config-if)#switchport

CA3550(config-if)#switchport mode access

CA3550(config-if)#switchport access vlan 600

CA3550(config-if)#exit

CA3550(config-if)#interface vlan600

CA3550(config-if)#ip address 10.0.0.1 255.255.255.0

Best Regards,

Mounir Mohamed

Re: inter-vlan routing

hi imran,

here you need to creat the multiple svi...like this

config)#interface vlan XXX

config-if)# ip address 10.1.x.x 255.x.x.x

config-if)# no shut

config)#interface vlan yyy

config-if)# ip address 10.2.x.x 255.x.x.x

config-if)# no shut

like this on switch 33550

hope this helps you

rate this post if it helps

regards

Devang

314
Views
5
Helpful
5
Replies