Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Interface flap after re applying policy-map, 2911, 15(0)M

Hi everyone,

Got a wierd issue today with 2911 series, i needed to remove the policy-map which I had under the WAN interfaces (2 seprate serial interfaces working in load balance) and after removing the service policy command and re creating the policy-map again as I needed to adjust the EF CAR... I applied the service-policy command again under both interfaces but one of them just flapped!

The platform is Cisco 2911 running on - Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.0(1)M7, RELEASE SOFTWARE (fc2)

Here is what happned (see below) and after it you can see more details about the config and show policy-map interface and show invent, I could not see a bug for that IOS or 15(0) train but I had same thing on other sites running 15(0) IOS on same platform...

Now thing is why only one serial flapped while the other one  was not affected? hence both are same module

conf t

do ter mon

interface Serial0/0/0:1

no service-policy output etm-01

interface Serial0/1/0:1

no service-policy output etm-01

!

no policy-map etm-01

!

policy-map etm-01

class realtime

    priority 768

    police 768000 conform-action transmit  exceed-action drop

class priority

    bandwidth remaining percent 40

     random-detect dscp-based

class missioncritical

    bandwidth remaining percent 39

     random-detect dscp-based

class transactional

    bandwidth remaining percent 16

     random-detect dscp-based

class scavenger

    bandwidth remaining percent 1

     random-detect dscp-based

class class-default

    bandwidth remaining percent 4

     random-detect dscp-based

!

interface Serial0/0/0:1

service-policy output etm-01

interface Serial0/1/0:1

service-policy output etm-01

RT01(config)#interface Serial0/0/0:1

RT01(config-if)# no service-policy output etm-01

RT01(config-if)#interface Serial0/1/0:1

RT01(config-if)# no service-policy output etm-01

RT01(config-if)#!

RT01(config)#no policy-map etm-01

RT01(config)#

RT01(config)#

RT01(config)#policy-map etm-01

RT01(config-pmap)# class realtime

RT01(config-pmap-c)#    priority 768

RT01(config-pmap-c)#    police 768000 conform-action transmit  exceed-action drop

RT01(config-pmap-c-police)# class priority

RT01(config-pmap-c)#    bandwidth remaining percent 40

RT01(config-pmap-c)#     random-detect dscp-based

RT01(config-pmap-c)# class missioncritical

RT01(config-pmap-c)#    bandwidth remaining percent 39

RT01(config-pmap-c)#     random-detect dscp-based

RT01(config-pmap-c)# class transactional

RT01(config-pmap-c)#    bandwidth remaining percent 16

RT01(config-pmap-c)#     random-detect dscp-based

RT01(config-pmap-c)# class scavenger

RT01(config-pmap-c)#    bandwidth remaining percent 1

RT01(config-pmap-c)#     random-detect dscp-based

RT01(config-pmap-c)# class class-default

RT01(config-pmap-c)#    bandwidth remaining percent 4

RT01(config-pmap-c)#     random-detect dscp-based

RT01(config-pmap-c)#!

RT01(config-pmap-c)#

RT01(config-pmap-c)#

RT01(config-pmap-c)#

RT01(config-pmap-c)#exit

RT01(config-pmap)#exit

RT01(config)#

RT01(config)#

RT01(config)#

RT01(config)#interface Serial0/0/0:1

RT01(config-if)# service-policy output etm-01

RT01(config-if)#interface Serial0/1/

Jul 10 11:40:22 GMT: Interface Serial0/0/0:1 max_reserved_bandwidth config will not

take effect on the queueing features configured via service-policy0:1

RT01(config-if)# service-policy output etm-01

RT01(config-if)#!

.Jul 10 11:40:53 GMT: %BGP-5-ADJCHANGE: neighbor x.x.x.x Down Interface flap

.Jul 10 11:40:53 GMT: %BGP_SESSION-5-ADJCHANGE: neighbor x.x.x.x IPv4 Unicast topology base removed from session  Interface flap

.Jul 10 11:40:53 GMT: %BGP-5-ADJCHANGE: neighbor y.y.y.y vpn vrf CustomerPartner1 Down Interface flap

.Jul 10 11:40:53 GMT: %BGP_SESSION-5-ADJCHANGE: neighbor y.y.y.y IPv4 Unicast vpn vrf CustomerPartner1 topology base removed from session  Interface flap

.Jul 10 11:40:54 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0:1, changed state to down

.Jul 10 11:41:04 GMT: Interface Serial0/1/0:1 max_reserved_bandwidth config will not

take effect on the queueing features configured via service-polic

RT01(config-if)#

!!! here is part of the running config and I replaced the IP addresses!!!

!

interface Serial0/0/0:1

bandwidth 1984

no ip address

no ip redirects

encapsulation frame-relay IETF

!

max-reserved-bandwidth 100

service-policy input etm-metering-inbound

service-policy output etm-01

!

interface Serial0/0/0:1.100 point-to-point

bandwidth 1984

ip address x.x.x.x-1 255.255.255.252

no ip redirects

ip nbar protocol-discovery

ip flow ingress

no cdp enable

frame-relay interface-dlci 100 IETF  

!        

interface Serial0/0/0:1.105 point-to-point

bandwidth 1984

ip vrf forwarding CustomerPartner1

ip address y.y.y.y-1 255.255.255.252

no ip redirects

ip nbar protocol-discovery

ip flow ingress

no cdp enable

frame-relay interface-dlci 105 IETF  

!

interface Serial0/1/0:1

bandwidth 1984

no ip address

no ip redirects

encapsulation frame-relay IETF

!

max-reserved-bandwidth 100

service-policy input etm-metering-inbound

service-policy output etm-01

!

interface Serial0/1/0:1.100 point-to-point

bandwidth 1984

ip address z.z.z.z 255.255.255.252

no ip redirects

ip nbar protocol-discovery

ip flow ingress

no cdp enable

frame-relay interface-dlci 100 IETF  

!

interface Serial0/1/0:1.105 point-to-point

bandwidth 1984

ip vrf forwarding CustomerPartner1

ip address a.a.a.a 255.255.255.252

no ip redirects

ip nbar protocol-discovery

ip flow ingress

no cdp enable

frame-relay interface-dlci 105 IETF

RT01#show policy-map interface serial 0/0/0:1

Serial0/0/0:1

  Service-policy input: etm-metering-inbound

    Class-map: realtime-in (match-any)

      68294 packets, 8660523 bytes

      5 minute offered rate 0 bps

      Match: ip dscp cs5 (40) ef (46)

        68294 packets, 8660523 bytes

        5 minute rate 0 bps

    Class-map: priority-in (match-any)

      929 packets, 164183 bytes

      5 minute offered rate 0 bps

      Match: ip dscp cs4 (32) af41 (34) af42 (36) af43 (38)

        929 packets, 164183 bytes

        5 minute rate 0 bps

    Class-map: missioncritical-in (match-any)

      77005 packets, 26187491 bytes

      5 minute offered rate 13000 bps

      Match: ip dscp cs3 (24) af31 (26) af32 (28) af33 (30) cs6 (48) cs7 (56)

        77005 packets, 26187491 bytes

        5 minute rate 13000 bps

    Class-map: transactional-in (match-any)

      11926 packets, 2361349 bytes

      5 minute offered rate 1000 bps

      Match: ip dscp cs2 (16) af21 (18) af22 (20) af23 (22)

        11926 packets, 2361349 bytes

        5 minute rate 1000 bps

    Class-map: general-in (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps

      Match: ip dscp af11 (10) af12 (12) af13 (14)

        0 packets, 0 bytes

        5 minute rate 0 bps

    Class-map: scavenger-in (match-any)

      1081 packets, 864078 bytes

      5 minute offered rate 6000 bps

      Match: ip dscp cs1 (8)

        1081 packets, 864078 bytes

        5 minute rate 6000 bps

    Class-map: besteffort-in (match-any)

      548904 packets, 385606742 bytes

      5 minute offered rate 271000 bps

      Match: ip dscp default (0)

        548904 packets, 385606742 bytes

        5 minute rate 271000 bps

    Class-map: class-default (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

  Service-policy output: etm-01

    queue stats for all priority classes:

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 165934/21128455

    Class-map: realtime (match-any)

      165934 packets, 21128455 bytes

      5 minute offered rate 8000 bps, drop rate 0 bps

      Match: ip dscp cs5 (40) ef (46)

        165934 packets, 21128455 bytes

        5 minute rate 8000 bps

      Priority: 768 kbps, burst bytes 19200, b/w exceed drops: 0

      police:

          cir 768000 bps, bc 24000 bytes

        conformed 165934 packets, 21128455 bytes; actions:

          transmit

        exceeded 0 packets, 0 bytes; actions:

          drop

        conformed 8000 bps, exceed 0 bps

    Class-map: priority (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp cs4 (32) af41 (34) af42 (36) af43 (38)

        0 packets, 0 bytes

        5 minute rate 0 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 0/0

      bandwidth remaining 40% (486 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

    Class-map: missioncritical (match-any)

      90065 packets, 9425720 bytes

      5 minute offered rate 4000 bps, drop rate 0 bps

      Match: ip dscp cs3 (24) af31 (26) af32 (28) af33 (30) cs6 (48) cs7 (56)

        90065 packets, 9425720 bytes

        5 minute rate 4000 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 90065/9208605

      bandwidth remaining 39% (474 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

        af31       87993/8456146         0/0              0/0                 32            40  1/10

        cs6         2372/787185          0/0              0/0                 32            40  1/10

    Class-map: transactional (match-any)

      7255 packets, 1928031 bytes

      5 minute offered rate 2000 bps, drop rate 0 bps

      Match: ip dscp cs2 (16) af21 (18) af22 (20) af23 (22)

        7255 packets, 1928031 bytes

        5 minute rate 2000 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 7255/1943627

      bandwidth remaining 16% (194 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

        cs2         7317/1955711         0/0              0/0                 24            40  1/10

    Class-map: scavenger (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp cs1 (8)

        0 packets, 0 bytes

        5 minute rate 0 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 0/0

      bandwidth remaining 1% (12 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

    Class-map: class-default (match-any)

      527242 packets, 166637097 bytes

      5 minute offered rate 175000 bps, drop rate 0 bps

      Match: any

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/172/0

      (pkts output/bytes output) 533645/176365765

      bandwidth remaining 4% (48 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

        default   534391/176552148       6/2142         166/117722            20            40  1/10

RT01#show policy-map interface serial 0/1/0:1

Serial0/1/0:1

  Service-policy input: etm-metering-inbound

    Class-map: realtime-in (match-any)

      520087 packets, 65868300 bytes

      5 minute offered rate 135000 bps

      Match: ip dscp cs5 (40) ef (46)

        520087 packets, 65868300 bytes

        5 minute rate 135000 bps

    Class-map: priority-in (match-any)

      4 packets, 331 bytes

      5 minute offered rate 0 bps

      Match: ip dscp cs4 (32) af41 (34) af42 (36) af43 (38)

        4 packets, 331 bytes

        5 minute rate 0 bps

    Class-map: missioncritical-in (match-any)

      98093 packets, 20060646 bytes

      5 minute offered rate 43000 bps

      Match: ip dscp cs3 (24) af31 (26) af32 (28) af33 (30) cs6 (48) cs7 (56)

        98093 packets, 20060646 bytes

        5 minute rate 43000 bps

    Class-map: transactional-in (match-any)

      11424 packets, 2133731 bytes

      5 minute offered rate 1000 bps

      Match: ip dscp cs2 (16) af21 (18) af22 (20) af23 (22)

        11424 packets, 2133731 bytes

        5 minute rate 1000 bps

    Class-map: general-in (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps

      Match: ip dscp af11 (10) af12 (12) af13 (14)

        0 packets, 0 bytes

        5 minute rate 0 bps

    Class-map: scavenger-in (match-any)

      454 packets, 156462 bytes

      5 minute offered rate 0 bps

      Match: ip dscp cs1 (8)

        454 packets, 156462 bytes

        5 minute rate 0 bps

    Class-map: besteffort-in (match-any)

      652987 packets, 591665964 bytes

      5 minute offered rate 525000 bps

      Match: ip dscp default (0)

        652987 packets, 591665964 bytes

        5 minute rate 525000 bps

    Class-map: class-default (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

  Service-policy output: etm--01

    queue stats for all priority classes:

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 282927/38949662

    Class-map: realtime (match-any)

      282927 packets, 38949662 bytes

      5 minute offered rate 51000 bps, drop rate 0 bps

      Match: ip dscp cs5 (40) ef (46)

        282927 packets, 38949662 bytes

        5 minute rate 51000 bps

      Priority: 768 kbps, burst bytes 19200, b/w exceed drops: 0

      police:

          cir 768000 bps, bc 24000 bytes

        conformed 282927 packets, 38949662 bytes; actions:

          transmit

        exceeded 0 packets, 0 bytes; actions:

          drop

        conformed 51000 bps, exceed 0 bps

    Class-map: priority (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp cs4 (32) af41 (34) af42 (36) af43 (38)

        0 packets, 0 bytes

        5 minute rate 0 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 0/0

      bandwidth remaining 40% (486 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

    Class-map: missioncritical (match-any)

      143278 packets, 14699805 bytes

      5 minute offered rate 28000 bps, drop rate 0 bps

      Match: ip dscp cs3 (24) af31 (26) af32 (28) af33 (30) cs6 (48) cs7 (56)

        143278 packets, 14699805 bytes

        5 minute rate 28000 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 143278/14490627

      bandwidth remaining 39% (474 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

        cs3           12/1140            0/0              0/0                 26            40  1/10

        af31      144875/14803653        0/0              0/0                 32            40  1/10

        cs6          666/37793           0/0              0/0                 32            40  1/10

    Class-map: transactional (match-any)

      5456 packets, 2551744 bytes

      5 minute offered rate 2000 bps, drop rate 0 bps

      Match: ip dscp cs2 (16) af21 (18) af22 (20) af23 (22)

        5456 packets, 2551744 bytes

        5 minute rate 2000 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 5456/2564372

      bandwidth remaining 16% (194 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

        cs2         5579/2639166         0/0              0/0                 24            40  1/10

    Class-map: scavenger (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp cs1 (8)

        0 packets, 0 bytes

        5 minute rate 0 bps

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 0/0

      bandwidth remaining 1% (12 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 0 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

    Class-map: class-default (match-any)

      490444 packets, 178337041 bytes

      5 minute offered rate 199000 bps, drop rate 0 bps

      Match: any

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 33/217/0

      (pkts output/bytes output) 490227/178175683

      bandwidth remaining 4% (48 kbps)

        Exp-weight-constant: 9 (1/512)

        Mean queue depth: 19 packets

        dscp     Transmitted       Random drop      Tail drop          Minimum        Maximum     Mark

                  pkts/bytes     pkts/bytes       pkts/bytes          thresh         thresh     prob

        default   514925/185621959     243/183276         0/0                 20            40  1/10

RT01#

RT01#show inventory

NAME: "CISCO2911/K9 chassis", DESCR: "CISCO2911/K9 chassis"

PID: CISCO2911/K9      , VID: V05 , SN: FGL155111A3

NAME: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 0", DESCR: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1"

PID: VWIC2-1MFT-T1/E1  , VID: V01 , SN: FOC1547317S

NAME: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 1", DESCR: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1"

PID: VWIC2-1MFT-T1/E1  , VID: V01 , SN: FOC1547313F

NAME: "PVDM3 DSP DIMM with 16 Channels on Slot 0 SubSlot 4", DESCR: "PVDM3 DSP DIMM with 16 Channels"

PID: PVDM3-16          , VID: V01 , SN: FOC15452L09

NAME: "C2911 AC Power Supply", DESCR: "C2911 AC Power Supply"

PID: PWR-2911-AC       , VID: V04 , SN: DCA1544R3PM

Everyone's tags (5)
553
Views
0
Helpful
0
Replies
CreatePlease login to create content