Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

interface mismatch

i have a etherdrop between two routers.

one interface is fastethernet and other is gigabitethernet . i tried to hardcore the duplex setting and speed 100 but as it is taking only half-duplex due to which i am getting collisions and output drops.

Output::::215 output errors, 124 collisions, 214 interface resets

interface FastEthernet0/1

description *** P2P 6MB to Netmagic via Airtel ***

bandwidth 16000

ip address

ip route-cache flow

duplex auto

speed 100

no cdp enable


Re: interface mismatch


whts the TDM end point here in your location ?

are you connecting this ethernet port to a mux placed in your location?

or is it a ethernet drop from the SP end if its an ethernet drop from the sp end do check up with the SP whether the same settings has been replicated/configured on their devices as well..


Re: interface mismatch


I agree with spremkumar.

If your ethernet is connected to Mux means possibility of duplex : full & speed: 100

(or) duplex: half & speed : 10

Best regards,

Guru Prasad R

New Member

Re: interface mismatch


ethernet is connected to MUX placed at our end and i have checked with SP,he is saying he is getting full duplex.Also , i am not able to put gigabit interface in full duplex.

if i tried then it goed down , so we have to put it into auto duplex.

and yes speed is 100 on both the ends.

Re: interface mismatch

are you sure on the part that the mux interface supports full duplex ?

i dont think your mux ethernet port supports it.

can you check the datastheets or supporting doc of your mux for the duplex limitations.

since you have only 6Mbps can you try connecting the same onto a ethernet port which can support hardcoding of duplex settings.

do explore on how to change the duplex on the mux port.



Re: interface mismatch


as you have mentioned that you hardcoded the duplex settings (but its showing as "auto" in the interface config you have pasted, i hope you have changed it to "auto" once the hardcoded "full duplex" didnt work)) and SP is saying that it is getting "full duplex" negotiated (but not hardcoded) at his end.

I would definately recommend you that if you are going to hardcode the speed & duplex settings then hardcode it to "full duplex" at both ends rather than "auto" at SP end and you making it "full duplex" at your end.

once its full duplex on both ends then clear the counters and check for the errors on the interface.

If you are NOT facing the similar problem on your giginterface then let it be as auto duplex on the both ends and check the duplex it negotiate with other end.



Hall of Fame Super Gold

Re: interface mismatch

In my experience if you hard code speed then duplex will not negotiate (negotiation of duplex is dependent on negotiation of speed). And if duplex is not negotiated then the default is to do half duplex. If you are going to code speed then code duplex.




Re: interface mismatch


Also the solution I have mentioned to hardcode the duplex at both ends is from my experience only.

As Rick suggested from his expereince that if speed is set then duplex wonnt be negotiated.

I agree with this as I think when we say auto-negotiation, we talk about both speed and duplex and if we set speed as manual that means autonegotiation is off and duplex wonnt be negotiated so set to default i.e. "half duplex"

I hope I got this explanation correct.

I got this interested link which clearly tell what to do and not to do with duplex and speed setting. It consider desktop NIC and cisco catalyst switch for reference and I hope it will be applied to OTHER NETWORK DEVICES ALSO WHICH SUPPORT AUTONEGOTIATION STANDARD(IEEE 802.3u)

"i made the previous statement in capitals as this what i think, correct me if i am wrong with above statement":)

it also explain why your giginterface goes down when you try to hardcode the duplex only at your end, it says:- combination of "auto" and "hardcode" on two connected device's giginterface will make the interface go down..


CreatePlease to create content