Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Internet Bandwidth Restriction

HI

Router 2811 got 3 Interfaces.  One Interface connected to INTERNETProvider, Second Interface connected to Sales_Dept, Third Interface connected to Business_Dept. Internet Bandwidth in Total is 8MB. I need assistance to allocate 6MB total bandwidth to Sales_Dept and 2MB total to Business_Dept

Sales_dept has 48port switch 2960, Business_Dept 24 port switch 2960. Gateway for users is the 2811 Router and both are on different subnets

THANKS

ST

  • WAN Routing and Switching
Everyone's tags (3)
3 REPLIES

Re: Internet Bandwidth Restriction

ST,

You may be able to do something like this:

policy-map Sales-Out

class class-default

shape average 2048000

policy-map Sales-In

class class-default

police 2048000

policy-map Business-In

class class-default

police 8192000

policy-map Business-Out

class class-default

shape average 8192000

int fa0/0

To Internet

int fa0/1

for Business

service-policy input Business-In

service-policy output Business-Out

int fa0/2

for Sales

service-policy input Sales-In

service-policy output Sales-Out

The above may not work, but it's worth a try. I wrote the above thinking that you had separate circuits initially, but now I figure that your departments have separate interfaces to the internal network. The above can be cleaned up if you have separate subnets for each:

Business subnet:

192.168.1.0/24

Sales subnet:

192.168.50.0/24

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

access-list 150 permit ip 192.168.50.0 0.0.0.255 any

class-map Business

match access-group 101

class-map Sales

match access-group 150

policy-map Outbound

class Sales

shape average 2048000

class Business

shape average 8192000

class class-default

Inbound traffic is going to be more difficult to manage. Does each department nat out their own address? If so, it would be much easier because then you could police traffic to their respective speeds to their natted address.

HTH,

John

Please rate all useful posts....

HTH, John *** Please rate all useful posts ***
New Member

Re: Internet Bandwidth Restriction

Thanks John for replying

My Public Subnet is  /28 , i can assign one public IP for each department

what additional config is needed with this setup

THANKS

ST

Re: Internet Bandwidth Restriction

You would need to nat out the public address and then police traffic coming back into the public. So, you could try something like this:

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

ip nat pool Business 5.5.5.5 5.5.5.5 prefix-length 28

ip nat pool Sales 5.5.5.6 5.5.5.6 prefix-length 28

ip nat inside source list 101 pool Business

ip nat inside source list 150 pool Sales

ip access-list ext SalesInbound

permit ip any host 5.5.5.6

ip access-list ext BusinessInbound

permit ip any host 5.5.5.5

class SalesInbound

match access-group name SalesInbound

class BusinessInbound

match access-group name BusinessInbound

policy-map Inbound

class BusinessInbound

police 8192000

class SalesInbound

police 2048000

class class-default

int fa0/0

desc to Internet

ip nat out

service-policy input Inbound

service-policy outpu

int

ip nat inside

int

ip nat inside

You'll need both shaping and policing in order to do what you want.

HTH,

John

Please rate all useful posts...

HTH, John *** Please rate all useful posts ***
402
Views
0
Helpful
3
Replies