Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Internet Link - Load-Balance/Failover

I have Router with 3 Ethernet-ports

ISP1= connected to F0/0

ISP2= connected to F0/1

Inside = connected to LAN F1/1

Is there a way to make load-balancing and Failover for these Internet Link.

The idea behind this is to have Office-executive browse internet with good speed and uninterrupted services....

Currently we have

Internet----<Internet-RTR>------BLUECOAT---<SWitch-connected to LAN>>

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Internet Link - Load-Balance/Failover

I am sorry not....

I think you can use source IP address to load blance.

Best Regards

Cheng

5 REPLIES
New Member

Re: Internet Link - Load-Balance/Failover

This is my Example:

!

!

!

interface Ethernet0/0 (LAN interface)

ip address 10.0.123.1 255.255.255.0

ip nat inside

ip policy route-map MAP1

half-duplex

!

interface Serial0/0 (WAN interface 1)

ip address 10.0.15.1 255.255.255.0

ip nat outside

encapsulation frame-relay

shutdown

frame-relay map ip 10.0.15.5 100 broadcast

!

interface Ethernet0/1

no ip address

shutdown

half-duplex

!

interface Serial0/1 (WAN interface 2)

ip address 10.0.14.1 255.255.255.0

ip nat outside

encapsulation frame-relay

frame-relay map ip 10.0.14.4 777 broadcast

!

ip nat inside source route-map NAT1 interface Serial0/1 overload

ip nat inside source route-map NAT2 interface Serial0/0 overload

ip nat inside source route-map NAT3 interface Serial0/0 overload

ip nat inside source route-map NAT4 interface Serial0/1 overload

no ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.15.5

ip route 0.0.0.0 0.0.0.0 10.0.14.4

!

!

access-list 1 permit 10.0.123.3

access-list 2 permit 10.0.123.2

!

route-map NAT3 permit 10

match ip address 2

match interface Serial0/0

!

route-map NAT2 permit 10

match ip address 1

!

route-map NAT1 permit 10

match ip address 1

match interface Serial0/1

!

route-map MAP1 permit 10

match ip address 1

set interface Serial0/1

!

route-map MAP1 permit 20

match ip address 2

set interface Serial0/0

!

route-map NAT4 permit 10

match ip address 2

!

!

Best Regards

Cheng

New Member

Re: Internet Link - Load-Balance/Failover

Thanks.

I will check the config on lab and check.

can you let me know what these hosts are 10.0.123.3 // 10.0.123.2 ( bluecoat / proxy-server // cache-engine )

New Member

Re: Internet Link - Load-Balance/Failover

10.0.123.3 and 10.0.123.2 is my test PC ip address. Their default gateway is 10.0.123.1.

Topology looks like this:

PC1 and PC2 connect Switch. Switch connect R1.

R1 lan interface is 10.0.123.1.

R1 have got two internet circuit connect ISP.

In current, PC1 use ISP1 with NAT to access Internet. PC2 use ISP2 with NAT to access Internet.

If ISP1 DOWN! PC1 use ISP2 access Internet. So is PC2.

Best Regards

Cheng

New Member

Re: Internet Link - Load-Balance/Failover

Thanks....

Did you did any test or implemented using hardware based Proxy.

in our scenario all users browse internet using BLUECOAT

New Member

Re: Internet Link - Load-Balance/Failover

I am sorry not....

I think you can use source IP address to load blance.

Best Regards

Cheng

169
Views
0
Helpful
5
Replies
CreatePlease to create content