Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Internet Load Balancing IOS

Has anyone sucessfully implemted Internet Load Balancing with OER with help of following config. example by cisco

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml

If yes please check my config . Sometimes internet works dead slow but i can see NAT entries and sometimes IP SLA will always fail . If i remove that tracking and put static routes it seems to work fine .

Has anyone implemented this sucessfully in production networks ?

Router#sh run

Building configuration...

Current configuration : 2147 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash c1841-advsecurityk9-mz.124-24.T3.bin

boot-end-marker

!

logging message-counter syslog

enable password cisco

!

no aaa new-model

dot11 syslog

ip source-route

!

!

!

!

ip cef

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

track 1 ip sla 1 reachability

default-state up

delay down 15 up 10

!

track 2 ip sla 2 reachability

default-state up

delay down 15 up 10

!

!

!

interface FastEthernet0/0

description ISP 1

ip address 10.2.2.211 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

description ISP 2

ip address 192.168.1.211 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1/0

switchport access vlan 20

!

interface FastEthernet0/1/1

switchport access vlan 20

!

interface FastEthernet0/1/2

switchport access vlan 20

!

interface FastEthernet0/1/3

switchport access vlan 20

!

interface Vlan1

no ip address

!

interface Vlan20

description LAN INTERFACE

ip address 172.16.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.2.2.1 track 1

ip route 0.0.0.0 0.0.0.0 192.168.1.1 track 2

ip http server

no ip http secure-server

!        

!

ip nat inside source route-map dhcp-nat interface FastEthernet0/0 overload

ip nat inside source route-map fixed-nat interface FastEthernet0/1 overload

!

ip sla 1

icmp-echo 4.2.2.2 source-interface FastEthernet0/0

frequency 5

ip sla schedule 1 start-time now

ip sla 2

icmp-echo 4.2.2.2 source-interface FastEthernet0/1

frequency 5

ip sla schedule 2 start-time now

access-list 110 permit ip 172.16.1.0 0.0.0.255 any

!

!

!

route-map fixed-nat permit 10

match ip address 110

match interface FastEthernet0/0

!

route-map dhcp-nat permit 10

match ip address 110

match interface FastEthernet0/1

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

no login

!

scheduler allocate 20000 1000

end

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Internet Load Balancing IOS

It sems fine but as most cisco things it should be verified live.

Note if you're using isp modem/router with nat, it would be better to configure them in bridge modem, and bring the public address directly to the router.

5 REPLIES
Hall of Fame Super Gold

Re: Internet Load Balancing IOS

Try updating IOS.

Note you don't need mss adjust.

Also there is to see why the tracking fails.

New Member

Re: Internet Load Balancing IOS

Do you think configuration is fine ? Any recommendations for the IOS , should i try 15.x ?

Hall of Fame Super Gold

Internet Load Balancing IOS

It sems fine but as most cisco things it should be verified live.

Note if you're using isp modem/router with nat, it would be better to configure them in bridge modem, and bring the public address directly to the router.

New Member

Re: Internet Load Balancing IOS

Thats what I was thinking of yesterday . Because the Cisco router is doing NAT and then the ISP Modem/Router is doing NAT again this can be a problem .

I will test this out somehow and let you know .

New Member

Re: Internet Load Balancing IOS

I tested it with the public IP terminated on routers and it worked great . IPSLA did had some problems and thus I put static routes for the ip to which icmp packets were being sent and created default route with track .

350
Views
0
Helpful
5
Replies
CreatePlease to create content