Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Intervlan Routing Frustrations

Hello All,

Do any of you have some clear directions on how to enable intervlan routing for the Catalyst 4500 Series? I have a very simple network, and need to vlan it.

Here is the basic layout:

Internet--Firewall(non cisco)--Catalyst 4506

I have my two vlans created. That works great, but I cannot get my routing to work. I have the Supervisor II+ card which support routing. I have tried to follow the directions at this link: http://www.cisco.com/warp/public/473/howto_L3_intervlanrouting.html , but I dont really have an defualt router its my firewall.

Also other links have told me to create an Switch Virtual Interface, but I thought I did that when I added and IP address to my Vlans. I am posting my Show Run and Show route statments.

So far my vlans work, but there is no routing between subnets. I have always done this before with Trunking and an actual router, not just on one device. Any help would be most appreciated.

*****Show Run ******

!

!

vlan internal allocation policy ascending

!

interface GigabitEthernet5/34

switchport access vlan 2

!

interface Vlan1

ip address 172.16.0.254 255.255.0.0

!

interface Vlan2

ip address 192.168.1.254 255.255.255.0

ip helper-address 172.16.0.10

!

router rip

network 172.16.0.0

network 192.168.1.0

** Show Route **

Gateway of last resort is not set

C 172.16.0.0/16 is directly connected, Vlan1

C 192.168.1.0/24 is directly connected, Vlan2

6 REPLIES

Re: Intervlan Routing Frustrations

you dont need rip unless there are other devices on either vlans that also run the same.

Your config looks fine and devices in either vlans should be able to talk to each other.

Is it that clients are not able to get DhCP or is it that you cannot ping between two devices in vlan 1 and 2 ?

If its a DHCP issue, Try setting portfast on ports on the switch (Vlan2) so that the port come up (bypasses STP timer requirements) and helps in faster DHCP.

PS: Please rate the post if you found it helpful!

New Member

Re: Intervlan Routing Frustrations

Both pinging and dhcp do not work.

I put a 192.168.1.x ip on my laptop, set the GW to 192.168.1.254. I can ping 192.168.1.254 that I put on the Vlan 2. But i cannot ping anything in the 172.16.0.x range.

The only reason I enabled RIP is I was hoping it might create my routes for me. I had static ones in, but thought I did those wrong.

Thanks for the help.

Matt

Re: Intervlan Routing Frustrations

Have you verified, if the devices in 172.16.x.x network have been configured the appropriate mask (/16) and also set with the right default gateway ?

Can you ping the same devices on 172.16.x.x network from the switch ?

HTH

PS: Please rate the post if it helped you!

New Member

Re: Intervlan Routing Frustrations

Hi mgoodhue,

You need to check your vlan configuration try to put a port in vlan 1 and other onr in vlan 2 than put two machine there and ping to each other and remember while testing believe on static ip addressing once you are able to ping each other than try this with DHCP.

And one more thing be sure that you have entered ip routing command in your switch.

Hope this help

Kamlesh Sharma

Re: Intervlan Routing Frustrations

Is your vlan1 int up.

If it is up, can you ping the vlan1 interface's IP, 172.16.0.254 from your PC on vlan2. If you are unable to ping this address then "ip routing" mayn't be enabled on the switch. You can enable it from the global config mode using the cmd "ip routing". You don't need a routing protcol as the networks are directly connected to the switch.

If you can ping the vlan1 int IP but unable to ping a PC on vlan1 then make sure the PC is configured with the correct default gateway address and subnet mask. Ensure the switchports PC's are connected are assigned to the correct access vlan.

If the problem is still not resolved, please post the complete config from the switch, show vlan, show int vlan, show ip route.

New Member

Re: Intervlan Routing Frustrations

First ensure that your hosts that are connected to the switch have the correct vlans assigned to them and also you have to enable layer 2 by issuing:

vlan 1-2

exit

That should sort out your issues. Since the routes are connected any hosts that are using that router do not need a default just a default gateway which is your 4500.

119
Views
0
Helpful
6
Replies