Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Intervlan Routing Issue

I am not able to communicated between vlan 1, 2,3, although inter vlan routing is enabled on cisco 3750 l3 switch.

Bellow is the configuration.

Please suggest on it

APHS_CORE#sh running-config                                  

Building configuration...                                    

                                                             

Current configuration : 7022 bytes                           

!                                                            

version 12.2                                                 

no service pad                                               

service timestamps debug uptime                              

service timestamps log uptime                                

service password-encryption                                  

!                                                            

hostname APHS_CORE                                           

!                                                            

enable secret 5 $1$ZIFI$evixjAIDgo9nV/451.v9U0               

enable password 7 14050107                                   

!                                                            

no aaa new-model                                             

switch 1 provision ws-c3750g-48ts                            

ip subnet-zero                                               

ip routing                                                   

!                                                            

!                                                            

!                                                            

!                                                            

no file verify auto                                          

spanning-tree mode pvst                                      

spanning-tree extend system-id                               

!                                                            

vlan internal allocation policy ascending                    

!                                                            

interface GigabitEthernet1/0/1                               

description WS-038                                          

switchport access vlan 2                                    

spanning-tree portfast                                      

!                                                            

interface GigabitEthernet1/0/2                               

description WS-010                                          

switchport access vlan 2                                    

spanning-tree portfast                                      

!                                                                             

interface GigabitEthernet1/0/3                                                

description WS-007                                                           

switchport access vlan 2                                                     

spanning-tree portfast                                                       

!                                                                             

interface GigabitEthernet1/0/4                                                

description WS-009                                                           

switchport access vlan 2                                                     

spanning-tree portfast                                                       

!                                                                             

interface GigabitEthernet1/0/5                                                

description UD01                                                             

switchport access vlan 3                                                     

storm-control multicast level 0.05                                           

spanning-tree portfast                                                       

!                                                                             

interface GigabitEthernet1/0/6                                                

description PI01                                                             

switchport access vlan 3                                                     

spanning-tree portfast                                                       

!                                                                             

interface GigabitEthernet1/0/7                                                

description PI02                                                             

switchport access vlan 3                                                     

spanning-tree portfast                                                       

!                                                                             

interface GigabitEthernet1/0/8                                                

description LP01                                                             

switchport access vlan 3                                                     

spanning-tree portfast                                                       

!                                                                             

interface GigabitEthernet1/0/9                                                

description HL01                                                             

switchport access vlan 3                                                     

spanning-tree portfast                                                       

!                                                                             

interface GigabitEthernet1/0/10                                               

description EN02                                                             

spanning-tree portfast                 

!                                       

interface GigabitEthernet1/0/11         

description HL02                       

switchport access vlan 3               

spanning-tree portfast                 

!                                       

interface GigabitEthernet1/0/12         

description WS-011                     

switchport access vlan 2               

spanning-tree portfast                 

!                                       

interface GigabitEthernet1/0/13         

description OT1DF2                     

switchport access vlan 3               

spanning-tree portfast                 

!                                       

interface GigabitEthernet1/0/14         

description PB2LP1                     

switchport access vlan 3               

spanning-tree portfast                 

!                                       

interface GigabitEthernet1/0/15         

description PB1CS12                    

switchport access vlan 3               

spanning-tree portfast                 

!                                       

interface GigabitEthernet1/0/16         

description PB6LP1                     

switchport access vlan 3               

spanning-tree portfast                 

!                                       

interface GigabitEthernet1/0/17         

description PB1HL1                     

switchport access vlan 3               

spanning-tree portfast                 

!                                       

interface GigabitEthernet1/0/18               

description WS-039                           

switchport access vlan 2                     

spanning-tree portfast                       

!                                             

interface GigabitEthernet1/0/19               

description LP02                             

switchport access vlan 3                     

spanning-tree portfast                       

!                                             

interface GigabitEthernet1/0/20               

description LP03                             

switchport access vlan 3                     

spanning-tree portfast                       

!                                             

interface GigabitEthernet1/0/21               

description EN01                             

switchport access vlan 3                     

spanning-tree portfast                       

!                                             

interface GigabitEthernet1/0/22               

description PB2HL1                           

switchport access vlan 3                     

spanning-tree portfast                       

!                                             

interface GigabitEthernet1/0/23               

description HL03                             

switchport access vlan 3                     

spanning-tree portfast                       

!                                             

interface GigabitEthernet1/0/24               

description PB1CS34                          

switchport access vlan 3                     

spanning-tree portfast                       

!                                             

interface GigabitEthernet1/0/25               

description RB01                             

switchport access vlan 3                     

spanning-tree portfast                       

!                                   

interface GigabitEthernet1/0/26     

description DR-SERVER-LEVEL1       

switchport access vlan 3           

spanning-tree portfast             

!                                   

interface GigabitEthernet1/0/27     

description DR-SERVER-LEVEL2       

switchport access vlan 2           

spanning-tree portfast             

!                                   

interface GigabitEthernet1/0/28     

description SAL-SERVER1-LEVEL1     

switchport access vlan 3           

spanning-tree portfast             

!                                   

interface GigabitEthernet1/0/29     

description SAL-SERVER2-LEVEL1     

switchport access vlan 3           

spanning-tree portfast             

!                                   

interface GigabitEthernet1/0/30     

description SAL-SERVER1-LEVEL2     

switchport access vlan 2           

spanning-tree portfast             

!                                   

interface GigabitEthernet1/0/31     

description SAL-SERVER2-LEVEL2     

switchport access vlan 2           

spanning-tree portfast             

!                                   

interface GigabitEthernet1/0/32     

description CR-WS01-LEVEL2         

switchport access vlan 3           

spanning-tree portfast             

!                                   

interface GigabitEthernet1/0/33     

description CR-WS02-LEVEL2         

switchport access vlan 2         

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/34   

description CR-WS03-VLAN1        

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/35   

description CR-WS04-VLAN1        

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/36   

description CR-WS05-VLAN1        

switchport access vlan 2         

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/37   

switchport access vlan 2         

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/38   

switchport access vlan 2         

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/39   

switchport access vlan 2         

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/40   

switchport access vlan 2         

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/41   

switchport access vlan 3         

spanning-tree portfast           

!                                 

interface GigabitEthernet1/0/42   

spanning-tree portfast           

!                                      

interface GigabitEthernet1/0/43        

spanning-tree portfast                

!                                      

interface GigabitEthernet1/0/44        

spanning-tree portfast                

!                                      

interface GigabitEthernet1/0/45        

spanning-tree portfast                

!                                      

interface GigabitEthernet1/0/46        

switchport access vlan 3              

spanning-tree portfast                

!                                      

interface GigabitEthernet1/0/47        

switchport trunk encapsulation dot1q  

switchport mode trunk                 

!                                      

interface GigabitEthernet1/0/48        

switchport trunk encapsulation dot1q  

switchport mode trunk                 

!                                      

interface GigabitEthernet1/0/49        

switchport trunk encapsulation dot1q  

switchport mode trunk                 

!                                      

interface GigabitEthernet1/0/50        

switchport trunk encapsulation dot1q  

switchport mode trunk                 

!                                      

interface GigabitEthernet1/0/51        

switchport trunk encapsulation dot1q  

switchport mode trunk                 

!                                      

interface GigabitEthernet1/0/52        

switchport trunk encapsulation dot1q  

switchport mode trunk                 

!                                                    

interface Vlan1                                      

ip address 10.36.24.1 255.255.255.0                 

standby ip 10.36.24.4                               

!                                                    

interface Vlan2                                      

ip address 10.36.25.241 255.255.255.0               

standby ip 10.36.25.243                             

standby priority 110                                

!                                                    

interface Vlan3                                      

ip address 10.36.26.241 255.255.255.0               

standby ip 10.36.26.243                             

standby priority 110                                

!                                                    

ip classless                                         

ip route 0.0.0.0 0.0.0.0 10.36.24.3                  

ip http server                                       

!                                                    

ip access-list extended SAL1                         

permit udp 10.36.26.0 0.0.0.255 host 10.22.19.16    

permit udp any any                                  

ip access-list extended SAL1_out                     

permit ip host 10.22.19.16 10.36.26.0 0.0.0.255     

permit ip host 10.2.219.91 10.36.26.0 0.0.0.255     

permit ip host 10.2.161.16 10.36.26.0 0.0.0.255     

permit ip host 10.44.108.110 10.36.26.0 0.0.0.255   

ip access-list extended SAL2                         

permit ip 10.36.25.0 0.0.0.255 host 10.22.19.16    

permit udp any any                                  

permit ip 10.36.25.0 0.0.0.255 host 10.44.108.110   

permit ip 10.36.25.0 0.0.0.255 host 10.2.219.91     

deny   ip any any                                   

ip access-list extended SAL2_out                      

permit ip host 10.2.161.16 10.36.25.0 0.0.0.255      

permit udp any any                                   

permit ip host 10.22.19.16 10.36.25.0 0.0.0.255      

permit ip host 10.44.108.110 10.36.25.0 0.0.0.255    

permit ip host 10.2.219.91 10.36.25.0 0.0.0.255      

!                                                     

access-list 101 deny   ip any any                     

access-list 102 deny   ip any any                     

access-list 111 deny   igmp any any                   

snmp-server community public RO                       

snmp-server location APHS Control Room                

snmp-server contact Suresh Malviya                    

!                                                     

control-plane                                         

!                                                     

!                                                     

line con 0                                            

line vty 0 4                                          

password 7 104F191116                                

login                                                

line vty 5 15                                         

password 7 141602031F                                

login                                                

!                                                     

!                                                     

end                                                                                                                      

16 REPLIES

Re: Intervlan Routing Issue

Hi,

If possible, pls post sh ip route and sh vlan of the switch

HTH

Hitesh Vinzoda

Pls rate useful posts

Community Member

Re: Intervlan Routing Issue

sh ip route

Gateway of last resort is 10.36.24.3 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 3 subnets

C       10.36.26.0 is directly connected, Vlan3

C       10.36.24.0 is directly connected, Vlan1

C       10.36.25.0 is directly connected, Vlan2

S*   0.0.0.0/0 [1/0] via 10.36.24.3

10.36.24.3 is router and a static route is given for it

sh vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Gi1/0/34, Gi1/0/35, Gi1/0/42

                                                Gi1/0/43, Gi1/0/44, Gi1/0/45

2    VLAN0002                         active    Gi1/0/1, Gi1/0/2, Gi1/0/3

                                                Gi1/0/4, Gi1/0/12, Gi1/0/18

                                                Gi1/0/27, Gi1/0/30, Gi1/0/31

                                                Gi1/0/33, Gi1/0/36, Gi1/0/37

                                                Gi1/0/38, Gi1/0/39, Gi1/0/40

3    VLAN0003                         active    Gi1/0/5, Gi1/0/6, Gi1/0/7

                                                Gi1/0/8, Gi1/0/9, Gi1/0/10

                                                Gi1/0/11, Gi1/0/13, Gi1/0/14

                                                Gi1/0/15, Gi1/0/16, Gi1/0/17

                                                Gi1/0/19, Gi1/0/20, Gi1/0/21

                                                Gi1/0/22, Gi1/0/23, Gi1/0/24

                                                Gi1/0/25, Gi1/0/26, Gi1/0/28

                                                Gi1/0/29, Gi1/0/32, Gi1/0/41

                                                Gi1/0/46

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        0      0

2    enet  100002     1500  -      -      -        -    -        0      0

3    enet  100003     1500  -      -      -        -    -        0      0

1002 fddi  101002     1500  -      -      -        -    -        0      0

1003 tr    101003     1500  -      -      -        -    -        0      0

1004 fdnet 101004     1500  -      -      -        ieee -        0      0

1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type              Ports

------- --------- ----------------- ------------------------------------------

Community Member

Re: Intervlan Routing Issue

Configure a Routing protocol like EIGRP or RIP v2 in switch for all the vlan Networks.

You're not using a Router for Intervlan Communication.

Normally if ur not using Router in a stick for Intervlan communication, you need to configure a Routing Protocol like EIGRP or RIP.

Best Regards,

Dasuntha

Community Member

Re: Intervlan Routing Issue

I have already used following commands on the switch

ip routing

router ospf

I thing above commands will enable inter vlan routing.

Community Member

Re: Intervlan Routing Issue

If you configured ospf properly, we can see routes learned from OSPF.

But in your routing table, I cant see any routes learned from OSPF.

So, double check the OSPF config.

Or show me ur config & i can double check for you.

Regards,

Dasuntha

Re: Intervlan Routing Issue

Advait,

wonder how ospf/eigrp or rip enables inter vlan routing here, unless untill you want to send subnets attached with the Vlans to another device

Just breezed through your configurations:-

1.You need to check whether the "trunking" is happening with the outher switches first. (sh interfaces trunk)

2.The Associated hosts in the Vlan should point to their respective SVI's as gateway. (ping test)

Could you explain the need for Standby ?

3. If using standby in you design, your hosts should point to the standby address configured in the SVI's.

Better if you could get it working in a normal way before hardening it.

Re: Intervlan Routing Issue

Hi,

Post "sh standy brief" from both the switches, also do you have a link between 2 switches.

HTH

Hitesh Vinzoda

Pls rate useful posts

Community Member

Re: Intervlan Routing Issue

What IP address have you specified as the gateway on hosts ?

Is it the HSRP virtual IP address ? For example for hosts connected to VLAN 1 should have the gateway 10.36.24.4

Is that correct ?

Thanks & Regards

Zeeshan Sanaullah

Community Member

Re: Intervlan Routing Issue

Hi Tharak,

You can see in the question that, he is using only 3 switches. No Router.

So, for inter vlan communication, you need a Layer 3 Switch to do the routing between each vlan.

Otherwise you cant communicate with each vlan subnet.

I used this setup using EIGRP & L3 switch & its working fine.

And routing much faster than when we used a Router.

Pls test this & you'll see it.

Regards,

Dasuntha

Re: Intervlan Routing Issue

Dasuntha,

He's using a L3 switch or he wouldn't be able to enable routing on it. That aside, regardless of the routing protocol being used, the OP should be able to ping all 3 vlans from a host in ANY vlan on that switch as long as the default gateway for the host is correct. Also, it doesn't matter if the HSRP address is used as the gateway or the physical address.

Tharak,

If a host is connected to the switch, does the vlan show to be up?

Can you ping the physical address from the host of the vlan that it's a member of? (ping the vlan2 address if you're connected to a port that is in that vlan).

If you get a response, can you ping vlan 1?

Do you have edge switches connected to the 3750 and trying to ping from the edge switch?

HTH,

John

HTH, John *** Please rate all useful posts ***
Community Member

Re: Intervlan Routing Issue

John,

That's what I said.

When we use L3 switches for InterVLAN routing, we need to configure Routing Protocol like RIP, EIGRP or OSPF.

Otherwise Inter VLAN communication will not work.

YOu can see from this SH Ip Route output that no route was learnt from OSPF.

That means its not configured properly.

Regards,

Dasuntha

Community Member

Re: Intervlan Routing Issue

Hi Dasuntha Dinesh,

Tharak Abraham is right, You do need any routing protocol for InterVLAN to work. The routing protocol output shows all VLAN subnets as connected routes even if you were to run a routing protocol still you will not see routes from any routing protocol for these subnets as the administrative distance of connected routes is lower than any routing protocol

Thanks & Regards

Zeeshan Sanaullah

Community Member

Re: Intervlan Routing Issue

Hi Tharak & Zeshaan,

Yes Correct. I noticed now that all the vlan interfaces with ip address are configured in SwitchA.

So, no need of Routing Protocol.


Advait,

I tested the same setup in PT using ur config & its working fine for me.

And Inter VLAN communication between vlan 1,2,3 is working fine.

Regards,

Dasuntha

Re: Intervlan Routing Issue

John,

The host should be able to ping the SVI of the corresponding Vlan, if i got your question correct.

The SVI's acts as default gateways to the corresponding Vlan's...so communication between hosts in seperate Vlans also will happen without any other configuration. (Similar to the Router on Switch fundamental)

Re: Intervlan Routing Issue

Tharak,

Sorry. I directed the question to you, but it was meant for the OP.

John

HTH, John *** Please rate all useful posts ***

Re: Intervlan Routing Issue

Advait,

The switch configuration looks OK!!!

I am trying to understand from what are you pinging from and to what?

Are the PC's you ping from and to are on the same switch?

What is the PC default gatway IP & MAC address?

Is the APHS_CORE connected to another switch / HSRP ?

Can you provide a connectivity diagram?

If you can provide the info above then we shoudl be able to assisit you further

Francisco

797
Views
0
Helpful
16
Replies
CreatePlease to create content