Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

IOS bad checksum

Hi dear Cisco fellows,

I have a 837 cisco router with an empty flash. I am trying to download from tftpserver an IOS image but i always got a Bad Checksum error:

rommon 24 > dir flash:

File size Checksum File name

9819796 bytes (0x95d694) 0x8bb2 c837-k9o3sy6-mz.124-8a.bin (bad checksum

: 0x9ba4)

rommon 25 > boot flash:c837-k9o3sy6-mz.124-8a.bin

Checksum failed on c837-k9o3sy6-mz.124-8a.bin

Expected checksum: 8bb2, calculated checksum: 9ba4

open: file "c837-k9o3sy6-mz.124-8a.bin" not found

open(): Open Error = -1

loadprog: error - on file open

boot: cannot load "flash:c837-k9o3sy6-mz.124-8a.bin"

What can i check?

5 REPLIES
Silver

Re: IOS bad checksum

Download a fresh copy from CCO and try the new image.

HTH

Hall of Fame Super Silver

Re: IOS bad checksum

I agree that trying a new image is a good idea. And depending on what you are using to transfer the image make sure that it is done as a binary transfer rather than as an integer transfer.

HTH

Rick

New Member

Re: IOS bad checksum

I have downloaded the latest IOS available and i get a bad checksum, i have tried other releases and it is the same.

I am using tftp server from solarwinds and i launch tftpdnld from Hyperterminal.

File reception completed.

Copying file c837-k9o3sy6-mz.124-7c.bin to flash.

Erasing flash

Programming flash .Programming flash .Programming flash ........................

................................

rommon 28 > dir flash:

File size Checksum File name

9988944 bytes (0x986b50) 0x485e c837-k9o3sy6-mz.124-7c.bin (bad checksum

: 0x358e)

New Member

Re: IOS bad checksum

The badchecksum is for the router checksum. What does that mean?

New Member

Re: IOS bad checksum

Have you tried to delete the partition on the flash device, erase the filesystem and recreate it? I was thinking there might be something fouled on the flash device that is causing the checksum to fail.

890
Views
0
Helpful
5
Replies
CreatePlease to create content