Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IOS DHCP: trying to configure manual binding

Router: 1605R used as nat/pat box to cable modem. Using ios c1600-k8osy-mz.123-9b.bin.

I'm trying to get a manual DHCP binding working. So far, no success. This is my corrent config:

ip dhcp excluded-address 192.168.24.192

ip dhcp excluded-address 192.168.24.1

ip dhcp excluded-address 192.168.24.2

ip dhcp excluded-address 192.168.24.3

ip dhcp ping timeout 100

!

ip dhcp pool pool02

host 192.168.24.4 255.255.255.0

hardware-address 0011.2fdf.b064 ieee802

default-router 192.168.24.2

dns-server <deleted>

client-name p4-3k

!

ip dhcp pool pool01

network 192.168.24.0 255.255.255.0

default-router 192.168.24.2

dns-server <deleted>

!

!

interface Ethernet0

description cable modem, get IP addr from ISP via DHCP client.

ip address dhcp client-id Ethernet0

ip nat outside

!

interface Ethernet1

description local LAN

ip address 192.168.24.2 255.255.255.0

ip nat inside

<other irrelevant stuff deleted>

Now, when i do a dhcp renew with my pc with the mac address 0011.2fdf.b064 i get an address from the pool (192.168.24.5) instead of the manually reserved 192.168.24.4 address.

I wonder what i'm doing wrong here, or maybe just don't understand.

The DHCP client part on E0 works fine. It's the DHCP server for the internal LAN that's bugging me.

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: IOS DHCP: trying to configure manual binding

3 REPLIES
Bronze

Re: IOS DHCP: trying to configure manual binding

Yop are probably not doing anything wrong as far as I understand that is the it's supposed to work.

Having said that I have never got it working that way.

However try this imsteed:

ip dhcp pool pool02

host 192.168.24.4 255.255.255.0

client-identifier 0100.112f.dfb0.64

default-router 192.168.24.2

dns-server

The 01 before the MAC address is the same as ieee802, when using the command hardware-address.

But please try it out and let me know what you think.

Silver

Re: IOS DHCP: trying to configure manual binding

New Member

Re: IOS DHCP: trying to configure manual binding

Thanks guys! That did the trick. I got my fixed lease now.

235
Views
10
Helpful
3
Replies