Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

IOS IP SLA MisConfigurtions

hi 

I  am actually having a problem with the configurations of IOS sla for default backup link ,Can any one guide me what i might be misconfiguring as this is my first time in configuring the IOS SLA feature .

Well the topology is simple .i have three routers R1,R2 and CoreSLA with the following topology

R1 ---> interface f0/0 <--> CoreSLA--> interface g0/0

R2----> interface f0/1 <--> CoreSLA--> interface g0/1

R1-->Loopback Interface 0=1.1.1.1{to simulate a single IP at destination }

R2-->Loopback Interface 0=1.1.1.1

R1 ---> interface f0/0 = 10.1.1.2/24

R2----> interface f0/1=11.1.1.2/24

CoreSLA--> interface g0/0 = 10.1.1.1/24

CoreSLA--> interface g0/1= 11.1.1.2/24

Now following ipsla is configured at CoreSla and  two default route

ip sla 100

icmp-echo 1.1.1.1 source-interface GigabitEthernet0/0

timeout 500

frequency 3

ip sla schedule 100 life forever start-time now

track 100 rtr 100 reachability
delay down 10 up 20
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0  track 100
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 10
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 20
Now my objective is that if GigabitEthernet0/0 is up but some how i cannot go reach my destination from GigabitEthernet0/0 then i may be ablw to use GigabitEthernet0/1 for the network and it should be replaced there in routing table.
Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: IOS IP SLA MisConfigurtions

Hi,

I think your tracking and IP sla is fine, but you have 3 static routes configred. You can remove the 2nd static "ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 10" in your configure.

HTH,

Lei Tian

5 REPLIES
Cisco Employee

Re: IOS IP SLA MisConfigurtions

Hi,

I think your tracking and IP sla is fine, but you have 3 static routes configred. You can remove the 2nd static "ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 10" in your configure.

HTH,

Lei Tian

Community Member

Re: IOS IP SLA MisConfigurtions

it is working after removing the route ,but when the primary link is up again it is not going back to primary path .

Community Member

Re: IOS IP SLA MisConfigurtions

Now its working fine i have removed the extra route and then i have changed the topology as well .......instead of using loopback i have placed a switch there so that R1 and R2 connect to that switch which has vlan 1 configured as 1.1.1.1 ,Thanks for your help

Cisco Employee

Re: IOS IP SLA MisConfigurtions

You welcome; glad it works for you.

Community Member

Re: IOS IP SLA MisConfigurtions

hi letian

i want to add another thing in the discussion that after configuring ip sla on the router , the router memory utilization started to increase per day and after 1 week it went to 90 %. i checked the router and found out that the router interface buffer was full and after contacting the TAC they told us that whenever u use IP SLA dont use this interface in ip route command to track

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0  track 100
rather use next hop ip
ip route 0.0.0.0 0.0.0.0 next_hop_ip  track 100
and when i changed all the routes the memory utilization came to normal.
rgds

517
Views
0
Helpful
5
Replies
CreatePlease to create content