Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IOS NAT over multiple outbound interfaces

Our 3845 have 2 public FEthernet interfaces with /24 addresses and a public Serial P2P interface with default outbound route. Can we make internal 10.0.0.0/24 hosts NATed over those 2 public netblocks /24 instead of Serial global PAT and able to route those NATed public IP through this Serial interface and reach internet?

Thanks,

Dave

3 REPLIES

Re: IOS NAT over multiple outbound interfaces

Dave,

I hope I understood your requirement correctly. You have two public class C networks and you want to NAT your internal hosts to use an address from this range.

You sure can do it provided, your ISP connected via Serial Interface knows these two networks can be reached via their serial connection to you.

If you have a different requirement then could you clarify that for us.

HTH,

Sundar

New Member

Re: IOS NAT over multiple outbound interfaces

Hi Sundar,

Thanks for the reply, So is this following config. works or do I have to use vrf?

Thanks,

Dave

interface vlan10

description $inside private address$

ip address 10.10.10.0 255.255.255.0

ip nat inside

interface Vlan57

description $outside public address$

ip address 64.57.xx.1 255.255.255.0

ip nat outside

interface Vlan65

description $outside public address$

ip address 64.65.xx.1 255.255.255.0

ip nat outside

interface Serial2/0

description $P2P to ISP$

ip address 46.xx.xx.54 255.255.255.252

ip nat outside

ip route 0.0.0.0 0.0.0.0 46.xx.xx.53

ip nat pool NET65 64.65.xx.4 64.65.xx.14 netmask 255.255.255.0

ip nat pool NET57 64.57.xx.4 64.57.xx.14 netmask 255.255.255.0

ip nat inside source list 4 pool NET65 overload

ip nat inside source list 4 pool NET57 overload

access-list 4 permit 10.10.10.0 0.0.0.255

Re: IOS NAT over multiple outbound interfaces

Dave,

The configuration looks good. Are these two networks, 64.57.xx.0/24 & 64.65.xx.0/24, assigned to you by the ISP connected via serial2/0 and if it is then it should work fine.

You don't even need to use NAT overload option as the config only shows you have 254 internal hosts or less. NAT overload makes it PAT, which I believe you don't want.

HTH,

Sundar

385
Views
0
Helpful
3
Replies