Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

IOS Noob here, load-balancing and/or fail over configuration

Hello There,

Firstly a brief introduction of what i have:

A cisco 1941 Router + HWIC-2FE

2 Static IP Incoming Lines (Both of them 5mb UP/Down)

Now i have seen all over the forums what i could find , and i have setup a SLA fail over, but for some reason it alaways gives problem , if anoyone is kind enough to have time and some solution at least for fail over and not for Load-Balancing , it would be really appriciated .

Thanks for your time

3 REPLIES
Purple

IOS Noob here, load-balancing and/or fail over configuration

Hi,

post your config and topology it will be easier to troubleshoot.

Regards.

Alain

Don't forget to rate helpful posts.
Community Member

Re: IOS Noob here, load-balancing and/or fail over configuration

Ok thanks , here is the config :

!

no aaa new-model

!

!

!

!

no ipv6 cef

no ip subnet-zero

no ip source-route

ip cef

!

!

!

!

ip domain name 8milalb.loc

ip name-server 208.67.222.222

ip name-server 208.67.220.220

ip port-map sip port udp 5060 list 2 description SIP

!

!

!

!

redundancy

!

!

!

track 1 ip sla 1 reachability

delay down 9 up 10

!

track 2 ip sla 2 reachability

delay down 9 up 10

!

!

!

!

!

!

!

interface GigabitEthernet0/0

description WAN$ETH-WAN$

ip address 109.69.1.110 255.255.255.248

ip load-sharing per-packet

ip nat outside

ip virtual-reassembly

no ip route-cache cef

duplex auto

speed auto

arp timeout 3

!

!

interface GigabitEthernet0/1

description LAN$ES_LAN$$ETH-LAN$

ip address 192.168.10.1 255.255.254.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

!

interface FastEthernet0/0/0

description TRINNG$ETH-WAN$

ip address 95.107.1.6 255.255.255.252

ip load-sharing per-packet

ip nat outside

ip virtual-reassembly

no ip route-cache cef

duplex auto

speed auto

arp timeout 3

!

!

interface FastEthernet0/0/1

no ip address

shutdown

duplex auto

speed auto

!

!

no ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

!

no ip nat service sip udp port 5060

ip nat inside source route-map ABCOM interface GigabitEthernet0/0 overload

ip nat inside source route-map TRING interface FastEthernet0/0/0 overload

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 track 1

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0/0 100 track 2

!

ip sla 1

icmp-echo 109.69.1.1 source-interface GigabitEthernet0/0

timeout 1000

threshold 5

frequency 5

ip sla schedule 1 life forever start-time now

ip sla 2

icmp-echo 95.107.10.1 source-interface FastEthernet0/0/0

timeout 1000

threshold 3

frequency 3

ip sla schedule 2 life forever start-time now

no logging trap

!

!

!

!

route-map ABCOM permit 10

match interface GigabitEthernet0/0

!

route-map TRING permit 10

match interface FastEthernet0/0/0

!

!

snmp-server community public RO

snmp-server ifindex persist

!

control-plane

!

!

!

exception protocol ftp

scheduler allocate 20000 1000

end

Silver

IOS Noob here, load-balancing and/or fail over configuration

This should help:

considering gig0/0 connects to 1st isp and gig0/1 connects to 2nd isp

ip route 4.2.2.2 255.255.255.255 <1st isp gateway> permanent

track1 ip route 4.2.2.2 reachability

ip route 0.0.0.0 0.0.0.0 <1st isp gateway> track 1
ip route 0.0.0.0 0.0.0.0 <2nd isp gateway> 10

ip nat inside source route-map ISP1 gig0/0 overload
ip nat inside roure route-map ISP2 gig0/1overload

route-map ISP1
match interface gig0/0

route-map ISP2
match int gig0/1

HTH

Mukti

---
Posted by WebUser Mukti Chandwani

630
Views
0
Helpful
3
Replies
CreatePlease to create content