Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

IOS upgrade over WAN (using TFTP)

Hi All,

I need to upgrade my router IOS over a WAN connection.

the problem i face is that when i establish the command: "copy tftp: flash:" it gives my (time out). when i checked the logs on the TFTP server i found that the request is received from the Private IP of the router (the one configured on the Serial interface) not the real IP address.

and the TFTP server machine can't access the router private IP address over the WAN.

Here is the configuration on the router, I'll be so glad if someone can help me is soling this issue.

How can i let the TFTP requests coming from the router with the Real IP which is configured on the Interface Fa0/0?

Current configuration : 1315 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip source-route

!

!

!

!

ip cef

multilink bundle-name authenticated

!

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0/0

ip address 196.219.x.y 255.255.255.224 (My Real IP Address)

duplex auto

speed auto

no keepalive

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type q933a

!

interface Serial0/0/0.16 point-to-point

ip address 172.16.133.2 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 16

!

interface Serial0/0/1

no ip address

encapsulation frame-relay IETF

ignore dcd

frame-relay lmi-type q933a

!

interface Serial0/0/1.16 point-to-point

ip address 172.16.134.2 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 16

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Serial0/0/0.16

ip route 0.0.0.0 0.0.0.0 Serial0/0/1.16

!

!

no ip http server

!

access-list 80 permit 196.219.224.1

!

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: IOS upgrade over WAN (using TFTP)

Mohamed

There is an aspect of your question that puzzles me. The default behavior of IOS is to use as the source address the address of the outbound interface. If the router is using the address of the serial then it believes that the serial is the best way to get to the TFTP server. If the TFTP server is on the inside of your network then why can it not get to the inside address of your router?

But you asked how to get the router to use the address of Fa0/0 and the answer is straightforward. Use this command:

ip tftp source-interface fa0/0

and then the router will use the source address of Fa0/0 for its TFTP traffic.

HTH

Rick

3 REPLIES
Hall of Fame Super Silver

Re: IOS upgrade over WAN (using TFTP)

Mohamed

There is an aspect of your question that puzzles me. The default behavior of IOS is to use as the source address the address of the outbound interface. If the router is using the address of the serial then it believes that the serial is the best way to get to the TFTP server. If the TFTP server is on the inside of your network then why can it not get to the inside address of your router?

But you asked how to get the router to use the address of Fa0/0 and the answer is straightforward. Use this command:

ip tftp source-interface fa0/0

and then the router will use the source address of Fa0/0 for its TFTP traffic.

HTH

Rick

New Member

Re: IOS upgrade over WAN (using TFTP)

Hi, Thanks alot for the last command ;-)

it solves my problem

For your question; my TFTP server is not on the LAN it's over the WAN so it have to get it through the serial interface but the problem was that it takes the IP of the serial interface which is a private IP between the router and the ISP. and the real IP address is configured on the Fa0/0...

Little bit tricky but it works...

Thank u very much :-)

Hall of Fame Super Silver

Re: IOS upgrade over WAN (using TFTP)

Mohamed

That helps explain why you need the source address to be different from the address of the outbound interface. I am glad that my suggestion did help you solve your issue. Thank you for using the rating system to indicate that your problem was solved (and thanks for the rating). It makes the forum more useful when people can read about a problem and can know that they will read a suggestion that did solve the problem.

HTH

Rick

587
Views
4
Helpful
3
Replies
CreatePlease to create content