Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Ip address dhcp

Hi, 

 

I have taken an internet account with an isp. The account is a dhcp account and I have to give username and password from webpage while connecting it through computer. Is it possible to connect the same link with cisco 1841 router. I got the ip address when I issue ip address dhcp on interface. How to pass username and password through this. 

 

Regards, 

 

Mero

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Mero You can pass the

Mero

 

You can pass the username by using the command ip address dhcp hostname. I am not sure of how to include the password. See this link for details

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr/command/ipaddr-cr-book/ipaddr-c1.html#wp3343120296

 

HTH

 

Rick

5 REPLIES
Hall of Fame Super Gold

Mero You can pass the

Mero

 

You can pass the username by using the command ip address dhcp hostname. I am not sure of how to include the password. See this link for details

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr/command/ipaddr-cr-book/ipaddr-c1.html#wp3343120296

 

HTH

 

Rick

Community Member

Hi, Have you try with this

Hi, 

Have you try with this command ???

username xxxxxx privilege 15 password xxxxxx

Community Member

Dear Feltinsilije,  This is

Dear Feltinsilije, 

 

This is for router login command. 

 

Regards, 

 

Mero

Community Member

I have  a 831 router use

I have  a 831 router use PPPoE. Please note that is a PPPoE seting.
!
interface Ethernet0
ip address (LAN IP ADD)
ip nat inside----> must in my case
!
!
interface Ethernet1
no ip address
ip nat outside

duplex auto
pppoe enable
pppoe-client dial-pool-number 1

no cdp enable
!
interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1

no cdp enable
ppp authentication chap pap callin callout
ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxx (may need, please ask your ISP)
ppp chap password 7 xxxxxxxxxxxxxxxxxxxx (may need, please ask your ISP)
ppp pap sent-username abc@singtel.com password 123456 ----> must in my case
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip nat inside source list nat_address interface Ethernet1 overload--->Must in my case
!

 

To see if u get IP debug ppp negotiation and debug ppp authentication .

Community Member

Dear Sir,  This is not a

Dear Sir, 

 

This is not a PPPoe Account 

 

Regards, 

 

Mero

58
Views
0
Helpful
5
Replies
CreatePlease to create content