Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

ip helper address

Hi,

I config the router with 5 vlan, the DHCP server is on vlan 1 (default vlan).

The DHCP server is MS 2000 server. I cannot get the ip address from vlan 2, 3, 4 and 5. If I put the client pc on vlan 1, I can get the ip address (172.16.1.0/24). anything I missing? It is related to IOS?

R1

!

interface FastEthernet0

no ip address

!

interface FastEthernet0.1

description Vlan 1

encapsulation dot1Q 1 native

ip address 172.16.1.10 255.255.255.0

ip helper-address 172.16.1.3

!

interface FastEthernet0.2

description Vlan 2

encapsulation dot1Q 2

ip address 172.16.2.10 255.255.255.0

ip helper-address 172.16.1.3

!

interface FastEthernet0.3

description Vlan 3

encapsulation dot1Q 3

ip address 172.16.3.10 255.255.255.0

ip helper-address 172.16.1.3

!

interface FastEthernet0.4

description Vlan 4

encapsulation dot1Q 4

ip address 172.16.4.10 255.255.255.0

ip helper-address 172.16.1.3

!

interface FastEthernet0.5

description Vlan 5

encapsulation dot1Q 5

ip address 172.16.5.10 255.255.255.0

ip helper-address 172.16.1.3

!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ip helper address

Hi,

Router config looks okay. Please post switch config. Also, try this including this command line in Fa0.2 to Fa0.5 "ip forward-protocol udp".

Make sure that DHCP server;

- Have a scope for 5 VLANs and activated

- Authorized.

- See http://www.windowsnetworking.com/articles_tutorials/w2kdhcpc.html

Following are DHCP Troubleshooting Links:

Client side http://technet2.microsoft.com/windowsserver/en/library/1cba3948-5605-4a19-89ef-8762cdcdc7ad1033.mspx?mfr=true

Server side http://technet2.microsoft.com/windowsserver/en/library/6350df25-a5d9-46e4-82c7-85d9141aa24f1033.mspx?mfr=true

Network side http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a00800f0804.shtml

Regards,

Dandy

4 REPLIES
Hall of Fame Super Bronze

Re: ip helper address

I'm assuming you've configured scopes in the DHCP server for each Vlan. What options did you enter under the scope ? One of the options must be the 'router' option (DHCP Option 003) which should be represented by the IP address of each Vlan.

For instance, for Vlan 5, the router option should be 172.16.5.10 under DHCP scope at the server.

BTW, you don't need an ip helper command under Vlan 1.

Re: ip helper address

In addition to Edison remarks, also check trunk on swithc side ensuring those vlans are indeed passed as well as corresponding vlan membership in switchports.

New Member

Re: ip helper address

Hi,

Router Config is ok. could you please post switch running-config ?

Re: ip helper address

Hi,

Router config looks okay. Please post switch config. Also, try this including this command line in Fa0.2 to Fa0.5 "ip forward-protocol udp".

Make sure that DHCP server;

- Have a scope for 5 VLANs and activated

- Authorized.

- See http://www.windowsnetworking.com/articles_tutorials/w2kdhcpc.html

Following are DHCP Troubleshooting Links:

Client side http://technet2.microsoft.com/windowsserver/en/library/1cba3948-5605-4a19-89ef-8762cdcdc7ad1033.mspx?mfr=true

Server side http://technet2.microsoft.com/windowsserver/en/library/6350df25-a5d9-46e4-82c7-85d9141aa24f1033.mspx?mfr=true

Network side http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a00800f0804.shtml

Regards,

Dandy

141
Views
8
Helpful
4
Replies
CreatePlease to create content