Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

ip load balance per-packet

Hi, Messrs!

I have 4 links of 2Mbps connecting two routers, I would like

to make load balance per packet, but it doesn't works well.

The inbound traffic is load balanced, but the

outbound traffic doesn't work well.

Below I send my cfg (the other router I don't have configuration).

What could be wrong?

!

!

ip cef

!

!

!

interface Serial0/0

description XXX-0

bandwidth 2048

ip address xxx.xxx.xxx.xx6 255.255.255.252

no ip redirects

no ip unreachables

ip nat outside

ip load-sharing per-packet

ip route-cache flow

no ip mroute-cache

load-interval 30

no fair-queue

no cdp enable

!

interface Serial0/1

description XXX-1

bandwidth 2048

ip address xxx.xxx.xxx.xx2 255.255.255.252

no ip redirects

no ip unreachables

ip nat outside

ip load-sharing per-packet

ip route-cache flow

no ip mroute-cache

load-interval 30

no fair-queue

no cdp enable

!

interface Serial0/2

description xxx-2

bandwidth 2048

ip address xxx.xxx.xxx.xx6 255.255.255.252

no ip redirects

no ip unreachables

ip nat outside

ip load-sharing per-packet

ip route-cache flow

no ip mroute-cache

load-interval 30

no fair-queue

no cdp enable

!

interface Serial0/3

description xxx-3

bandwidth 2048

ip address xxx.xxx.xxx.xx8 255.255.255.252

no ip redirects

no ip unreachables

ip nat outside

ip load-sharing per-packet

ip route-cache flow

no ip mroute-cache

load-interval 30

no fair-queue

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xx1

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xx5

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xx5

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xx7

thanks,

Renato

9 REPLIES
Purple

Re: ip load balance per-packet

Hi Renato,

Are you sure it's the inbound traffic that is load-balanced properly and not the outbound. It's just that with the config you have, the outbound traffic should be load-balanced in a per-packet manner but you would not have any control over inbound traffic if you don't own the other router you are connected to.

Unless you have specific arrangements in place, you can only influence the traffic that you yourself send out.. inbound traffic will come in through whatever mechanism is used by the router at the other end.

Hope that helps - pls rate the post if it does.

Paresh

Hall of Fame Super Gold

Re: ip load balance per-packet

Renato

Perhaps you can clarify some aspects of the addressing:

interface Serial0/0

ip address xxx.xxx.xxx.xx6 255.255.255.252

interface Serial0/1

ip address xxx.xxx.xxx.xx2 255.255.255.252

interface Serial0/2

ip address xxx.xxx.xxx.xx6 255.255.255.252

interface Serial0/3

ip address xxx.xxx.xxx.xx8 255.255.255.252

From this config it looks like serial0/0 and serial0/2 might be defining the same subnet. Perhaps you can clarify the addressing of the interfaces and the next hops of the static routes.

Perhaps there is an alternative that you might consider which is multilink. If you configure all four interfaces in a multilink bundle you will get the benefit of aggregate bandwidth, equal usage of the interfaces, and will not have the potential of out of order packets which per packet load balancing introduces.

HTH

Rick

Community Member

Re: ip load balance per-packet

Hi,

Try removing the command ip cef.

-Sai.

Community Member

Re: ip load balance per-packet

Hello,

Disabling CEF would cause the router to revert to a lesser switching algorithm.

The configuration presented looks correct for cef per packet load balancing.

Additional info can be found at:

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080430ac3.html#wp1046601

I agree with the previous posts. That the router will make the decision for load-balancing outbound traffic and you will have little (or no control) depending on the admistrative domain (admin control) of the router(s) on both sides. Also as previously mentioned you can investigate using MPPP to aggregate the bandwidth.

Hope this helps.

Regards,

James

Community Member

Re: ip load balance per-packet

Thank you a lot!

I will investigate about MPPP.

Bronze

Re: ip load balance per-packet

Hello,

looking at your initial configuration, and since you are NATting, you might want to try the following (assuming that you are overloading, and assuming that your internal address space is network 192.168.1.0/24, change that accordingly if your address space is different):

ip nat inside source route-map SERIAL0/1 interface serial0/1 overload

ip nat inside source route-map SERIAL0/2 interface serial0/2 overload

ip nat inside source route-map SERIAL0/3 interface serial0/3 overload

ip nat inside source route-map SERIAL0/4 interface serial0/4 overload

!

access-list 1 permit 192.168.1.0

!

route-map SERIAL0/1 permit 10

match ip address 1

match interface serial0/1

!

route-map SERIAL0/2 permit 10

match ip address 1

match interface Serial0/2

!

route-map SERIAL0/3 permit 10

match ip address 1

match interface Serial0/3

!

route-map SERIAL0/4 permit 10

match ip address 1

match interface Serial0/4

!

ip route 0.0.0.0 0.0.0.0 Serial0/1

ip route 0.0.0.0 0.0.0.0 Serial0/2

ip route 0.0.0.0 0.0.0.0 Serial0/3

ip route 0.0.0.0 0.0.0.0 Serial0/4

Regards,

Nethelper

Community Member

Re: ip load balance per-packet

I had the same problem...got it to work with ppp multilink:

!

interface Multilink1

ip address 172.20.1.5 255.255.255.252

fair-queue 256 256 0

ppp multilink

no ppp multilink fragmentation

multilink-group 1

!

!

interface Serial0/0

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

!

interface Serial0/1

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

Community Member

Re: ip load balance per-packet

But isn´t the config of mppp an issue where both ends need being configed?

So config the router for mppp doesn´t do any good (on the contrary) since the other end isn´t configed. And your lines will probably be in down mode.

-- Lars

Community Member

Re: ip load balance per-packet

Sorry, I left out that the other side has the same configuration except the Multilink1 interface has a different ip address.

170
Views
5
Helpful
9
Replies
CreatePlease to create content