Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP Precedence bit Setting

Hi,

I have the following configuration below:

access-list 100 permit udp any any range 16384 32767

access-list 100 permit tcp any any eq 1720

!

route-map classify_mark

match ip address 100

set ip precedence 5

!

interface Ethernet0/0

ip address 10.10.10.1 255.255.255.0

ip policy route-map classify_mark

!

Can I know what is the impact to the ip packet if I set the ip precedence to "5"? What does this mean? Does it mean that the ip packet will be labelled as "critical" by the network? What happen if I set the Ip precedence to "4"? Does it mean that the packet can be overrided during congestion interval?

4 REPLIES
Purple

Re: IP Precedence bit Setting

Hi,

There is no real impact to the treatment the packet gets downstream of this router unless the downstream routers are configured to recognise traffic marked precedence 5 and give it special service.

However, when designing QoS for a network, you will find that precedence 5 is used for real-time traffic. Routers within the network are configured to provide low-latency, low-jitter, low-loss service to such packets.

Within the Internet, for example, setting your precedence to 5 will get you nothing.

Precedence 4 is usually used for traffic such as streaming video and video conference. This type of traffic also needs special treatment within the network and so routers will be configured to provide this traffic a certain amount of "guaranteed" bandwidth.

By themselves, the precedence values don't much. It comes down to how you design your network to treat them. Whether an ip prec 4 packet is dropped in favour of an ip prec 5 packet is entirely up to configuration.

Hope that helps - pls rate the post if it does.

Regards,

Paresh

New Member

Re: IP Precedence bit Setting

First, to answer your question, IPP 5 is just a number. With IPP, it's a 3 bit value, so you get 0-7. Industry standards use IPP 5 for RTP voice, but you can define your policies as you wish.

If you are dealing with a service provider, it's best to find out how they expect packets to be marked. You wouldn't want your RTP voice queue to be marked IPP 1 if that were a less than best effort queue in the service provider's network.

In looking at your config I notice that you're looking to classify RTP voice traffic, and H.323 signalling, both as IPP 5. Following industry standards the RTP voice would be marked with IPP 5 and H.323 signalling as IPP 3. By classifying a 16k UDP port range, you run the risk of classifying non-voice traffic as IPP 5 with this configuration if the network is shared among ip phones and computers.

Also, is there a reason you are doing classification via a route map? Typically one would configure a policy map to classify and queue the traffic.

The QoS section of the SRND goes into best practices and designs in great detail:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_implementation_design_guide_chapter09186a0080447513.html#wp1043280

Re: IP Precedence bit Setting

Hello,

marking IP packets is usually done because of QoS. The underlying frame-work is DiffServ. The whole idea is to give some special treatment to some type of traffic. An example can be a bandwidth guarantee to HTTP on a specific interface.

The first part in QoS is: "Which traffic are you interested in?"

Now to treat traffic different the router has to recognize it. The description can be rather detailed, like "all HTTP traffic to and from www.cisco.com coming from my PC with IP 10.1.1.1".

Now you might understand that not every router can check with Gigabit throughput such detailed descriptions. Therefore a simple marking groups interessting IP packets into a specific class.

IP precedence serves this purpose.

The second part to QOS is "What to do with different traffic?".

Once a router is able to differentiate traffic, you have to tell the router what to do with it - called the service policy. Hence DiffServ, i.e. Differentiated Services. The performed actions range from "drop" (like Nimda, etc.) to rate limiting through policing and shaping, various queueing types and so on.

The third part to QoS is "Where to apply the service policy?"

In the final step the router needs to know where to apply the service policy, i.e. in which direction on which interface. NB you can have more than one policy, f.e. one for traffic coming from an ethernet interface, another for traffic sent through a Serial.

So marking alone is only a small portion of the whole picture. In case there is marking and you tell the router to ignore it, no special treatment will be applied. It really depends on the policy defined on the router, what will happen.

Hope this helps! PLease rate all posts.

Regards, Martin

Re: IP Precedence bit Setting

Hello Chris,

A book you might want to look at is called End-To-End QOS Network Design.

http://www.ciscopress.com/title/1587051761

It will explain the differences and give you explicit configurations that you can take and modify. One of the nice things is it covers the many different ways of doing QOS across the different switch types.

To do the same thing with a policy map as the route-map in your post here is what you would do.

access-list 100 permit udp any any range 16384 32767

access-list 101 permit tcp any any eq 1720

class-map match-any RTP-VOICE

match access-list 100

class-map match-any SIGNALLING-REMARK

match access-list 101

policy-map VOICE-REMARK

class RTP-VOICE

set precedence 5

class SIGNALLING-REMARK

set precedence 3

interface ethernet 0/0

service-policy input VOICE-REMARK

If you wanted to then act on your precedence values and actually set a policy outgoing to the wan for QOS here are the sample commands. This policy will match precedence 5 giveing it 128k of bandwith for the priority queue. The signalling will recieve 16k of bandwidth and everything else will be fair-queued. You can change the priority and bandwidth to percent of availble bandwith also.

class-map match-any VOICE

match precedence 5

class-map match-any SIGNALLING

match precedence 3

policy-map WAN-QOS

class VOICE

priority 128

class SIGNALLING

bandwidth 16

class class-default

fair-queue

interface s0/0

service-policy output WAN-QOS

Patrick

Please for the stat mongers in us please rate our posts to help our egos. :)

3961
Views
16
Helpful
4
Replies
CreatePlease login to create content