Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ip routing command not working when all fastethernet are shut

I have a 2811 router. Two WAN interfaces are UP in that router. When I check in "sh ip route" output, then I get the below mentioned output.

Router#sh ip route

Default gateway is not set

Host Gateway Last Use Total Uses Interface

ICMP redirect cache is empty

Router#

There is a default route configured already using ip route 0.0.0.0 0.0.0.0 command. But when I checked the configuration, I could see an entry "no ip routing". Kindly note that all my other interfaces including fast ethernet are administratively shutdown.

Now I enter the configuration mode & give "ip routing" command. The moment I gave this command, I lost the connectivity. (I have telneted to this router via one of the WAN interfaces).

But this is not happening when one of the fast ethernet interface is UP. I mean, I give "no shut" to one of the fast ethernet & then try "ip routing". Now I can see routes in "sh ip route" command.

Is this some kind of bug, or is there a logic like for a router to enable routing, atleast one of the ethernet interface should be UP.

9 REPLIES
Silver

Re: ip routing command not working when all fastethernet are shu

Hi

Can you post running-config of this router?

Hall of Fame Super Silver

Re: ip routing command not working when all fastethernet are shu

vinod

In general there is not any requirement that you must have at least one Ethernet interface up to enable ip routing. I agree with Jose that there must be something in the router config that is causing this behavior and if you post the router config we may be able to identify what it is. I wonder about the default route and how it is configured and whether this may be causing it. Or I have seen situations where a router had both a default route and a default-gateway configured. With "no ip routing" the default gateway would be used and with "ip routing" the default gateway would not be used and the default route would be used. Perhaps this is the situation in your configuration?

So please post the router config so that we may be able to help you to resolve this.

HTH

Rick

New Member

Re: ip routing command not working when all fastethernet are shu

Hi.. the router config is as below:

Router#sh run

Building configuration...

Current configuration : 2233 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$nUdH$/SfrWV4ybAzAUAHlCAQoF.

enable password

!

no aaa new-model

!

resource policy

!

ip subnet-zero

no ip routing

!

!

no ip cef

!

interface FastEthernet0/0

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

!

interface BRI0/0/0

no ip address

no ip route-cache

shutdown

isdn point-to-point-setup

!

interface BRI0/1/0

no ip address

no ip route-cache

shutdown

isdn point-to-point-setup

!

interface Serial0/2/0

description "To Cloud"

ip address 12.1.32.45 255.255.255.252

encapsulation ppp

no ip route-cache

!

interface Serial0/2/1

bandwidth 1984

no ip address

encapsulation ppp

no ip route-cache

clock rate 2000000

!

interface Serial1/0

description "Main"

ip address 10.10.56.89 255.255.255.252

no ip route-cache

!

interface Serial1/1

no ip address

no ip route-cache

shutdown

no dce-terminal-timing-enable

!

interface Serial1/2

no ip address

no ip route-cache

shutdown

no dce-terminal-timing-enable

!

interface Serial1/3

no ip address

no ip route-cache

shutdown

no dce-terminal-timing-enable

!

interface Serial1/4

no ip address

no ip route-cache

shutdown

no dce-terminal-timing-enable

!

interface Serial1/5

no ip address

no ip route-cache

shutdown

no dce-terminal-timing-enable

!

interface Serial1/6

no ip address

no ip route-cache

shutdown

no dce-terminal-timing-enable

!

interface Serial1/7

no ip address

no ip route-cache

shutdown

no dce-terminal-timing-enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 12.1.32.46

ip route 10.10.1.0 255.255.255.0 12.1.32.46

ip route 10.10.59.128 255.255.255.192 10.10.56.90

!

ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

password

login

!

scheduler allocate 20000 1000

!

end

Router#

--

vvinod.

Silver

Re: ip routing command not working when all fastethernet are shu

Hi Vinod ,

enable ip routing on the router as it is disbled on the router currently.

Thanks,

satish

New Member

Re: ip routing command not working when all fastethernet are shu

Hi

Your running config shows 'no ip routing' on it still. Is it your problem that it stays even after you do 'ip routing' ?

cheers

Hall of Fame Super Silver

Re: ip routing command not working when all fastethernet are shu

vinod

Thanks for posting the router config. Unfortunately I am still puzzled about your problem. The default route appears to be correctly configured and points out the first serial interface. When configured with "no ip routing" the router is acting as an IP host and will not use the default route. With ip routing enabled the router does use the default route.

When you were telnetted into the router what was the IP address that you were using? I wonder if your telnet was coming in on the second serial interface and when you enabled ip routing if the default route was sending the response packets out the first serial interface?

HTH

Rick

New Member

Re: ip routing command not working when all fastethernet are shu

Hi Rick

I was telneting to the IP: 12.1.32.45. Which is in the default route.

But I could not understand the point what difference it makes that the "ip routing" command works fine when i give "no shut" to my fa0/1?

--

vvinod.

Hall of Fame Super Silver

Re: ip routing command not working when all fastethernet are shu

vvinod

I also do not understand why no shut on fa0/1 would make a difference about ip routing. Can you post the output of show interface fa0/1, and of show ip interface fa0/1?

If you were telnetting to 12.1.32.45, were you on the 12.1.32.46 device?

HTH

Rick

New Member

Re: ip routing command not working when all fastethernet are shu

Hi Rick

I think this is some kind of a bug. Will try with a different router & revert back. the show interface outputs are as pasted below. Thanks for your support.

Router#sh int FastEthernet0/1

FastEthernet0/1 is up, line protocol is up

Hardware is MV96340 Ethernet, address is 0019.06db.b211 (bia 0019.06db.b211)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:09, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 6000 bits/sec, 10 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

246386 packets input, 24105370 bytes

Received 246386 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

7587 packets output, 783647 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Router#sh ip int FastEthernet0/1

FastEthernet0/1 is up, line protocol is up

Internet protocol processing disabled

Router#

--

vvinod.

2068
Views
0
Helpful
9
Replies