Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

IP routing scenario

I have location A and location B

Location A connects to Location B primaryily through a T1 connection.

Secondary is a Frame Relay connection.

Is there a way to route a specific server at Location A to three specific servers at Location B and route those three back to the server at Location A over the Frame Relay Connection and what is the risks

Server A sits in a Location A one subnet

Servers B1,B2,B3 sit is Location B's one subnet.

Thanks

8 REPLIES
Purple

Re: IP routing scenario

Hi,

Yes, you can achieve this using policy-based routing. There is no real risk with doing so - if the frame relay link goes down, the traffic will start going back over the T1 link.

Here's a sample config that you can use to achieve this:

Location A:

int fast0/0

ip address x.x.x.x y.y.y.y

ip policy route-map ToFR

!

int s1/0:1

description T1 link

...

!

int s2/0:1.16

description FR link

!

access-list 101 permit ip host host

access-list 101 permit ip host host

access-list 101 permit ip host host

!

route-map ToFR permit 10

match ip address 101

set interface s2/0:1.16

!

Location B:

int fast0/0

ip address x.x.x.x y.y.y.y

ip policy route-map ToFR

!

int s1/0:1

description T1 link

...

!

int s2/0:1.16

description FR link

!

access-list 101 permit ip host host

access-list 101 permit ip host host

access-list 101 permit ip host host

!

route-map ToFR permit 10

match ip address 101

set interface s2/0:1.16

!

Hope that helps - pls rate the post if it does.

Paresh

Community Member

Re: IP routing scenario

Thank you for replying

How would you do if the two connections are on seperate routers?

Thanks again

Tom

Bronze

Re: IP routing scenario

I don't know your topology but let's assume your server is forwards packets to a default gateway. The gateway router has the connections to your internet routers. In this scenario, PBR can be applied to the gateway router. The next hop address will be the internet router with the Frame Relay connection.

If you can please describe your topology I think that'd help.

Community Member

Re: IP routing scenario

Location A router 1 connects to Location router B router 1 via T1

Location A router 2 connects to Location router B router2 via Frame

Location A Lan subnet is 192.168.2.0 /24 GW is 192.168.2.1

Location B Lan subnet is 192.168.3.0 /24 GW is 192.168.3.1

Location A server 1 is 192.168.2.100

Location B server 1 is 192.168.3.100

Location B server 2 is 192.168.3.101

Location B server 3 is 192.168.3.102

Hope this helps

Tom

Community Member

Re: IP routing scenario

Location A router 2 ethernet is 192.168.2.2

Location B router 2 ethernet is 192.168.3.2

Thanks again

Tom

Bronze

Re: IP routing scenario

Are Location A and B router 1 the gateway 192.168.2.1 and 192.168.3.1 respectively? And if I understand you correctly router 1 and router 2 (at both sites) have IP connectivity via the LAN segment? Is router 2 connected directly to router 1 or is there a layer 2 device connecting both routers and the LAN segment?

If 192.168.2.1 and 192.168.3.1 are router 1 at location A and B apply PBR there. Configure your next hop ip as 192.168.2.2 for 2.1’ policy and 192.168.3.2 for 3.1’s policy.

Test first if you can.

Ryan

Community Member

Re: IP routing scenario

You are understand me. Router 1 an Router two connect via a Catalyst 4500 at both locations.

Thank you!

Purple

Re: IP routing scenario

Hi,

Here's a config that will achieve what you want:

Location A:

===========

Router 1:

---------

int fast0/0

ip address 192.168.2.1 255.255.255.0

ip policy route-map ToFR

!

int s1/0:1

description T1 link

...

!

access-list 101 permit ip host 192.168.2.100 host 192.168.3.100

access-list 101 permit ip host 192.168.2.100 host 192.168.3.101

access-list 101 permit ip host 192.168.2.100 host 192.168.3.102

!

route-map ToFR permit 10

match ip address 101

set ip next-hop 192.168.2.2

!

ip route 192.168.3.0 255.255.255.0 s1/0:1

Router 2:

---------

ip route 192.168.3.0 255.255.255.0

Location B:

===========

Router 1:

---------

int fast0/0

ip address 192.168.3.1 255.255.255.0

ip policy route-map ToFR

!

int s1/0:1

description T1 link

...

!

access-list 101 permit ip host 192.168.3.100 host 192.168.2.100

access-list 101 permit ip host 192.168.3.101 host 192.168.2.100

access-list 101 permit ip host 192.168.3.102 host 192.168.2.100

!

route-map ToFR permit 10

match ip address 101

set ip next-hop 192.168.3.2

!

ip route 192.168.2.0 255.255.255.0 s1/0:1

Router 2:

---------

ip route 192.168.2.0 255.255.255.0

Paresh

162
Views
17
Helpful
8
Replies
CreatePlease to create content