Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

IP SLA Monitor and HSRP

I'm using an IP SLA to control the state of my HSRP between 2 internet facing routers. I'm monitoring the reachability of a hop from one of my routers. The problem is that every once in a while the destination router will fail to respond to an ICMP ping causing my HSRP to switch even though the connection is still up. I would like be able to not have it switch unless there are multiple consecutive pings lost. Below is a sample of the IP SLA setup on my router.

ip sla monitor 1

type echo protocol ipIcmpEcho 192.168.100.254 source-ipaddr 192.168.100.253

request-data-size 1

tos 160

timeout 2000

threshold 2000

frequency 15

hours-of-statistics-kept 8

ip sla monitor schedule 1 life forever start-time now

track 1 rtr 1

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

standby 1 ip 192.168.1.254

standby 1 priority 200

standby 1 preempt delay minimum 60

standby 1 track 1

interface GigabitEthernet0/1

ip address 192.68.100.253 255.255.255.0

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 192.168.100.254 track 1

1 REPLY
Cisco Employee

Re: IP SLA Monitor and HSRP

Hi,

The tracking process will poll the IP SLA return code every 5s.

As you are sending a ping every 15s, one ping lost is enough to change the state to DOWN.

What you can do is to configure a down delay timer so the tracking process will start this timer once the IP SLA return code changed to KO but at the end of the timer if the IP SLA code returns OK again, there is no change.

AS1-PE2-6509(config)#track 1 rtr 1

AS1-PE2-6509(config-track)#delay down 40

With a delay of 40s, you must lost two consecutive pings to trigger the tracking state change from UP to DOWN.

HTH

Laurent.

3574
Views
5
Helpful
1
Replies
CreatePlease to create content