Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

IP SLAs-Using the ICMP Echo problem

I have 2 ISP connections I am using NAT for load balancing and fail over

here is a sample config:

interface FastEthernet0/1

description $ISP1-WAN$

ip dhcp client route track 123

ip address dhcp client-id FastEthernet0/1

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

interface FastEthernet0/0

description $ISP2-WAN$

ip dhcp client route track 345

ip address dhcp client-id FastEthernet0/0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

interface FastEthernet1/1

description $LAN$

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

track timer interface 5

!

track 123 rtr 1 reachability

delay down 15 up 10

!

track 345 rtr 2 reachability

delay down 15 up 10

 

!

ip nat inside source route-map ISP1 interface FastEthernet0/1 overload

ip nat inside source route-map ISP2 interface FastEthernet0/0 overload

!

access-list 110 permit ip 192.168.1.0 0.0.0.255 any

access-list 122 permit icmp 172.168.0.0 0.0.255.255 any echo

access-list 133 permit icmp 10.10.10.0 0.0.0.255 any echo

!

!route map for NAT

route-map ISP1 permit 10

match ip address 110

match interface FastEthernet0/1

route-map ISP2 permit 10

match ip address 110

match interface FastEthernet0/0

!

!route map for local traffic

route-map INTERNET-REACHABILITY permit 10

match ip address 122

set interface FastEthernet0/1

!

route-map INTERNET-REACHABILITY permit 20

match ip address 133

set interface FastEthernet0/0

!

ip local policy route-map INTERNET-REACHABILITY

!

up to this stage every thing is working fine, 2 default routes are present in the routing table, NAT is load balancing between the 2 connections and fail over is working and I can ping internet addresses using source interfaces fast0/0 and fast 0/1

#show ip route track-table
ip route 0.0.0.0 0.0.0.0 172.168.0.1 254 track 123 state is [up]
ip route 0.0.0.0 0.0.0.0 10.10.10.1 254 track 345 state is [up]

now the problem is when I add SLAs using ICMP echo config to track the ISP reachability to the internet the two objects goes down and the default routes removed from the thr routing table.

here is the config

ip sla monitor 1

type echo protocol ipIcmpEcho 66.102.11.104 source-interface FastEthernet0/1

timeout 1000

threshold 40

frequency 3

ip sla schedulw 1 life forever start-time not

ip sla monitor 2

type echo protocol ipIcmpEcho 66.102.11.104 source-interface FastEthernet0/0

timeout 1000

threshold 40

frequency 3

ip sla schedulw 2 life forever start-time not

  show ip route track-table
ip route 0.0.0.0 0.0.0.0 172.168.0.1 254 track 123 state is [down]
ip route 0.0.0.0 0.0.0.0 10.10.10.1 254 track 345 state is [down]

from debug

the router manages to send the packets out using the right interfaces but reply from google times out, tried different address including ISP gateways and dns servers with same results

I tried different timeout and frequency settings even at some stage i did not use the optional commands to setup timeout and freq and still same results, again once I remove the SLAs config i can ping using the interfaces f0/0 and f0/1 as source .

any help please please

1 REPLY
Community Member

Re: IP SLAs-Using the ICMP Echo problem

any body

884
Views
0
Helpful
1
Replies
CreatePlease to create content