Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ip summary address eigrp not sending summary route

Hi. I have the following problem. I have my internet router redistributing the default route via EIGRP with a redistribute static. (Neighbors learn it as an external of course). Then I have a remote site, to which I only wish to send a default route as a summary address in the tunnel interface, but it seems to be ignoring the summary route, and instead learns the redistributed route with an AD of 170. Do you have any idea about this? Why is it preffering the external route? No eigrp distances have been changed in the EIGRP process.

Local Site tunnel config

interface Tunnel1001
description *local site*
ip address 10.95.3.57 255.255.255.252
ip summary-address eigrp 1 0.0.0.0 0.0.0.0 250
tunnel source x.x.x.x
tunnel destination x.x.x.x

Remote Site tunnel config 

interface Tunnel1001
description *remote site
ip address 10.95.3.58 255.255.255.252
tunnel source x.x.x.x
tunnel destination x.x.x.x
end

Remote Site routing Table 

remote_site#SHOW IP ROUTE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.95.3.57 to network 0.0.0.0

*omited output*
D*EX 0.0.0.0/0 [170/1763328] via 10.95.3.57, 1d00h, Tunnel1001

Everyone's tags (1)
7 REPLIES
New Member

I think the AD (250) that u

I think the AD (250) that u given in the summary statement is the problem. Because it is higher than the AD 170 of external eigrp route.  Ther router will always consider lower AD as the preferable route.

Please let me know if this is correct or not.

Thanks

New Member

I don´t think that´s the

I don´t think that´s the problem. Cisco states about summary route: "anything summirized with ip summary-address eigrp AD is added with that AD into local table; and it is advertised as EIGRP 90". Thank you anyway!!! 

Hello,

Hello,

When you redistribute routes to the same autonomous system, EIGRP ignores Administrative distance. If you check your EIGRP routing topology on your remote site, you will find a default route probably with higher metric which is generated by IP summary.

sh ip eigrp topology (on remote site to check ip summary)

Hope it helps,

Masoud

New Member

You might have nailed it. Let

You might have nailed it. Let me check that out.

New Member

Why would you have a EIGRP

Why would you have a EIGRP summary statement if you have a default route pointing to the tunnel anyway??

New Member

Yes, I mean, it works, but I

Yes, I mean, it works, but I want to recieve the route from the local site, not from the redistributing source and it should have an internal EIGRP route, not the external that you see there. 

Bronze

Hello,I tried some model

Hello,
I tried some model situations and it seems that
ip summary-address... takes effect only if you summarize with smaller mask than original network.

For example:

if you have network 192.168.8.0/24 (redistributed via EIGRP) and you enter command:

ip summary-address eigrp 1 192.168.8.0 255.255.255.0 - this route stay as external.

But if you enter command:
ip summary-address eigrp 1 192.168.8.0 255.255.254.0
then this route will be as internal with AD = 90.

Problem is that you cannot use "smaller" mask with default route.

And next thing is that command:

ip summary-address ei 1 0.0.0.0 0.0.0.0 will summarize all networks (not only default route).

I think that it is good to have default route with biggest AD, because it should be used as last option.

463
Views
0
Helpful
7
Replies
CreatePlease to create content