Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

IP Tunnels

Hi,

I have a tunnel set up between two 2611 routers over a DSL connection using Zhone Paradyne modems, the problem is I cannot ping the destination tunnel address, I can ping the DSL internet address proving connectivity between the two. To further complicate matters I can ping a second tunnel address located somewhere else. I have tried using tunnnel mode ipip but this has not solved the problem. All ip routes are set up as required.

This is an extract from the config:

interface Tunnel2

description Residence link

ip address X.X.X.77 255.255.255.252

tunnel source Ethernet0/0

tunnel destination X.X.X.X

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route X.X.X.128 255.255.255.240 Tunnel2

Does anyone have any ideas please..? Thanks.

6 REPLIES
Hall of Fame Super Silver

Re: IP Tunnels

Hello Gurcharan,

if X.X.X.X tunnel 2 destination is an IP address taken from X.X.X.128 255.255.255.240 your configuration is not correct:

you can route over the tunnel everything expect the tunnel destination itself

else your config is fine

Hope to help

Giuseppe

New Member

Re: IP Tunnels

Hi Giuseppe,

thanks for your input, the tun2 destination address is not in the range you say, it's actually an internet IP starting 190.X.X.X as supplied to our DSL line by the ISP.

I should have made this clearer in my original Post.

The thing that puzzles me is that I can ping a tunnel address (there are 2 tunnels set up) back to the UK from this router and vice versa, but not the tunnel address that is between the two routers out in that country, not sure if it has anything to do with MTU size, but would not have thought so as otherwise it wouldn't be able to ping the other tunnel. Also GRE must be enabled on the Paradyne router as again it wouldn't have allowed ping to the one tunnel.

Gurch.

Hall of Fame Super Silver

Re: IP Tunnels

Hello Gurch,

mine was just a basic check.

Can you reach the destination prefix behind your tunnel ?

I have remote sites in our network where I cannot ping the tunnel GRE destination but I can reach the internal LAN ip address

Hope to help

Giuseppe

New Member

Re: IP Tunnels

Hi Giuseppe,

I can only reach the destination from the UK router, I cannot reach from either router at each end at either remote site, so therefore I cannot reach the internal LAN IP address.

If I could ping the internal LAN IP from each remote site to each other then my problem would be solved I think.

Thanks.

Gurch.

Re: IP Tunnels

Can you post a config?

HTH, John *** Please rate all useful posts ***
New Member

Re: IP Tunnels

Here you go, config as requested...

Current configuration : 1517 bytes

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Remote_One

!

logging rate-limit console 10 except errors

!

ip subnet-zero

!

!

no ip finger

!

no ip dhcp-client network-discovery

!

!

!

interface Tunnel1

description Home

ip address 10.204.18.82 255.255.255.252

tunnel source Ethernet0/0

tunnel destination 107.128.115.250

!

interface Tunnel2

description Remote_Two

ip address 10.204.18.77 255.255.255.252

tunnel source Ethernet0/0

tunnel destination 100.90.58.200

!

interface Ethernet0/0

ip address 192.168.1.3 255.255.255.0

half-duplex

!

interface Serial0/0

no ip address

shutdown

!

interface Ethernet0/1

ip address 10.101.100.120 255.255.255.248

half-duplex

!

interface Serial0/1

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 10.202.0.0 255.255.0.0 10.202.122.121

ip route 10.204.1.0 255.255.255.0 Tunnel1 permanent

ip route 10.204.130.120 255.255.255.240 Tunnel2

ip route 195.70.48.200 255.255.255.255 192.168.1.1

ip route 192.168.12.230 255.255.255.255 Tunnel1

ip route 107.128.115.250 255.255.255.255 192.168.1.1

no ip http server

!

!

line con 0

login local

transport input none

line aux 0

line vty 0 4

login local

line vty 5 15

login

!

no scheduler allocate

111
Views
0
Helpful
6
Replies
CreatePlease to create content