Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

IPv4 BGP Problem

1.png

Hello Guys,

Here is my network topology.

R1 and R2 are in the same AS which is 100. OSPF is configured as well as IBGP.

R4 and R6 are in the same AS which is 200. OSPF is configured as well as IBGP.

The problem is that I'm not able to ping from R2 to 1.0.0.1. It's reachable only toR6 serial.

Can any one please help.

R1 configuration

hostname R1

!

!

interface Serial1/1

ip address 10.0.0.50 255.255.255.252

ip nat inside

no sh

!

interface Serial1/0

ip address 1.0.0.37 255.255.255.252

ip nat outside

no sh

!

router ospf 1

network 10.0.0.48 0.0.0.3 area 0

!

router bgp 100

no synchronization

bgp log-neighbor-changes

neighbor 10.0.0.49 remote-as 100

neighbor 10.0.0.49 update-source Serial1/1

neighbor 10.0.0.49 next-hop-self

neighbor 1.0.0.38 remote-as 200

neighbor 1.0.0.38 ebgp-multihop 2

neighbor 1.0.0.38 update-source Serial1/0

no auto-summary

!


R2 configuration

hostname R2

!

!

interface fa2/0

ip address 10.0.0.1 255.255.255.240

no sh

interface Serial1/0

ip address 10.0.0.49 255.255.255.252

no sh

!

interface Serial1/1

ip address 10.0.0.53 255.255.255.252

no sh

!

router ospf 1

network 10.0.0.0 0.0.0.15 area 0

network 10.0.0.48 0.0.0.3 area 0

network 10.0.0.52 0.0.0.3 area 0

!

router bgp 100

neighbor 10.0.0.50 remote-as 100

neighbor 10.0.0.50 update-source s1/0

neighbor 10.0.0.50 next-hop-self

R4 configuration

hostname R4

!

!

interface fa2/0

ip address 1.0.0.17 255.255.255.240

no sh

interface Serial1/0

ip address 1.0.0.38 255.255.255.252

no sh

int s1/1

ip add          1.0.0.34 255.255.255.252

no sh

!

router ospf 1

network 1.0.0.16 0.0.0.15 area 1

network 1.0.0.32 0.0.0.3 area 1

!

router bgp 200

no synchronization

bgp log-neighbor-changes

neighbor 1.0.0.39 remote-as 100

neighbor 1.0.0.39 ebgp-multihop 2

neighbor 1.0.0.39 update-source Serial1/0

neighbor 1.0.0.33 remote-as 200

neighbor 1.0.0.33 update-source s1/0

neighbor 1.0.0.33 next-hop-self

redistribute connected

redistribute ospf

no auto-summary

!

R6 configuration

hostname R6

!

!

!

interface fa2/0

ip address 1.0.0.1 255.255.255.240

no sh

!

interface Serial1/0

ip address 1.0.0.33 255.255.255.252

no sh

!

router ospf 1

log-adjacency-changes

network 1.0.0.0 0.0.0.15 area 1

network 1.0.0.32 0.0.0.3 area 1

!

router bgp 200

neighbor 1.0.0.34 remote-as 200

neighbor 1.0.0.34 update-source Serial1/0

neighbor 1.0.0.34 next-hop-self


Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: IPv4 BGP Problem

No static route is needed as 1.0.0.0 is being advertised properly and is seen on R2 with correct next hop. All the networks are advertised and things should work. Lets us know by testing if ping is now successful.

Note: Other solution is Static route if configured on R1 (not on R2) and redistributed into bgp might work as well. Considering R4-R6 is not advertising it.

Thanks,

Nandan

10 REPLIES

IPv4 BGP Problem

Can you post your OSPF configurations and "sh ip bgp" from these routers?

HTH, John *** Please rate all useful posts ***

Re: IPv4 BGP Problem

Here they are.

New Member

Re: IPv4 BGP Problem

You didn't actually post any output.

Sent from Cisco Technical Support iPad App

Re: IPv4 BGP Problem

Looks like R2 has network 1.0.0.0/28 which it is redistributing. So It is getting preffered. Is there any loopback interface or physical interface on R2 which has network 1.0.0.0/28 and not shown in diagram?

check by "show ip route 1.0.0.0" on R2

So overall the thing is R1 is learning 1.0.0.0 from two BGP neighbors and R2 has this network sourced through redistribution and hence its not reaching the actual destination i.e R6 (locally sourced is preferred and it is only available bgp route )

Credits to John for asking relevant outputs

Thanks,

Nandan

IPv4 BGP Problem

Hi guys,

Here are the outputs again.

R1 OSPF/BGP

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.0.0.53         0   FULL/  -        00:00:34    10.0.0.49       Serial1/1

R1#sh ip bgp

BGP table version is 9, local router ID is 10.0.0.50

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 1.0.0.0/28       1.0.0.38                               0 200 i

*> 1.0.0.16/28      1.0.0.38                 0             0 200 ?

*> 1.0.0.32/30      1.0.0.38                 0             0 200 ?

r> 1.0.0.36/30      1.0.0.38                 0             0 200 ?

*> 10.0.0.0/28      10.0.0.49               65         32768 ?

*> 10.0.0.48/30     0.0.0.0                  0         32768 ?

**********************************************************************************

R2 OSPF/ BGP

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.0.0.50         0   FULL/  -        00:00:37    10.0.0.50       Serial1/0

R2#sh ip bgp

BGP table version is 11, local router ID is 10.0.0.53

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*>i1.0.0.0/28       10.0.0.50                0    100      0 200 i

*>i1.0.0.16/28      10.0.0.50                0    100      0 200 ?

*>i1.0.0.32/30      10.0.0.50                0    100      0 200 ?

*>i1.0.0.36/30      10.0.0.50                0    100      0 200 ?

r>i10.0.0.0/28      10.0.0.50               65    100      0 ?

r>i10.0.0.48/30     10.0.0.50                0    100      0 ?

************************************************************************************************

R4 OSPF / BGP

R4#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.0.0.33          0   FULL/  -        00:00:35    1.0.0.33        Serial1/1

R4#sh ip bgp

BGP table version is 10, local router ID is 1.0.0.38

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

r>i1.0.0.0/28       1.0.0.33                 0    100      0 i

*> 1.0.0.16/28      0.0.0.0                  0         32768 ?

*> 1.0.0.32/30      0.0.0.0                  0         32768 ?

*> 1.0.0.36/30      0.0.0.0                  0         32768 ?

*> 10.0.0.0/28      1.0.0.37                65             0 100 ?

*> 10.0.0.48/30     1.0.0.37                 0             0 100 ?

**************************************************************************************************

R6 OSPF/BGP

R6#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.0.0.38          0   FULL/  -        00:00:31    1.0.0.34        Serial1/0

R6#sh ip bgp

BGP table version is 11, local router ID is 1.0.0.33

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 1.0.0.0/28       0.0.0.0                  0         32768 i

r>i1.0.0.16/28      1.0.0.34                 0    100      0 ?

r>i1.0.0.32/30      1.0.0.34                 0    100      0 ?

*>i1.0.0.36/30      1.0.0.34                 0    100      0 ?

*>i10.0.0.0/28      1.0.0.34                65    100      0 100 ?

*>i10.0.0.48/30     1.0.0.34                 0    100      0 100 ?

================================

I don't have any loopbacks configured in my network and there isn't any connected network to R2 with network ID 1.0.0.0.0/28.

and here is the output of sh iproute 1.0.0.0 on R2

R2#sh ip route 1.0.0.0

Routing entry for 1.0.0.0/8, 4 known subnets

  Variably subnetted with 2 masks

  Redistributing via bgp 100

B       1.0.0.0/28 [200/0] via 10.0.0.50, 00:05:39

B       1.0.0.16/28 [200/0] via 10.0.0.50, 00:25:53

B       1.0.0.32/30 [200/0] via 10.0.0.50, 00:25:53

B       1.0.0.36/30 [200/0] via 10.0.0.50, 00:25:53

Re: IPv4 BGP Problem

In your previous output things looked different and now they changed

Previous Output:

Latest Output For  R2:

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.0.0.50         0   FULL/  -        00:00:37    10.0.0.50       Serial1/0

R2#sh ip bgp

BGP table version is 11, local router ID is 10.0.0.53

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

    Network          Next Hop            Metric LocPrf Weight Path

*>i1.0.0.0/28       10.0.0.50                0    100      0 200 i

*>i1.0.0.16/28      10.0.0.50                0    100      0 200 ?

*>i1.0.0.32/30      10.0.0.50                0    100      0 200 ?

*>i1.0.0.36/30      10.0.0.50                0    100      0 200 ?

r>i10.0.0.0/28      10.0.0.50               65    100      0 ?

r>i10.0.0.48/30     10.0.0.50                0    100      0 ?

---------------

Observe the next hop and bgp table version. Anyway my previous suggestion was based on first output that you gave.

Regards,

Nandan

IPv4 BGP Problem

I copied the configuration after I took out a statically configured route on R2 to 1.0.0.1 as I was trying to figure out the problem.

There is no need to have a static route, right?

Re: IPv4 BGP Problem

No static route is needed as 1.0.0.0 is being advertised properly and is seen on R2 with correct next hop. All the networks are advertised and things should work. Lets us know by testing if ping is now successful.

Note: Other solution is Static route if configured on R1 (not on R2) and redistributed into bgp might work as well. Considering R4-R6 is not advertising it.

Thanks,

Nandan

IPv4 BGP Problem

Can't believe it. It worked

Thank you guys your help is really appreciated!

Re: IPv4 BGP Problem

Thats good Jory

Thanks.

577
Views
0
Helpful
10
Replies