Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

IPV6 on BVI Interface: Not working

Setup: PC (2001:8B0:122E:F25B::2) <----> Router (1921) (Gi0/1    2001:8B0:122E:F25B::1)

Running: 15.2(4)M2

---- Working ----:

no ipv6 source-route

ipv6 unicast-routing

ipv6 multicast-routing

ipv6 cef

!

interface GigabitEthernet0/1

ipv6 address 2001:8B0:122E:F25B::1/64

ipv6 enable

!

With the above configuration, The PC can ping the switch.

But as soon as I change it to this:

no ipv6 source-route

ipv6 unicast-routing

ipv6 multicast-routing

ipv6 cef

!

interface GigabitEthernet0/1

  bridge-group 1

!

interface BVI1

ipv6 address 2001:8B0:122E:F25B::1/64

ipv6 enable

!

bridge 1 protocol ieee

bridge 1 route ip

!

Then it's broken. In this setup, some IPv6 is working, i.e. the PC can see router advertisments, but from looking at packet debug, it seems that the ICMPv6 neighbor solicitations do not make it to the BVI interface, hence it not working. But why? IPv6 has supposed to have been working on BVI interfaces for quite some time now...

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: IPV6 on BVI Interface: Not working

Hi Matthew,

I am glad to hear it works now. I think you should discuss with your Cisco account team and make them aware of the situation. They will be able to help you with the licencing issue given that the datak9 technology package is only required for the work around.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
12 REPLIES
Cisco Employee

IPV6 on BVI Interface: Not working

Hi Matthew,

IPv6 should indeed be supported on a BVI interface in this version. I found a bug that could be a match for the behavior you are seeing. Could you post the output of a "show ver" for this 1921.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

IPV6 on BVI Interface: Not working

Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.2(4)M2, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2012 by Cisco Systems, Inc.

Compiled Wed 07-Nov-12 12:45 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M12, RELEASE SOFTWARE (fc1)

Edge uptime is 19 hours, 16 minutes

System returned to ROM by reload at 10:08:32 UTC Sat Aug 10 2013

System image file is "flash:c1900-universalk9-mz.SPA.152-4.M2.bin"

Last reload type: Normal Reload

Last reload reason: Reload Command

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco CISCO1921/K9 (revision 1.0) with 487424K/36864K bytes of memory.

Processor board ID

1 DSL controller

1 Ethernet interface

6 Gigabit Ethernet interfaces

1 ATM interface

1 terminal line

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity disabled.

255K bytes of non-volatile configuration memory.

250864K bytes of USB Flash usbflash0 (Read/Write)

License Info:

License UDI:

-------------------------------------------------

Device#   PID                   SN

-------------------------------------------------

*0        CISCO1921/K9         

Technology Package License Information for Module:'c1900'

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

              Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      securityk9    Permanent      securityk9

data          None          None           None

Configuration register is 0x2102

Cisco Employee

Re: IPV6 on BVI Interface: Not working

Hi Matthew,

It appears that you came across CSCtl43156. You can load the datak9 technology package as a workaround. Can you run the following command then reload the box and see if it fixes the issue.

license boot module c3900 technology-package datak9

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

IPV6 on BVI Interface: Not working

Just looking at that bug

A) It says that it's only present _when_ the data package is running (which mine isn't)

B) It also says fixed in releases which are all older than ones I've tried and seen the issue on

C) This is really not a router I want to go rebooting unless I absolutely know I have to -

You sure about that?

Cisco Employee

IPV6 on BVI Interface: Not working

Hi Matthew,

This is not a sure shot indeed. I have seen a TAC case though, where the issue is the same you are seeing and it got solved using the suggested workaround. I unfortunately do not have the required setup to test it at the moment.

I have not found any other obvious bugid explaining why ipv6 does not work for you on the BVI interface.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

IPV6 on BVI Interface: Not working

Tried that and tried upgrading to 15.2(4)M4

It appears that IPv6 on BVI remains broke.

Probably time to escalate to customer support...

Cisco Employee

IPV6 on BVI Interface: Not working

Hi Matthew,

Could you post another "show ver" and the entire config if possible.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: IPV6 on BVI Interface: Not working

Config posted below

Community Member

Re: IPV6 on BVI Interface: Not working

The original configuration is more than 1000 lines long (and confidential) so I won't be posting that here

However I have just taken it out of service so I can deal with this issue so can now post a default config with the BVI on IPv6, which is:

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash:c1900-universalk9-mz.SPA.152-4.M4.bin

boot-end-marker

!

!

!

no aaa new-model

!

ip cef

!

!

!

!

!

!

ipv6 unicast-routing

ipv6 cef

!

multilink bundle-name authenticated

!

!

!

license udi pid CISCO1921/K9 sn

!

!

vtp mode transparent

!

redundancy

!

!

!

!

!

controller VDSL 0/0/0

!

vlan 2-9

!

!

!

!

!

!

bridge irb

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

bridge-group 1

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

shutdown

no atm ilmi-keepalive

!

interface Ethernet0/0/0

no ip address

shutdown

!

interface GigabitEthernet0/1/0

no ip address

!

interface GigabitEthernet0/1/1

no ip address

!

interface GigabitEthernet0/1/2

no ip address

!

interface GigabitEthernet0/1/3

no ip address

!

interface Vlan1

no ip address

!

interface BVI1

no ip address

ipv6 address 2001:8B0:122E:F25B::1/64

ipv6 enable

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

!

end

Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.2(4)M4, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Thu 20-Jun-13 12:49 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M12, RELEASE SOFTWARE (fc1)

Router uptime is 3 minutes

System returned to ROM by reload at 12:43:24 UTC Sun Aug 18 2013

System image file is "flash:c1900-universalk9-mz.SPA.152-4.M4.bin"

Last reload type: Normal Reload

Last reload reason: Reload Command

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco CISCO1921/K9 (revision 1.0) with 487424K/36864K bytes of memory.

Processor board ID

1 DSL controller

1 Ethernet interface

6 Gigabit Ethernet interfaces

1 ATM interface

1 terminal line

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity disabled.

255K bytes of non-volatile configuration memory.

250864K bytes of USB Flash usbflash0 (Read/Write)

License Info:

License UDI:

-------------------------------------------------

Device#   PID                   SN

-------------------------------------------------

*0        CISCO1921/K9         

Technology Package License Information for Module:'c1900'

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

              Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      securityk9    Permanent      securityk9

data          None          None           None

Configuration register is 0x2102

With the above configuration/version: Same behavoir: as soon as IPv6 is moved to the BVI, it ceases to function. Packets egress from the BVI, but no ingress.

Cisco Employee

Re: IPV6 on BVI Interface: Not working

Hi Matthew,

The "show ver" output still indicates that datak9 is not active. Could you please activate it with the following command, reload the router and retry the ipv6 ping.

Router> enable
Router# configure terminal Router(config)# license boot module c1900 technology-package datak9

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: IPV6 on BVI Interface: Not working

Okay, now it works.

So where does that leave me? depending on a licence pack I don't own to make this work?

Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.2(4)M4, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Thu 20-Jun-13 12:49 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M12, RELEASE SOFTWARE (fc1)

Router uptime is 2 minutes

System returned to ROM by reload at 13:19:21 UTC Sun Aug 18 2013

System image file is "flash:c1900-universalk9-mz.SPA.152-4.M4.bin"

Last reload type: Normal Reload

Last reload reason: Reload Command

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco CISCO1921/K9 (revision 1.0) with 487424K/36864K bytes of memory.

Processor board ID

1 DSL controller

1 Ethernet interface

6 Gigabit Ethernet interfaces

1 ATM interface

1 terminal line

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity disabled.

255K bytes of non-volatile configuration memory.

250864K bytes of USB Flash usbflash0 (Read/Write)

License Info:

License UDI:

-------------------------------------------------

Device#   PID                   SN

-------------------------------------------------

*0        CISCO1921/K9         

Technology Package License Information for Module:'c1900'

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

              Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      securityk9    Permanent      securityk9

data          datak9        EvalRightToUse datak9

Configuration register is 0x2102

Cisco Employee

Re: IPV6 on BVI Interface: Not working

Hi Matthew,

I am glad to hear it works now. I think you should discuss with your Cisco account team and make them aware of the situation. They will be able to help you with the licencing issue given that the datak9 technology package is only required for the work around.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
656
Views
0
Helpful
12
Replies
CreatePlease to create content